zlp1992
2015-11-19 09:13
采纳率: 33.3%
浏览 2.1k

centos 两个python版本导致无法import lxml

在centos服务器上,将默认的2.6版本的python升级为2.7.3版本的,并设置2.7.3为默认的,使用sudo yum install python-lxml安装lxml时
提示如下:
图片说明
但当我在默认的升级后的python2.7.3里import lxml时出错了,如下
图片说明
当我使用旧的python版本2.6来import lxml时却有用,如下
图片说明
也就是说我安装的lxml在旧版的python上有用,在升级替换后的新版的python没用,
但是我的lxml是我在升级python后安装的,使用python命令也可以看到默认的python
使用的是我新安装的版本,请问如何解决呢?谢谢。

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • zlp1992 2015-11-25 01:00
    已采纳

    问题已经解决,应该是缺少了包,我安装完包 libxml2-devel.i686,再源码安装lxml后,两个版本的python都可以 import lxml,具体见stackoverflow :
    http://stackoverflow.com/questions/33819268/import-lxml-failed-on-centos-release-6-7-final?noredirect=1#comment55510455_33819268

    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • oyljerry 2015-11-19 11:20

    你用yum源安装方式,系统还是认的2.6
    你可以下载lxml的包下来,然后用2.7的python安装就可以了

    评论
    解决 无用
    打赏 举报
  • zlp1992 2015-11-20 02:48

    @oyljerry,因为回复不好贴图,就在下面回复了:
    一开始我使用pip安装,如下
    直接使用sudo pip install lxml,报错如下:
    图片说明
    于是改为:sudo /usr/local/bin/pip install lxml,报错如下:
    图片说明
    看这意思是我的libxml2没安装,但是我查看libxml2是安装了的,如下:
    图片说明
    查看安装的其他环境
    图片说明
    可以看到所需环境应该是都已经安装了的。
    于是我从源码安装lxml,根据它的安装文档
    cd lxml-3.4.4
    sudo python setup.py build,报错如下
    图片说明
    网上搜索安装:
    yum install libxslt-devel
    图片说明
    说明我之前已经安装了libxslt-devel,检查其他环境如下:
    图片说明

    再次运行 sudo yum python setup.py build,还是报之前一样的错误
    请问,该怎么解决呢?

    评论
    解决 无用
    打赏 举报
  • 水的只能学 2015-11-21 11:41

    卸载吊一个,这样就可以了

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题