lwjjiayou 2015-11-29 06:29 采纳率: 0%
浏览 1712

C语言 这个问题我写的代码为什么没有输出

Description

The killer Matengss got a new mission to assassinate an evil cat. Matengss needs to be well prepared to win the battle. Now, there are several weapons and Matengss can pick any of them. Each weapon has an ability value. The power of Matengss is sum of the weapons' ability values which he took away. We will tell you the ability value of each weapon. Please calculate the max power that Matengss can get.

Input

The first line contains an integer T ( T < 20) indicating the number of test cases.
Each test case begins with a integer n(n<=1000), means there are n weapons that matengss can choose. The next line contains the values of those weapons ai(|ai|<1000) separated by the space.

Output

Print the max power the matengss can achieve in a single line.

Sample Input
2
3
1 2 3
5
0 0 1 0 4

Sample Output
6
5
我的代码
#include "stdio.h"

int main()
{
int T,n,i,j,a,b,h,sum=0;
while( scanf("%d",&T)!=EOF)
{
for( i=1; i<=T; i++ )//控制多少数据
{
while(scanf("%d",&a)!=EOF)//魅族数据个数
{
for( b=1;b<=a; b++)
{
while( scanf("%d",&h)!=EOF)
{
sum+=h;
}
}
}
printf("%d\n",sum);
sum=0;

    }

}
return 0;

}

  • 写回答

1条回答 默认 最新

  • JinJie_Zhang 2015-11-29 06:51
    关注

    Ctrl+z,输入结束

    评论

报告相同问题?

悬赏问题

  • ¥15 基于卷积神经网络的声纹识别
  • ¥15 Python中的request,如何使用ssr节点,通过代理requests网页。本人在泰国,需要用大陆ip才能玩网页游戏,合法合规。
  • ¥100 为什么这个恒流源电路不能恒流?
  • ¥15 有偿求跨组件数据流路径图
  • ¥15 写一个方法checkPerson,入参实体类Person,出参布尔值
  • ¥15 我想咨询一下路面纹理三维点云数据处理的一些问题,上传的坐标文件里是怎么对无序点进行编号的,以及xy坐标在处理的时候是进行整体模型分片处理的吗
  • ¥15 CSAPPattacklab
  • ¥15 一直显示正在等待HID—ISP
  • ¥15 Python turtle 画图
  • ¥15 stm32开发clion时遇到的编译问题