2 u010089114 u010089114 于 2016.01.18 13:02 提问

java向mySql插入数据乱码

图片说明
为什么我执行以下命令行后暂时成功改成了utf8,但是退出mysql后重新进入又变成gbk编码了呢
mysql> SET character_set_client = utf8;

mysql> SET character_set_results = utf8;

mysql> SET character_set_connection = utf8;

7个回答

meng20166
meng20166   Rxr 2016.01.18 13:41
已采纳

你要在my.ini需要修改两处
default-character-set=utf8
character-set-server=utf8
而且修改后还需要重启mysql的服务

meng20166
meng20166 直接把latin1改成utf8保存
2 年多之前 回复
u010089114
u010089114 只是character_set_server还是latin1怎么改成UTF8
2 年多之前 回复
u010089114
u010089114 你好,已经改了,还是乱码
2 年多之前 回复
oyljerry
oyljerry   Ds   Rxr 2016.01.18 13:33

这个只是改了当前的命令行状态, 你可以到my.ini配置文件中修改

wojiushiwo945you
wojiushiwo945you   Ds   Rxr 2016.01.18 13:38

命令行修改的参数只对当前连接生效,退出后就还原了。若要永久修改某些配置,需要修改mysql的配置文件my.ini。
找到mysql的安装路径下这个文件,修改你需要更改的配置项,重启试试。

meng20166
meng20166   Rxr 2016.01.18 13:42

mi.ini文件在你的mysql安装路径下

rainsponsor
rainsponsor   2016.01.18 14:17

确保项目编码UTF-8,数据库编码UTF-8(通过命令设置以及更改my.ini文件中默认的编码格式),项目访问数据库的地址后面最好加入characterEncoding操作,指定为UTF-8

Royal_lr
Royal_lr   Ds   Rxr 2016.01.18 14:18

改一下配置文件就行了

xionglangs
xionglangs   Rxr 2016.01.18 14:19
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
java程序想mysql数据库插入数据乱码解决方法()
在eclipse  mysql数据库编码全调成utf-8的编码后还是乱码,怎么办? 解决办法   在jdbc连接url     jdbc:mysql://localhost:3306/mav?useUnicode=true&characterEncoding=UTF-8    ps:UTF-8只能这么写插入的数据才不会是乱码  例如utf-8 utf8   都是不行的    已验证。
关于java插入到mysql数据库出现乱码
1、关闭MySql服务 2、在Mysql的安装目录下,在my.ini中添加红色部分: [client] default-character-set=utf8 port=3306 [mysql] default-character-set=utf8 # SERVER SECTION # -----------------------------------------
JDBC-Java程序向mysql中插入数据的中文乱码
Java程序向mysql中插入数据的中文乱码现象: 用JDBC将中文字段插入MySQL数据库中,然后打开表发现,那些字段都是”??”,或者是乱码. 原因: 1.由于创建数据库时指定默认的编码方式为utf8。 2.Client端字符集为gbk. 3.进行jdbc链接时使用了不匹配的字符集。 解决办法: 1.创建数据
java web mysql数据库插入数据乱码问题解决方法
1打开mysql控制台 2输入密码登录 3依次输入如下命令:  SET character_set_client = utf8 ;   SET character_set_connection = utf8 ;    SET character_set_database = utf8 ;    SET character_set_results = utf8 ;     SET ch
java jdbc 链接mysql插入数据中文显示乱码
java jdbc 链接mysql插入数据中文显示乱码,自己在解决过程中的解决方案,以及自己遇到的一些问题,之前一直记再云笔记上,和大家分享出来。
解决Java程序向mysql数据库插入中文乱码问题的多种方式
方式一:设置编码统一1.设置eclipse环境编码2.设置mysql环境编码mydb为需要修改的数据库名称 方式二:创建数据库时设置编码1.mysql创建database时设置编码create database mydb default character set utf8 collate utf8_general_ci;2.创建表时设置编码CREATE TABLE `type` ( `id` i
Myeclipse向Mysql中插入数据乱码问题
解决的思路就是把 Myeclipse和Mysql字符集都改为utf8如果你是 安装版的mysql 可以到my.ini中把默认字符集改为utf-8,有两个;免安装版(安装版也可以)的就在navicat中改(选中数据库,右键数据库属性)可以在cmd下进入mysql使用数据库,用命令show variables like 'character%';client为客户端使用的字符集。connection为...
eclipse插入数据到mysql中的乱码问题解决
一、设置MyEclipse的字符编码,步骤如下: 1、进入Window--Preferences--General--Workspace,Text file encoding 选项中默认的Default(GBK)选项更改为Other,并将值设为utf-8; 2、进入Window--Preferences--MyEclipse--Files and Editors,将这个选项下面的:AS
spring框架中mysql插入中文乱码
问题很奇怪,Intellij IDEA的编码是UTF-8,mysql的编码也都是UTF-8,在执行新增操作时,console打出来的sql显示的也是中文,但是数据插入后,字段里面中文都是??,网上找了很多资料,都没能解决,因为用的是spring boot,配置文件就只有pom.xml和application.properties,再一检查,发现是连接数据的url掉了编码参数。 只需要在datas
向mysql插入数据显示乱码的问题
向mysql数据库插入数据显示乱码的问题 在做一个java web工程时,有时会碰到在向数据库添加数据库时,结果出现乱码”???“的问题。针对该问题的主要解决办法有几种: 第一:确保是否添加了字符集过滤器 在项目的web.xml里,添加以下代码解决乱码: filter> filter-name>encodingFilterfilter-name> fil