2 sinat 33833083 sinat_33833083 于 2016.01.23 20:29 提问

跪求!!ACCESS数据库写入无法找到相应行!

代码如图所示

3个回答

caozhy
caozhy   Ds   Rxr 2016.01.23 20:34

你怎么知道这个表有111行。

caozhy
caozhy   Ds   Rxr 2016.01.23 20:35

你的i从哪里来的。

caozhy
caozhy 回复sinat_33833083: 你要先插入,然后才能修改。
2 年多之前 回复
sinat_33833083
sinat_33833083 还有就是table类我会用,但我不知道怎么写入数据库
2 年多之前 回复
sinat_33833083
sinat_33833083 是这样的,我数据库学的不好,我这个程序的目的是将一些列数据制成一张表写入数据库,我用一个i代表要加入的行数,然后每次Adapter写入数据库
2 年多之前 回复
enpterexpress
enpterexpress   Rxr 2016.01.23 20:47

取数据取成固定的行了

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
IIS发布站点Access数据库不能写
1、.Net Framework 2.0中,共享池采用经典模式,在.Net Framework 2.0中,共享池采用集成模式。 2、在共享池高级设置中将“启用32位应用程序”属性值设置为true。 3、在数据库文件夹中,将IUSR_***权限设置为允许修改,写入。将数据库文件属性栏将“只读”前的“√”点掉即可。  4、在上传文件夹中,将IUSR_***权限设置为允许修改,写入。
asp+access数据库写入问题
机房重装了系统,一切搞定后,发现以前做的ASP网站不能对数据库进行写入操作了,连接正常,能顺利读取数据库中的数据并显示,但就是修改不了 ,令我很是郁闷开始认为是IIS的问题,于是查看了了网站目录属性,发现果然没有打开写入权限,于是打开写入权限,令人郁闷的是竟然还不好用~~~~因为重装系统后,分区改成了NTFS格式,于是想可能是NTFS的安全问题,记得NTFS分区的文件夹属性里有一个 安全 选项卡,
"软件包 opera-stable 需要重新安装,但是我无法找到相应的安装文件 " 解决办法
以前一时需要安装了Opera浏览器,下载的是deb文件,在Ubuntu上面安装万之后浏览器是可以用了,但是在用命令安装其他软件的时候老是提示我以下: 软件包 opera-stable 需要重新安装,但是我无法找到相应的安装文件 无奈什么都做不了,于是从网上 找到了一个解决办法,办法是用于其他软件的,我改了一下,发现可以有效的解决问题,下面就是所用的办法: sudo dpkg --remove
C# 读取写入数据到ACCESS数据库基于FRAMEWORK2.0
using System; using System.Collections.Generic; using System.Configuration; using System.IO; using System.Net; using System.Text; using System.Web; using System.Web.UI; using System.Web.UI.WebControls
E: 软件包 astah-professional 需要重新安装,但是我无法找到相应的安装文件。
apt install vim 正在读取软件包列表... 完成 正在分析软件包的依赖关系树        正在读取状态信息... 完成        E: 软件包 astah-professional 需要重新安装,但是我无法找到相应的安装文件。 又宕在这里 这样apt就不能用了呀!能不能不让它管这个软件的事了,然后照常工作,不能因为这个错误影响到全局阿! 但是事实上我已经安
E: 软件包 atom 需要重新安装,但是我无法找到相应的安装文件。
ubuntu安装atom官方下载的安装包时,电脑有点卡 我给强制关闭了,估计安装到一半了,然后重启打开软件管理中心,各种退!sudo apt-get check然后报错 E: 软件包 atom 需要重新安装,但是我无法找到相应的安装文件。各种autoremove、 remove 、purge都不行然后sudo dpkg --remove --force-remove-reinstreq atom搞定
apt-get E:软件包 xxx 需要重新安装,但是我无法找到对应的安装文件 解决方法
系统:Ubuntu 14.04问题:执行 sudo apt-get install libffi-dev 失败,提示 E:软件包 xxx 需要重新安装,但是我无法找到对应的安装文件问题如下:执行 sudo apt-get update 也失败。解决方法:sudo dpkg --remove --force-remove-reinstreq 提示的包sudo apt-get upgrade 正常执行...
如何提取access数据库中符合特定条件的记录
详细情况如下:  dormitory表中Dor_num字段有如下的记录1y1041y10312612123121851013316182101y404136021第九栋1021第九栋103这些记录是唯一的,第一个数字代表校区,最后三个数字代表宿舍号,其余的代表栋别,怎么提取栋别使它不会重复显示在下拉列表中!用asp是怎么做到的?          sqld="SELECT distinct M
win7运行ACCESS数据库不能读写
进我的电脑c盘windows,在TEMP文件件上单击右键选择-属性,点击“安全”选项,添加一个everyone,权限设置为完全控制便可以了.但是有同学在属性里看不见安全选项.解决方法如下:
软件包 xxx需要重新安装,但是我(apt)无法找到相应的安装文件的解决办法
系统Debian lenny 错误信息如下: E: 软件包 adobe-flashplugin 需要重新安装,但是我无法找到相应的安装文件。 我不是问怎么安装adobe-flashplugin的,只是想问下,怎么别让apt包管理程序宕在这里,不干事情了。 例如: arnk@debian4arnk:~/bak$ sudo apt-get upgrade 正在读取软件包列表... 完成