swallowing_
humeng_s
2016-02-18 02:51

在CentOS6.5 32位下安装PyQt4编译出错

  • python
  • pyqt
  • centos

在CentOS6.5 32位下安装PyQt4
已经安装了sip和Qt4;
下载了PyQt4源码包,进入目录,输入 python configuer.py -k --qmake /usr/lib/qt4/bin,配置通过,没有报错,接下来输入make编译,报错如下:

/usr/local/lib/python2.7/PyQt-x11-gpl-4.11.4/QtGui/sipQtGuiQAbstractPrintDialog.cpp:1776: 错误:‘PrintCurrentPage’不是‘QAbstractPrintDialog’的成员
/usr/local/lib/python2.7/PyQt-x11-gpl-4.11.4/QtGui/sipQtGuiQAbstractPrintDialog.cpp:1782: 错误:‘sipEnumMemberDef’的初始值设定项太多
make[1]: *** [sipQtGuiQAbstractPrintDialog.o] 错误 1
make[1]: Leaving directory `/usr/local/lib/python2.7/PyQt-x11-gpl-4.11.4/QtGui'
make: *** [all] 错误 2

请问各路大神,这是怎么回事,弄了好久也编译不过,求解决方法,感激不尽!
更多 0

  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

3条回答