2 u010668910 u010668910 于 2016.02.24 18:53 提问

Installation error: INSTALL_FAILED_OLDER_SDK

在eclipse(Mars.1 Release (4.5.1))运行andriod项目,一直提示这个错误信息

[2016-02-24 18:40:04 - MainActivity] Installation error: INSTALL_FAILED_OLDER_SDK
[2016-02-24 18:40:04 - MainActivity] Please check logcat output for more details.
[2016-02-24 18:40:05 - MainActivity] Launch canceled!

注释了"uses-sdk android:minSdkVersion="4" "这行代码,也还是提示同样的错误信息

8个回答

VNanyesheshou
VNanyesheshou   2016.02.24 20:05

把4改成8试试,应该是最小版本太低了。

u010668910
u010668910 回复VNanyelieshou: 已经贴出图片了,烦请看看
2 年多之前 回复
u010668910
u010668910 私信不能超过200字
2 年多之前 回复
VNanyesheshou
VNanyesheshou 回复mike陈: 私信看看能发过来不,我给你看看
2 年多之前 回复
u010668910
u010668910 下面贴出了project.properties文件信息,但是AndroidManifest文件暂时好像贴不出来,再想想办法
2 年多之前 回复
u010668910
u010668910 <?xml version='1.0' encoding='utf-8'?>
2 年多之前 回复
VNanyesheshou
VNanyesheshou 把你的AndroidManifest文件和project.properties文件贴出来,
2 年多之前 回复
u010668910
u010668910 改成8还是报一样的错误。
2 年多之前 回复
u011249920
u011249920   2016.02.25 10:48

SDK版本太低,更新个新点的试试

u010668910
u010668910 是呀是呀,想换个思路,却又没有。
2 年多之前 回复
u011249920
u011249920 6666666666666666 不知道咋办了,大不了重装
2 年多之前 回复
u010668910
u010668910 1.删除bin/res,project重新clean之后,还是一样2.之前已经注释了<uses-sdk android:minSDKVersion="4" />这段再跑,也是如此,API已经是5.0.1
2 年多之前 回复
u011249920
u011249920 试试 1.删除bin/res 2.删除AndroidManifest.xml中<uses-sdk android:minSDKVersion="4" /> 3.新建一个API Level更高的AVD 4.重新编译运行
2 年多之前 回复
u010668910
u010668910 回复Queen_hz: 可以,之前可以运行一个sdk版本的支付demo,没有问题
2 年多之前 回复
u011249920
u011249920 eclipse中以前能运行android项目吗
2 年多之前 回复
u010668910
u010668910 更新至sdk21,还是一样的有问题
2 年多之前 回复
u010668910
u010668910   2016.02.25 14:14

<?xml version='1.0' encoding='utf-8'?>















This file is automatically generated by Android Tools.

Do not modify this file -- YOUR CHANGES WILL BE ERASED!

#

This file must be checked in Version Control Systems.

#

To customize properties used by the Ant build system edit

"ant.properties", and override values to adapt the script to your

project structure.

#

To enable ProGuard to shrink and obfuscate your code, uncomment this (available properties: sdk.dir, user.home):

#proguard.config=${sdk.dir}/tools/proguard/proguard-android.txt:proguard-project.txt

Project target.

target=android-21
android.library.reference.1=CordovaLib

u010668910
u010668910   2016.02.25 14:15

<?xml version='1.0' encoding='utf-8'?>















u010668910
u010668910   2016.02.25 14:16

屏蔽< >符号????

u010668910
u010668910   2016.02.25 14:17

<?xml version='1.0' encoding='utf-8'?>















u010668910
u010668910   2016.02.25 16:24

图片说明

VNanyesheshou
VNanyesheshou   2016.02.25 17:03

<activity android:name=""
activity名字设置一下,试试,其他的真看不出来有什么问题了。

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
android studio使用中碰到Failure [INSTALL_FAILED_OLDER_SDK] 问题
最近看好多人在使用Android studio开发工具、这个是google2013年开发者大会上公布的新的Android开发
Failure [INSTALL_FAILED_OLDER_SDK] Android-L, Android Studio.
装了个Android Studio,编译的时候,提示 Failure [INSTALL_FAILED_OLDER_SDK],
安装提示错误 [INSTALL_FAILED_OLDER_SDK]的解决方案
原先在1.6rc1上写的程序,拿到1.5的SDK重新编译后却不能用 abd install bin/xxx.apk   安装上去,提示错误是: Failure [INSTALL_FAILED_OLDER_SDK]   找了一下,是这个原因:   打开源码目录下的AndroidManifest.xml文件,然后注释掉或者删除掉这行:     
Android问题集锦之四十二:INSTALL_FAILED_OLDER_SDK
错误描述如下:$ adb install ./app/build/outputs/apk/app-debug.apk 2999 KB/s (8256380 bytes in 2.688s) pkg: /data/local/tmp/app-debug.apk Failure [INSTALL_FAILED_OLDER_SDK]原因就是您设备的Android版本过低,app不支持。
Installation error: INSTALL_FAILED_OLDER_SDK
使用android studio真机调试出现 Installation error: INSTALL_FAILED_OLDER_SDK 解决: 在Project Structure->自己的module选项->Compile Sdk Version选择自己合适的sdk版本 在相应module下修改build.gradle里的 defaultConfig {        
Android studio Installation error: INSTALL_FAILED_OLDER_SDK
因为studio开发出的app版本高于device的android版本。 解决办法 修改minSdkVersion
Android APK安装提示INSTALL_PARSE_FAILED_NO_CERTIFICATES错误
在开发Android App后,升级JDK到1.7,遇到APK安装提示INSTALL_PARSE_FAILED_NO_CERTIFICATES错误! 解决方法如下: 使用jarsigner签名时加上参数 -digestalg SHA1 -sigalg MD5withRSA即可
关于Installation failed的情况及解决方案
Android Studio: Application Installation Failed Failure [INSTALL_PARSE_FAILED_MANIFEST_MALFORMED: Failed parse during installPackageLI: /data/app/vmdl1028823254.tmp/base.apk (at Binary XML file line #97):
<学习笔记>安装apk报错:an error occured while deploying the file install failed older sdk
原因:apk运行所需要的最低版本高于你的真机的android版本 解决方法:下载GenyMotion-ARM-Translation_v1.1.zip:http://download.csdn.net/download/iaiti/8224603     运行虚拟器,将下载好的zip包用鼠标拖到虚拟机窗口中,出现确认对跨框点OK,然后重启虚拟机。     再重新将apk文件拖进虚拟机窗口
Android studio Failure [INSTALL_FAILED_OLDER_SDK]
Android Studio写的程序,想在安卓2.3.3(对应的sdk版本是10)虚拟器上运行,报Failure [INSTALL_FAILED_OLDER_SDK]错误。