2 u012230634 u012230634 于 2016.02.26 15:29 提问

php连接sql server 出问题 100C

php5.4.3连接SQL server2008。服务器是IIS。连不上。
我已经把php_pdo_sqlsrv_54_ts.dll和php_sqlsrv_54_ts.dll放到ext里面了,而且扩展目录路径也对。php.ini里也修改好了。

1个回答

caozhy
caozhy   Ds   Rxr 2016.02.28 06:47

检查:
sql server 2008服务是否启动运行,如果是windows 7以上,需要安装sp4补丁
sql server是否允许远程连接和tcp/ip协议
用户名密码验证方式
防火墙
你的php的驱动,环境变量,连接字符串

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
PHP连接SQLSERVER2012
说明1:PHP5.2.x本身有个php_mssql.dll的扩展用来连接Sql server,但是这个dll只是用来连接低版本 Sql server的(2000以下版本),在Sql server 2005及以上版本无法使用mssql_connect连接到数据库。 2:php5.3.x不再支持php_mssql.dll 拓展库了,及时使用php5.2.x中的php_mssql.dll也无法使用。 微
php+sqlserver之如何连接sqlserver数据库
如果说用php去开发一个网站的话,大家都会想到使用数据库mysql,跟php搭配,网上很多源码都是采用了php+mysql的方式配合开发。最近刚好有一个需求,就是使用sqlserver当数据库去开发一个网站,这里就简单介绍一个如何去连接sqlserver数据库,以及一些简单的数据库操作方法,看完这篇之后,你就会知道,其实无论是哪种数据库去开发,其实原理都很相似,只要掌握一种,其他就可以快速上手。但是
PHP+SQL Server 连接数据库(一)
新建登录名 展开“安全性”,右击“登录名”,选择“新建登录名”。如图3:1、填写登录名称;如图4 2、选择SQL Server 身份验证; 3、填写密码; 4、取消“强制实施密码策略”; 5、选择数据库;(这里使用默认值为例) 6、点击确定;(新建完成) 7、展开“登录名”,查看新建的登录名。如图5
基于Linux下PHP连接SQL Server方法
基于Linux下PHP连接SQL Server方法,可进行数据库等常用操作及查询
PHP中通过ODBC连接SQL Server数据库
http://blog.csdn.net/emili/article/details/4263084 现象:        一台 Windows 服务器,装有 SQL Server 数据库,除了可以访问本地的 SQL Server 外,还可以访问另一台机器的 SQL Server. 通过配置 PHP.ini 中的 extension=php_mssql.dll 并在网上
php 5.5.12 连接sql2008
PHP连接SQLSERVER2008 问题汇总: 1. 需要手动配置扩展和安装一个驱动 拓展就是些dll文件 。微软的官网山更有相关的下载地址。https://www.microsoft.com/en-us/download/details.aspx?id=20098 拓展包版本与php版本对应: Version 4.0 supports PHP 7.0+
PHP连接SQL server数据库
PHP连接sql server数据库
关于PHP5.6连接SQL Server 2008 R2数据库驱动及一些问题
今天因为一些原因,接触到了php连接MSSQL2008的问题,自己毕竟第一次接触,出了不少洋相,然后根据自己查阅资料学习等等,终于搞定了这个事情,因为在网上没找到一篇完整像样的文章,所以写了这一篇文章,希望能对大家有所帮助!谢谢!
php 连接SqlServer小结
php 连接SqlServer(windows/Linux)最近遇到要用php连接SqlServer的情况,发现在Windows和Linux下还是有区别的,也遇到了不少坑,在此记录一下: windows下: 我使用的是PHP Version 5.4.33 NTS,VC9 需要注意的是要按照sqlsrv的相关扩展 修改php.ini把这两项前面的分号去掉,重启Apache服务即可: exte
php支持连接sql server数据库
1、软件配置 Win7 64 +wampserver2.2d-x32+SQL Server 2008 R2数据库,wamp2.2中的php版本是5.3.10。 Php环境也可以换成php+apache。 2、支持连接MySQL Server配置  php版本5.3以前,有php_mssql功能,可以使用,但是5.3及以后的版本不支持。 2.1、php连接mssql设置(php5.3以前版