2 u011359326 u011359326 于 2016.02.29 17:47 提问

eclipse有时候提示说要加;我明明加了但是还是报错

Syntax error, insert ";" to complete Statement
加了啊,明明就是加了啊,
但是始终报错啊
咋办啊????

3个回答

wojiushiwo945you
wojiushiwo945you   Ds   Rxr 2016.02.29 19:13
已采纳

你确定加的是英文输入法下的分号么?如果加的正确的话,保存下代码或者clean下项目就好了。

BieberSen
BieberSen   2016.02.29 18:14
      贴出来代码
wanghjbuf
wanghjbuf   2016.02.29 20:33

中英文切换注意这个问题

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
明明jar包已经引入了,并且编译不报错,但是运行却还提示classnotfound,什么原因?
我在写cxf的客户端代码调用cxf接口的时候,编译不报错,但是运行这一句的时候的时候报错: Client client = clientFactory.createClient("http://XX.XX.XX.XX:8080/XX/XXService?wsdl"); 报错提示: Caused by: java.lang.ClassNotFoundException: com.sun.t
java.lang.ClassNotFoundException但是项目里明明已经导入了需要的类
今天,从svn中下了一个web项目,用的是ssh框架。当一切准备就绪时候,run下项目,结果出现404错误。看了下控制台日志,出现各种 java.lang.ClassNotFoundException 看了下lib文件中,包都在啊,而且已经add进build path里面了啊。坑,怎么会找不到呢。。。 然后看了下tomcat下运行的项目中找下,发现还真的没有那些包。 试了下
Maven 本地仓库明明有jar包,但是pom文件还是报错解决办法
找到出错的jar包文件位置,删掉_maven.repositories文件 (或用文本编辑器打开,将“>XX=”改为“>=”,即删除main,当然main也可能是其他值) ,然后update project。就这么简单,完美解决。具体什么原因,待我进一步了解。
类存在却报ClassNotFound异常的解决方法
有时候使用eclipse时候编译程序类明明存在却报ClassNotFound异常,昨天又遇到了,记录一下分享。 原创文章,欢迎转载,请保留出处。 有任何错误、疑问或者建议,欢迎指出。 我的邮箱:Maxwell_nc@163.com
vs 已经添加了引用,编译还是提示没有添加引用
已经添加了引用,但是,编译还是通不过。 原因:项目整体框架是.Net FramWork4.5,nep中的框架也是4.5,而编译不过的工程是4.0, 解决办法:将编译不过的项目框架改为4.5
明明引用了,却还提示说没有引用DLL
问题:明明引用了,却还提示说没有引用DLL 答:把DLL的framwork版本和程序版本弄成一样的就行了
明明引入jar包,却依然ClassNOtFoundException
在项目中MAVEN加入了: org.slf4j slf4j-api 1.7.5 运行项目后出现红色提示: SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder". SLF4J: Defaulting to no-operation (NOP) logger impl
eclipse已经导入jar包了,但还是出现classNotFound异常
场景:分析-eclipse已经导入jar包了,但还是出现classNotFound异常 分析--eclipse已经导入jar包了,但还是出现classNotFound错误 最近在做一个web项目时,由于需要导入jar包,就直接在build path下导入了jar包,并且在java类中也直接通过import也能导入使用,并且单独运行一个java的main类可以正常运行,但是在运行了w
明明正确导入了外部jar包还是出现ClassNotFoundException
在建好的web工程下,新建lib文件夹,将所使用的的外部jar包复制进来,然后正确build-path后,使用单元测试完全没问题,但将项目发布以后,出现错误: java.lang.ClassNotFoundException: org.dom4j.DocumentException 明明单元测试都没问题却报这样的错误,后来去tomcat下的webapp里面寻找jar包,发现lib目录下并没有我
eclipse项目一直显示有错,但是一直找不到错误在哪里
eclipse项目一直显示有错,但是一直找不到错误在哪里这天在写项目的时候碰到了这么个问题,项目上一直提示着红叉,但不管是文件里还是java buildpath里都找不到报错,然后我就郁闷了。后来给我找到一个解决方案,能查看当前错误是什么: eclipse–>Window–>show View–>Markers,出现一个面板,然后在这个面板里就能查看到底是什么在出错啦。