2 heroleorogan heroleorogan 于 2016.03.09 17:08 提问

修改jre后 maven的pom就报错

请教各位高手
问题是:
SVN上拉下来一个项目,本来没问题,但是在build path里把jre从1.5改成1.6后,
maven的pom文件就报错,所有依赖的jar包都找不到了(jar包我本地仓库里都有,也排除了lastUpdated的问题),不知道怎么办,求大神帮忙
备注:IDE:eclipse
图片说明

1个回答

heroleorogan
heroleorogan   2016.03.09 17:13

忘了说了,在项目的Library里的maven dependencies里面,那些jar包都在......................

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Maven项目在Update Maven之后JRE被改成1.5的解决方法(转载)
Maven项目在Update Maven之后JRE被改成1.5的解决方法一、Maven Update 后 JDK变成1.5在Eclipse中新建了一个Maven工程、然后更改JDK版本为1.7或者以上、结果每次使用Maven > Update project的时候JDK版本都恢复成1.5。二、JDK1.5原因分析后来查了一下原因、Maven官方文档有如下描述: 译器插件用来编译项目的源文件从3.0
Maven项目Update Project之后jre被改成JSE1.4的问题
可能你当前使用的jdk是1.7+,但是每次Maven-> Update Project...之后,发现JRE Library又变成了JSE1.4,并且有可能不会报错,这种感觉就醉了。主要原因是每次Update时,它就会使用settings文件下的默认值。修改方法有两种(建议都使用)。 解决方案一: 修改maven的默认jdk配置,找到maven的conf\setting.xml文件中找
Maven项目中修改jre版本(主要是修改setting文件改变maven默认生成的项目jre版本)
有时候建maven,开发过程中会突然发现jre版本过低不支持操作,会有“Change project complicate and JRE to 1.7”诸如此类的快速解决方案,但是当我们选择快捷方式或者项目右键-->Properties-->Project Facets 右边Java 版本选项此类的解决方案解决后当再次选择 maven -> Update Project 更新的时候,会出现j
maven配置文件中修改默认jre
方法一:打开%maven_home%\conf\setting.xml,只会在新建项目时自动使用1.6的导入项目不会 在标签内添加如下配置:  jdk-1.8     true   1.8       1.8   1.8   1.8   方法二:不同的项目使用不同的jre,pom.xml里添加如下配置 导入项目可以这样配置然后进行maven
maven修改默认jre版本
今天遇到一个怪事,就是我的maven项目只要update project,修改过的jre版本回到了1.5,可是我本地的jdk版本与之不兼容,网上查阅资料看到解决办法,在pom.xml做一下修改 org.apache.maven.plugins maven-compiler-plugin 3.0 1.7 1.7
Maven项目中修改jre版本
有时候建maven,开发过程中会突然发现jre版本过低不支持操作,会有“Change project complicate and JRE to 1.7”诸如此类的快速解决方案,但是当我们选择快捷方式或者项目右键-->Properties-->Project Facets 右边java 版本选项此类的解决方案解决后当再次选择 maven -> Update Project 更新的时候,会出现jre
解决eclipse的maven项目update后,JRE环境由变成JAVASE-1.5问题
这个问题需要对maven进行配置,找到maven安装目录下的conf目录下的.setting.xml文件,我的目录是E:\JAVA\apache-maven-3.0.4-bin\apache-maven-3.0.4\conf。 如果没有此目录下没有此文件,可能是被隐藏了
解决:Maven项目,右键-update project后JRE system Library变为JavaSE1.5
在学习maven建项目的时候,执行了一下maven的update project后发现项目报错了,错误信息提示:Dynamic Web Module 3.0 requires Java 1.6 or newer. my_ssm line 1 Maven Java EE Configuration Problem。看了网上的解决方案都是在pom.xml文件中添加以下内容: defin
eclipse中解决update maven之后jre被改成1.5的问题
在项目的pom.xml文件中加入以下内容 org.apache.maven.plugins maven-compiler-plugin 2.1 1.7 1.7 然后重新update maven就可以解决该问题
Maven管理项目的时候 Update Project后jre变成1.5
用maven建完web项目后,由于jre的版本和Tomcat的版本是有要求的,所以有很多朋友常常出现下列问题: 1、这里,我明明设置了我的JRE是1.8了 2、然而,当我 Update Project后........ 不仅如此,更尴尬的是出现了一下问题 主要原因是每次Update时,它就会使用settings文件下的默认值。(原来这是maven自己