qq_33312212 2016-03-14 16:00 采纳率: 21.9%
浏览 1418
已采纳

poj 1276 背包问题 编译错误 求大神看看 英汉题意如下

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input

735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output

735
630
0
0
题意:有现今cash,和n种钱币,每种钱币有ni个,价值为di,求各种钱币组成的不超过cash的最大钱数.......

 #include <iostream>
#include <vector>
#include <cstring>

using namespace std;

int imax(int a,int b)
{
    return(a>b?a:b);
}

int main()
{
    int cash;
    int nu;
    while(cin>>cash>>nu)
    {
        vector <int> l;
        l.push_back(0);
        int num=0;
        int n;
        int d;
        int i;
        int j;

        for(i=1;i<nu+1;++i)
        {
            cin>>n>>d;
            num+=n;
            for(j=0;j<n;++j)
            {
                l.push_back(d);
            }
        }
        int f[num+1][cash+1];
        memset(f,0,sizeof(f));
        i=0;
        j=0;

        for(int i=1;i<num+1;++i)
        {
            for(int j=cash;j>=l[i];--j)
            {
                f[i][j]=imax(f[i-1][j-l[i]]+l[i],f[i-1][j]);
            }
        }
        cout<<f[num][cash]<<endl;
    }

    return 0;
}

  • 写回答

1条回答

  • threenewbee 2016-03-14 22:27
    关注
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥15 乘性高斯噪声在深度学习网络中的应用
  • ¥15 运筹学排序问题中的在线排序
  • ¥15 关于docker部署flink集成hadoop的yarn,请教个问题 flink启动yarn-session.sh连不上hadoop,这个整了好几天一直不行,求帮忙看一下怎么解决
  • ¥30 求一段fortran代码用IVF编译运行的结果
  • ¥15 深度学习根据CNN网络模型,搭建BP模型并训练MNIST数据集
  • ¥15 C++ 头文件/宏冲突问题解决
  • ¥15 用comsol模拟大气湍流通过底部加热(温度不同)的腔体
  • ¥50 安卓adb backup备份子用户应用数据失败
  • ¥20 有人能用聚类分析帮我分析一下文本内容嘛
  • ¥30 python代码,帮调试,帮帮忙吧