steve_yanrun
Ray-Yan
采纳率65.9%
2016-03-28 14:22 阅读 1.8k
已采纳

Myeclipse servlet无法运行

我刚刚学写了servlet程序如下:

import java.io.IOException;
import java.io.PrintWriter;
import javax.servlet.http.*;
import javax.servlet.*;

public class MyServlet extends HttpServlet{

    @Override
    protected void doGet(HttpServletRequest req, HttpServletResponse resp)
            throws ServletException, IOException {
        // HttpServletRequest 请求类,封装所有的请求信息
        // HttpServletResponse 响应类
        //super.doGet(req, resp);
        PrintWriter out = resp.getWriter();
        out.print("Hello Servlet!");
        out.close();
    }

    @Override
    protected void doPost(HttpServletRequest req, HttpServletResponse resp)
            throws ServletException, IOException {
        // TODO Auto-generated method stub
        //super.doPost(req, resp);
    }

}

运行后抛出异常如下:
java.lang.ClassNotFoundException: org.apache.catalina.startup.Catalina
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
网上有说是tomcat的配置问题,关于我的tomcat设置,见如下图片:
图片说明
图片说明
图片说明
不知道是哪出问题了,请大神帮忙看一下,刚刚接触MyEclipse和Tomcat。或者是不是其他地方的问题?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

4条回答 默认 最新

  • 已采纳
    Crabime Crabime 2016-03-28 14:28

    1、你在web.xml中有没有配置好该Servlet类?
    2、Tomcat启动是否成功,看看你控制台的启动信息,如果控制台启动有错误的话那就是Tomcat配置错了

    点赞 评论 复制链接分享
  • steve_yanrun Ray-Yan 2016-03-28 14:38

    图片说明

    点赞 评论 复制链接分享
  • steve_yanrun Ray-Yan 2016-03-28 14:41

    图片说明
    控制台的信息,但是就是运行不出来

    点赞 评论 复制链接分享
  • steve_yanrun Ray-Yan 2016-03-28 15:17

    图片说明
    看来是tomcat没配置好了,该怎么弄啊

    点赞 评论 复制链接分享

相关推荐