2 aabb895212798 AAbb895212798 于 2016.03.31 14:40 提问

在android studio中导入项目,提示这个问题

Gradle sync failed: failed to find Build Tools revision 19.1.0
Consult IDE log for more details (Help | Show Log)

    这是什么原因,

3个回答

cyxevil
cyxevil   2016.03.31 17:10
已采纳

如果是eclipse导到As的话,要在eclipse以as的形式先导出

这个好像是版本问题

Gradle sync failed: failed to find Build Tools revision 19.1.0

cyxevil
cyxevil 回复zgh_1994: 没事,希望能帮到你
2 年多之前 回复
AAbb895212798
AAbb895212798 回复cyxevil: ok,我去看看先。谢谢的啊
2 年多之前 回复
cyxevil
cyxevil 回复zgh_1994: 你看你有没有那个Tools或者你看看是不是少了build.gradle这个文件,没有它as是编译不出来的
2 年多之前 回复
cyxevil
cyxevil 回复zgh_1994: Gradle同步失败:没有找到构建工具修订19.1.0
2 年多之前 回复
cyxevil
cyxevil 回复zgh_1994: Gradle同步失败:没有找到构建工具修订19.1.0
2 年多之前 回复
AAbb895212798
AAbb895212798 是我向同学要的项目源码,他也是as编的,然后我导入as就报这个错
2 年多之前 回复
CSDNXIAOC
CSDNXIAOC   2016.03.31 14:54

在网上看到好的Demo,经常想Download下来研究一下,在导入到Android Studio的时候,可能会出现一个问题,项目没办法运行,所有的JAVA文件都有一个红色的标记,在右上角会出现一个Project is not define.试了几次才知道,原来是download下来的文件缺少了配置文件local.properties,这个文件是在首次创建项目的时候,AS根据配置自己创建的,在导入的......
答案就在这里:Android Studio导入项目的问题
----------------------你好,人类,我是来自CSDN星球的问答机器人小C,以上是依据我对问题的理解给出的答案,如果解决了你的问题,望采纳。

AAbb895212798
AAbb895212798 这个答案还给人悬念
2 年多之前 回复
l_o_s
l_o_s   2016.03.31 15:19

打开SDK Manager去下载Build Tools

AAbb895212798
AAbb895212798 下了好几遍的了
2 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Android studio第一次导入项目遇到的问题,和解决方案
在github或者其他的git平台下载的android studio项目导入到自己的Android studio中会出现一堆问题,    首先在导入之前先用自己的Android studio创建一个测试工程,主要使用测试工程下的2个文件,分别是:./build.gradle和./gradle/wrapper/gradle-wrapper.properties文件  例如1.build
Android studio导入项目(出现的问题)
前言:github对开发者而言无疑是个宝藏,但想利用它可不是件简单的事,用Android studio导入开源项目会遇到各种问题,今天我就以github上的一个图片轮播项目为例,解决导入过程中的常见问题.   1.下载项目压缩包 2.由于android studio采用gradle自动构建,而每个项目的gradle版本不一致会导致编译异常,所以要修改开源项目的gradle版本,过程如
导入一个AndroidStudio项目时遇到的gradle问题
问题: 由于你导入的项目的gradle版本与本地的gradle版本不一致,会导致让AndroidStudio去下载对应版本的gradle,而这个gradle一般在80M左右(需要翻墙),根本下载不下来,会导致卡死在那里。 解决方式一:如果你是导入github上的项目,只是为了学习一下代码,那么可以采用快速配置gradle的方式(修改所导入项目的gradle配置为本地的gradle配置,这样就不用
Android studio导入项目提示R错误原因
1.项目配置的API版本不一致,鼠标选中项目名,按F4。。。选择两个版本一致方可,以第一个版本为基准
Android Studio解决导入开源项目出现的相关问题
今天,用Import Module导一个网上的类库library,再在File的Project Structure中的Denpendencies将library作为Moudle denpendency添加进去, 结果sync时出现not found:'runProguard()'的问题,困扰我好久,最后解决。 从字面就能看出来,出现这个问题的原因是找不到runProguard()这个方法了(调用这个
导入项目到android studio中遇到的各种问题
最近学习一下别人的源码,于是在网上下载了各种源码,有17年的16年的等,本来是想直接找一个androidstudio项目,看着这些年份相对13年(Androidstudio问世)比较久远,猜想这些应该是androidstudio项目了吧,可是我所连续下载的三个都是eclipse项目。于是导入到androidstudio中出现了各种问题。eclipse导出的android项目有两种,一种是供ecli...
Android studio导入项目无法运行。keystore问题。
Error:Execution failed for task ':app:validateSigningDebug'. > Keystore file /Users/tanghaoshu/AndroidStudioProjects/mxcome-shigong-andorid/app/publish/mxcome.jks not found for signing config 'debu
Studio 导入项目常见问题
Studio 导入项目常见问题 ONE Goal,ONE Passion! Android studio安装配置常见问题及其解决方案: http://blog.csdn.net/fengltxx/article/details/52424768许多人都说,eclipse导入studio项目非常困难,还有就是studio项目导入studio更难.真的是这样吗?其实很多都是各种工具的版本问题。问
引入别人的Android Studio项目遇到的bug以及解决方法
常见问题1:Gradle version xxxx is required 解决方法: 出现此情况,应该是使用了gradle wrapper时候,创建工程时使用的gradle版本比当前使用的版本低得情况。此时log会提示 去修改 project_root/gradle/wrapper/gradle-wrapper.properties这个文件中 distributionUrl=http\
解决Android Studio中工程无法导入的问题。
从eclipse转到Android Studio之后经常会遇到一个问题:从github或其它地方下载下来的工程代码无法导入到Android Studio中,或者说在导入的时候Android Studio直接卡死。 原因大多是因为下载的工程代码里面的gradle版本和自己Studio里面的gradle的版本不一致造成的。 我们可以通过以下几个步骤解决这个问题: 1.直接在工程文件夹根目录中找到