2 cuiguanjun cuiguanjun 于 2016.04.01 14:28 提问

php配置libevent扩展的相关问题

php上配置libevent扩展,网上教程说将libevent0.1.0.tgz解压后执行./configure,但下载的包解压后都没有configure文件,没有办法按照该命令安装,该怎么解决?

2个回答

CSDNXIAOC
CSDNXIAOC   2016.04.01 14:32

PHP5.4环境搭配

apache httpd.config中的配置 

LoadModule php5_module "c:/www/php54/php5apache2_2.dll"
AddType application/x-httpd-php  .php
PHPIniDir "C:/www/PHP54"

1,php模块
2,识别php (.php)......
答案就在这里:php 配置以及相关问题
----------------------你好,人类,我是来自CSDN星球的问答机器人小C,以上是依据我对问题的理解给出的答案,如果解决了你的问题,望采纳。

devmiao
devmiao   Ds   Rxr 2016.04.01 23:14
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
php7.2 编译安装event扩展
event编译安装: 下载地址:http://pecl.php.net/package/event 安装event扩展,需要安装基础库libevent,版本要高 libevent: wget -c https://github.com/libevent/libevent/releases/download/release-2.1.8-stable/libevent-2.1.8-stable.ta...
php5.6安装libevent扩展
自己搞的时候还有点艰辛,但是一步步的百度总会有答案。先下载libevent扩展: wget http://pecl.php.net/get/libevent-0.1.0.tgztar zxvf libevent-0.1.0.tgz cd libevent-0.1.0 phpize ./configure --with-php-config=/usr/local/php/bin/php-conf
php libevent 扩展使用示例
define('CONNECT_IN_MSG', chr(1)); define('CONNECT_OUT_MSG', chr(2)); class epoll{     private static $socket;     public static $connections;     private static $buffers;  private static $msgs
PHP扩展库安装遇到的问题总结
首先来说明下遇到的问题,公司用php做游戏服务器开发语言,当然还用了php传说中不擅长的长连接(个人觉得开发效率高于机器成本,现在分布式网络集群时代,没必要省那么点钱),我们涉及到php5.3版本升级到5.6的时候,有的php扩展不能用了,蛋疼; 涉及到的模块有libevent,对,就是它,这是干吗用的呢?应为我们是长连接,必然是高并发的io密集型应用程序,所以,用libevent做io
workerman和webSocket与libevent扩展的关系
1、libevent介绍libevent是一个事件触发的网络库,适用于windows、linux、freebsd等多种平台,内部使用select、poll、epoll、kqueue等系统调用管理事件机制。Libevent是跨平台的,而且具有非凡的性能。与nodejs一样是事件驱动的;官方网站:http://libevent.org/2、workerman介绍workerman是一个高性能的PHP s
php7下安装event扩展
php7下安装event扩展 有效安排I/O,时间和信号的扩展 使用可用于特定平台的最佳I/O通知机制的事件,是PHP基础设施的libevent端口。 下载地址:http://pecl.php.net/package/event安装支持库libevent,需要编译高版本(这里以最新版本release-2.1.8-stable为例) wget -c https://github.com/li
推荐一些书籍
本来是写给新同学作为参考的,难得写这么多文字,贴到 blog 上自我陶醉下。咔咔。 -------------------------------------------------------------------------------------- -- 学习资料/推荐书目 -- -- 一个人不可能把所有知识都掌握无余,本文只希望达到“在学习某一领域软件知识时,可很快 --
php配置扩展相关
最近手痒打算重新拾起php,于是乎先配置上一波,结果遇到了两个小问题。 1、apt安装的php7.2.4.结果找不到php.ini 答案:确实没有,自己下一个源码,然后copy其中的php.ini-development或者php.ini-production,改名为php.ini放到 /etc/php/7.2/fpm 即可 2、安装mysqli插件时
ubuntu 12.04 PHP libevent扩展安装
debian/ubuntu系统安装教程(适用于php环境是get-get install安装的情况) 1、命令行运行 apt-get install php-pear php5-dev libevent-dev 2、命令行运行pecl install channel://pecl.php.net/libevent-0.1.0 3、命令行运行sudo echo extension=libevent.
libevent 编译错误问题
出现undefined reference to `event_add'; undefined reference to `event_init'; undefined reference to `event_set'; undefined reference to `event_add' 之类,是库没有连接上,如下编译:g++ -o libevent libevent.cpp -leve