D_reamW_eaver
泡泡机不冒泡了
2012-10-22 14:16
采纳率: 100%
浏览 18.2k
已结题

eclipse平台上android 虚拟机运行后看不到手机界面

我创建了新的adv之后点击start,之后点击launch,没有出现很多教程上那样的手机界面,只是屏幕略微闪了一下,之后就没有反应了。
我创建了一个hello工程,没有向其中加任何代码,直接用按android application 方式运行出现如下提示:

[2012-10-23 10:17:59 - Hello] Android Launch!
[2012-10-23 10:17:59 - Hello] adb is running normally.
[2012-10-23 10:17:59 - Hello] Performing com.android.hello.MainActivity activity launch
[2012-10-23 10:17:59 - Hello] Automatic Target Mode: Preferred AVD 'AVD4.1' is not available. Launching new emulator. [2012-10-23 10:17:59 - Hello] Launching a new emulator with Virtual Device 'AVD4.1'
  • 点赞
  • 收藏

38条回答 默认 最新

  • okgoodyes
    okgoodyes 2012-12-29 04:44
    已采纳

    根据报错来看,没有找到可用的AVD,你建的AVD不支持,建议更改下AVD的配置,“Device”选项更换成其他类型试一下。
    还有可能就是你的eclipse制定的寻找AVD的路径,跟你新建的AVD不是一个路径,打开elipse的window->preferences->android->build,看defalut debug keystor内的路径,看你新建的AVD所在的路径是否相同,不相同的话改下建的AVD的路径。

    点赞 评论
  • franzhong
    franzhong 2012-10-23 02:21

    try again.
    你机器啥配置啊?
    看看系统进程,多数是时间久你以为没启动起来
    刚开始就是闪几下,大家都认为模拟器启动时会很费时
    用真机测试

    点赞 评论
  • woshiwoxingfu
    woshiwoxingfu 2012-10-23 02:21

    进你的Virtual Device Manager看看,是不是跟我发的图一样,打勾才说明创建成功了,看你发的貌似虚拟机没创建成功

    enter image description here

    点赞 评论
  • O_1001_O
    O_1001_O 2012-10-23 02:27

    呃,这种情况有很多可能额,有可能是没连接成功,我建议你试试重启adb试试,不一定管用,不过可以试试,去DDMS里代开devices选项,然后再右上角选择view menu,点开之后有一个选项“reset adb”。

    点赞 评论
  • yangjunjie003
    Young002 2013-12-22 15:08

    这个应该是你的AVD配置问题,建议配置一下,可以查找一些配置方法!

    点赞 评论
  • u010359778
    吃鱼的灰太狼 2014-11-19 01:25

    你的sdk路径中的某个文件夹的命名过长,或者SDK路径没有空格。
    最好不要用虚拟机!不仅慢还很消耗内存,建议用安卓手机

    点赞 评论
  • LG_sun
    _-野草-_ 2014-11-19 05:14

    可能是SDK安装路径不对,在一个安卓的手机模拟器反应是很慢的第一次运行需要好几分钟,你需要耐心等候!

    点赞 评论
  • xiashuangxi
    xiashuangxi 2014-11-19 06:25

    这种问题的可能性比较多,你查看一下配置,或把adb重新启动一下吧。如果是使用自带的模拟器是很慢的,你可以考虑使用genymotion模拟器或真机测试 。

    点赞 评论
  • tiandi_5000
    HelloAke 2014-11-20 04:30

    avd4.1没有下载完整.

    点赞 评论
  • bbhay
    bbhay 2014-11-20 05:33

    你的AVD4.1设置有错误

    点赞 评论
  • chiqiang111
    小白兔设计大神 2014-11-20 06:25

    你的AVD4.1设置有错误

    点赞 评论
  • u012952324
    emilyshanlijuan 2014-11-20 07:42

    你的模拟器设置配得有问题
    你的模拟器设置配得有问题

    点赞 评论
  • ITbailei
    dali_yan 2014-11-20 13:20

    建议你把原先新建的AVD4.1有问题,具体看一下错误日志,把这个删除,重新新建一个模拟器试试看

    点赞 评论
  • sg_onlyway
    sg_onlyway 2014-11-20 15:41

    重新配置一下虚拟机试一试。

    点赞 评论
  • mynameisIT
    mynameisIT 2014-11-20 16:18

    建议你重新配置虚拟机,或者换个
    建议你重新配置虚拟机,或者换个

    点赞 评论
  • istruth
    istruth 2014-11-22 12:19

    Preferred AVD 'AVD4.1' is not available
    AVD 即虚拟机有问题,建议重新配置

    点赞 评论
  • guwei4037
    guwei4037 2014-11-23 03:56

    android开发环境有没有配置好,或者重新建一个avd。Android开发环境搭建

    点赞 评论
  • jiang_lei3000
    jiang_lei3000 2014-11-24 14:04

    重新配置下AVD,配置普通的

    点赞 评论
  • huangn347
    huangn347 2014-11-25 04:19
    点赞 评论
  • CSDNJavaLiwei
    liwei_Struggle 2014-11-25 07:11

    重新配置下AVD.......
    重新配置下AVD.......

    点赞 评论
  • csdn1457570681
    csdn1457570681 2014-11-26 03:02

    配置avd时,分辨率选择在800*480,选择sdk版本低一些,例如2.3.3,入门学习的话够用了。应该是avd配置的问题。

    点赞 评论
  • george_chee
    george_chee 2014-11-26 10:52

    请问 安卓SDK你是怎么更新的?fanqiang的话速度很慢下载耗时太长。

    点赞 评论
  • dxjwolf
    妖怪 2014-11-26 11:01

    AVD4.1模拟器报错,这个模拟器暂时不可用。你试一下换一个模拟器或者直接连手机来进行调试。

    点赞 评论
  • Cocoos
    阿荡 2014-11-27 01:15

    根据报错可知是AVD4.1出了问题,可以考虑重新配置一个AVD。(不建议使用AVD进行调试,启动较慢,可以考虑用android手机来调试)

    点赞 评论
  • u013173247
    术舞 2014-11-27 02:25

    cpu/abi不要选择intel的换成arm的

    点赞 评论
  • silence_cdsn
    三只小毛驴 2014-11-27 07:42

    重新配置你的模拟器吧,把ADT和配置好先!

    点赞 评论
  • xzw674469477
    xzw674469477 2014-11-27 10:42

    应该是配置有问题吧。

    点赞 评论
  • vaehke0000
    vaehcomputer 2014-11-29 06:19

    应该是操作的问题,按照我一下的方式就可以:
    1.新建一个android application空项目(先不要输你自己写的代码)
    2.在上栏windows下拉栏选择创建新的adv,然后选中你新建的adv,选择start即可
    稍后会出现安卓虚拟机界面
    3.如想运行你自己写的代码只需将自己的代码粘贴到空项目相应的类里,然后在左边选中项目右键选择run即可
    希望以上三点可以帮到你。。
    应该是操作的问题,按照我一下的方式就可以:
    1.新建一个android application空项目(先不要输你自己写的代码)
    2.在上栏windows下拉栏选择创建新的adv,然后选中你新建的adv,选择start即可
    稍后会出现安卓虚拟机界面
    3.如想运行你自己写的代码只需将自己的代码粘贴到空项目相应的类里,然后在左边选中项目右键选择run即可
    希望以上三点可以帮到你。。

    点赞 评论
  • moridehuixiang
    末日的回想 2014-11-30 00:28

    建议直接真机运行,速度绝对比模拟环境快不止一倍,亲测。。。

    点赞 评论
  • donnykeon
    donnykeon 2014-12-05 15:08

    楼主解决了吗?我也遇到这样的问题

    点赞 评论
  • wolfkingkg0129
    wolfkingkg0129 2014-12-10 07:01

    从你的贴出的提示信息看没有错误啊,是不是你的机器配置低,虚拟设备启动太慢造成的,建议真机调试,速度快很多

    点赞 评论
  • qaserfvvbbert
    hudk114 2014-12-12 11:33

    avd不适用于你当前的工程吧。设置成googlewatch之类的类型之类的
    用真机调试比较好,avd有很多问题……尤其网络那块

    点赞 评论
  • seacracker
    seacracker 2014-12-24 03:36

    虚拟机显示不支持openGL,要用物理机,或用手机调试。

    点赞 评论
  • xiaoqiang_521
    xiaoqiang_521 2014-12-30 09:33

    那是因为你配置的AVD有问题,重新配置个低配置的试试

    点赞 评论
  • GXSeveryday
    北顾丶 2014-12-30 23:46

    建议在电脑上下载一个安卓虚拟机,例如,天天安卓虚拟机和Bluestacks安卓模拟器。

    点赞 评论
  • wang1018960145
    令狐少侠-king 2015-01-04 02:51

    我解决的办法是新建一个低版本的avd试一下

    点赞 评论
  • u011988082
    wyccrazyguy 2015-06-12 00:20

    SDK安装路径不对吧

    点赞 评论
  • xuhuandeshouhuzhe
    虚幻的守护者 2015-10-10 08:32

    android 模拟器的话,我觉得你不要用google提供的那个模拟器。用这个genymotion吧,这个速度很快。

    点赞 评论

相关推荐