2 l18203612341 l18203612341 于 2016.04.11 11:03 提问

INSTALL_FAILED_NO_MATCHING_ABIS

在网上都已一大堆,都说是虚拟机上运行会出现这个问题,但是我这个是在真机上测试出现的。
来个大神瞅瞅吧。

1个回答

CSDNXIAOS
CSDNXIAOS   2016.04.11 12:05

在Android模拟器上安装apk的时候出现



INSTALL_FAILED_NO_MATCHING_ABIS

这个错误提示的解决办法。

是由于使用了native libraries 。该native libraries 不支持当前的cpu的体系结构。

INSTALL_FAILED_NO_MATCHING......
答案就在这里:INSTALL_FAILED_NO_MATCHING_ABIS
----------------------Hi,地球人,我是问答机器人小S,上面的内容就是我狂拽酷炫叼炸天的答案,除了赞同,你还有别的选择吗?

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
android studio导入so库Failure [INSTALL_FAILED_NO_MATCHING_ABIS]解决方案
出现此问题一般是在用虚拟机测试时,该问题说明so库不支持当前虚拟机cpu体系,只需在项目app/src/mian/jniLibs下新建文件夹mips和x86,并把so文件拷贝到这两个文件夹下,即可。 目录结构如下:
使用Genymotion安装APK出现错误Failure [INSTALL_FAILED_NO_MATCHING_ABIS]解决办法
Genymotion出现这个情况需要安装补丁包 原因是某些应用使用了原生库(NDK,Native Lib)因为这些库的编译目标通常是arm的cpu,在x86上运行就会报这样的错误。 具体解决办法如下: 1、下载Genymotion-ARM-Translation_v1.1.zip,直接拖入genymotion模拟器窗口,直到提示成功。        重启后再拖入需要
安装app时报INSTALL_FAILED_NO_MATCHING_ABIS错误解决方式
安装app时报INSTALL_FAILED_NO_MATCHING_ABIS错误解决方式
Android模拟器下安装APP报INSTALL_FAILED_NO_MATCHING_ABIS错误解决方案
当我们想在电脑的Android模拟器中安装APP的时候,会报INSTALL_FAILED_NO_MATCHING_ABIS错误【如图1】,导致APP无法在模拟器中运行。下面给出我的解决方案,希望能对你有所帮助! 【图1】adb install 命令安装APP 原因分析: 由于安装的APP中使用了与当前CPU架构不一致的native libraries,所以导致报错,因为现在绝大多数的
INSTALL_FAILED_NO_MATCHING_ABIS 的解决办法
在Android模拟器上安装apk的时候出现  INSTALL_FAILED_NO_MATCHING_ABIS
解决 Eclipse 运行 app 报错: INSTALL_FAILED_NO_MATCHING_ABIS
解决 Eclipse 运行 app, 报错: INSTALL_FAILED_NO_MATCHING_ABIS
INSTALL_FAILED_NO_MATCHING_ABIS 解决方案
本文首发在我的个人博客: http://www.geekqian.com/post/f3508228.html 转载请注明出处 在网上看到出现这个异常的原因是使用的了 Native lib 或者 JNI 之类的反正就是跟硬件有关的乱七八糟的包. 例如我使用了 一个图片压缩的包, 涉及到了 JNI, 之后打包就出现了上述的异常. 解决方案: 在 app 的 moudle 的 bu
Genymotion问题解决之 INSTALL_FAILED_NO_MATCHING_ABIS (一)
先贴上几个连接地址,后期会整理。 http://blog.csdn.net/wjr2012/article/details/16359113 http://blog.csdn.net/rznice/article/details/40260339
Installation failed with message INSTALL_FAILED_NO_MATCHING_ABIS.安装失败,解决办法
INSTALL_FAILED_NO_MATCHING_ABIS 在使用Genymotion安装程序时,使用了native libraries ,该nativelibraries 不支持当前的cpu的体系结构。 我发布的答案从另一个线程,因为它的工作对我来说,诀窍是增加两个架构的支持: 因为我找不到一个直接的答案,不得不看几篇不同的文章才能得到我想要做的… 最靠谱的解决办法
关于Installation error: INSTALL_FAILED_NO_MATCHING_ABIS的解决方法
遇到过好几次这种错误提示,工程代码没有任何错误,但是连安装都安装不上模拟器,console控制台就报出上面的错误:[2015-11-25 15:15:37 - Em4.x] Installation error: INSTALL_FAILED_NO_MATCHING_ABIS [2015-11-25 15:15:37 - Em4.x] Please check logcat output for m