2 csdn linan csdn_linan 于 2016.04.14 17:02 提问

ubuntu15.10安装qt5.5.1播放视频报错找不到解码器 1C

我在ubuntu15.10中安装了qt5.5.1,使用qt播放qt安装目录下的代码示例(视频播放功能),
报错说找不到解码器:
Warning: "找不到‘video/quicktime, variant=(string)iso’类型可用的解码器。"
是需要quicktime这个吗?系统中有啊。程序是没有问题的,因为是安装qt时自动安装的。qt安装完我直接启动了。系统需要如何配置?希望说的详细点。
大神们请指点一下。。。
谢谢~~~

1个回答

xxmvzeetbb
xxmvzeetbb   2016.10.08 01:41

找不到‘video/quicktime, variant=(string)iso’类型可用的解码器。"
是需要quicktime这个吗?系统中有啊。程序是没有问题的,因为是安装qt时自动安装的。qt安装完我直接启动了。系统需要如何配置?希望说的详细点。
大神们请指点一下。。。
谢谢~~~

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
解决视频播放器找不到解码器问题
打开视频播放器,我经常使用的qq影音精简版居然什么格式的视频都不能播放了(提示文件无法渲染),这时候我怀疑快播不能播放也是因为系统缺少dll文件了(提示文件格式不正确);设置了好长时间还是不行网上给出的资料大多数是视频文件损坏,下载最新版,什么什么的一大堆都不管用,最后使用暴风居然可以播放,不得不佩服暴风强大的解码器,但是使用暴风后视频加速功能居然不能用,最基本的avi格式也不能加速播放;于是有了
Qt5.3 第二次 一个视频播放器的困难和解决办法
对于一个刚入门的小白来说,每一步摸索都是艰辛而快乐的
QT雷达显示界面
有一定的参考价值,写了串口的函数,支持QT5.5.1,用的系统是Ubuntu15.10
centos7下视频解码播放环境搭建(ffmpeg等库编译)
1.软件环境 操作系统环境:centos7 ffmpeg源码: github上的master版本(当前官网的3.4.1版本有bug,在主干中修复了'x264_bit_depth' undeclared) x264源码:x264-20180201版本 SDL源码:SDL1.2 Yasm源码:yasm1.3.0 2.编译与安装 设置环境变量:(可以在/root/.bashrc脚本中设
unity3d研究之视频播放
写在前面: 首先需要安装qucktime 播放器,并升级至专业版,注册码请找度娘。安装完之后,如果发现unity还是无法解析视频文件至movietexture,可以尝试重启电脑,重新导入视频文件。导入操作可能会导致unity无响应,需要等待几分钟。如果导入成功,untiy会自动解析出视频的纹理和音频。如图: Unity支持的播放视频格式有.mov、.mpg、.mpeg、.mp4、.av
unity播放视频问题杂谈
我们经常会看到一个游戏打开的时候会播放一段游戏的背景视频,或者是宣传视频,那么这些视频是怎么被加载到游戏中播放的呢? MovieTexture 这个是目前来说最常见的播放本地视频的方式。首先,我们要知道Unity标准接口支持的播放视频格式有.mov、.mpg、.mpeg、.mp4、.avi和.asf。那么这些视频格式是可以被转换成Unity可以操作的MovieTexture的。当然为了要在Uni
Ubuntu15.10版本apt源地址笔记
Ubuntu原带的apt源地址很多软件下不了,不好用,网上找了一大堆的国内源地址,有些也不能用,试了很多终于找到一个合适的,所以记录一下以免忘记。 deb http://mirrors.yun-idc.com/ubuntu/ wily main restricted universe multiverse deb http://mirrors.yun-idc.com/ubunt
Fedora21 安装视频播放解码器
首先启用RPM Fusion软件源: sudo rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.n
Centos7 解决totem不能播放的问题
Centos7 安装totem播放器详细步骤,其他rhel7的发行版本应该也适用但不保证
ubuntu 15.10下cmake 的安装
因为原先ubuntu自带的cmake有点旧,就想着安装个最新的,可是直接安装卡在了某一步上,后面有说明。现将正确的安装方法列出来。 1.卸载原有的版本 sudo apt-get autoremove cmake 2. 下载最新的cmake :https://cmake.org/download/ 3. 解压:tar -xzvf cmake.tgz  进入解压的文件; cd cmake