2 qq 33833831 qq_33833831 于 2016.04.16 09:43 提问

andoroid studio 更新2.0后 出错

随便建立一个任务 都跑不起来 我并没有调用google服务

 [LegacyBackupAccountManager] Fail to get legacy transport context.
                                         android.content.pm.PackageManager$NameNotFoundException: Application package com.google.android.backup not found
                                             at android.app.ContextImpl.createPackageContextAsUser(ContextImpl.java:2172)
                                             at android.app.ContextImpl.createPackageContext(ContextImpl.java:2148)
                                             at android.content.ContextWrapper.createPackageContext(ContextWrapper.java:671)
                                             at android.content.ContextWrapper.createPackageContext(ContextWrapper.java:671)
                                             at com.google.android.gms.backup.as.<init>(SourceFile:47)
                                             at com.google.android.gms.backup.BackupTransportMigratorService.a(SourceFile:150)
                                             at com.google.android.gms.backup.BackupTransportMigratorService.onHandleIntent(SourceFile:82)
                                             at android.app.IntentService$ServiceHandler.handleMessage(IntentService.java:65)
                                             at android.os.Handler.dispatchMessage(Handler.java:102)
                                             at android.os.Looper.loop(Looper.java:135)
                                             at android.os.HandlerThread.run(HandlerThread.java:61)

2个回答

Jacky0319
Jacky0319   2016.04.16 10:34

我的初步意见, 颁本兼容性很差 ,非常头疼

luochoudan
luochoudan   Ds   Rxr 2016.04.16 13:40

应该是调用了谷歌的接口,没注意到,换个project试试

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Android studio升级导致原有工程出错的解决方法
AS1.5发布,修复了不少BUG,编译速度也大幅提升,所以把一直用的1.2升级到1.5,但是导入原有的工程时,由于Gradle版本问题导致工程无法编译通过,先解决方法如下: 1、首先找到工程目录下的build.gradle,dependencies { classpath 'com.android.tools.build:gradle:1.2.2' // NO
Android Studio更新后Gradle Build/Refresh失败的问题解决方案
Gradle介绍: Gradle是一个基于Apache Ant和Apache Maven概念的项目自动化建构工具。它使用一种基于Groovy的特定领域语言(DSL)来声明项目设置,抛弃了基于XML的各种繁琐配置。面向Java应用为主。当前其支持的语言限于Java、Groovy和Scala,计划未来将支持更多的语言。 问题原因 Android Studio(AS)的更新后,如果Gradle...
android studio升级后的各种错误解决
第一种:jar冲突 > com.Android.build.api.transform.TransformException: com.android.builder.packaging.DuplicateFileException: Duplicate files copied in APK META-INF/maven/com.squareup.okio/okio/pom.xml
Windows 10 更新补丁后Visual Studio 2017 运行项目出现错误
问题:今天更新了Windows 10(版本 1709)推送最新补丁后,打开Visual Studio 2017运行Web项目,都出现“指定的参数超出有效值的范围 参数名:site”,如下图:解决方案:打开“控制面板” -> “程序和功能”-> 找到“IIS 10.0 Express” 程序,选中并点击“修复”按钮,如下图:待系统完成修复处理后,重新打开Visual Studio 2017 运行We
关于android studio IDE升级到3.0之后出现的配置和项目兼容问题
1.编码问题,无所为就是出现,**编码出现错误,解决方案,直接在build gradle文件中配置,全局编码属性tasks.withType(JavaCompile) { options.encoding = &quot;GB2312&quot; } /* tasks.withType(Compile) { options.encoding = &quot;UTF-8&quot; }*/ /*android {...
Android studio更新自身或者SDK以后出错问题解决
通过Androidstudio更新自身或者SDK以后,经常会出现一些问题,很多都是配置需要修改造成的。一、gradle插件版本太老,点击给出的解决方法无效,打开文件又看不出所以然 Error:(1, 0) The android gradle plugin version 3.0.0-alpha1 is too old, please update to the latest version.
更新AndroidStudio导致依赖库使用出错
下午AndroidStudio提示更新,然后就点了下去更新到了2.3.1,结果更新完成之后加载依赖包的时候出现了点小问题。。。平时加载我所需要的依赖包的时候就通过:Fiie->Project Structure->Dependencies->+>Library dependency。比如我这里要使用cyclerview这个包。刚开始没怎么注意就直接点OKle,但是之后却莫名其妙报错了。建议让我在An
android studio升级到3.0之后的一个运行错误
android studio升级到3.0之后,编译时报的错误都处理完毕了,但是运行时还是报错,具体错误:Caused by: java.lang.ClassNotFoundException: Didn't find class "com.igexin.download.DownloadProvider" on path: DexPathList[[zip file "/data/app/co
Android Studio 2.3 导入外部类错误
错误信息: Error:Execution failed for task ':app:transformResourcesWithMergeJavaResForDebug'. > com.android.build.api.transform.TransformException: com.android.builder.packaging.DuplicateFileException: D
Android studio更新到3.0后问题解决
问题1: 自定义打包问题提示Cannot set the value of read-only property ‘outputFile’ for ApkVariantOutputImpl_Decorated{apkData=Main{type=MAIN, fullName=debug, filters=[]}} of type com.android.build.gradle.internal.