2 leifengpeng leifengpeng 于 2016.04.17 11:07 提问

mac Eclipse Unsupported major.minor version 52.0问题 10C

mac下使用Eclipse IDE for Java Developers(Mars.1 Release (4.5.1))编译android项目(使用的是ADT23)
报:
Errors occurred during the build.
Errors running builder 'Android Package Builder' on project 'showDownTip'.
com/android/dx/command/dexer/Main : Unsupported major.minor version 52.0
机子装了jdk1.7.0.。
图片说明
图片说明
求解!!!!!

4个回答

CSDNXIAOD
CSDNXIAOD   2016.04.17 11:12

eclipse 报错Unsupported major.minor version 52.0
Unsupported major.minor version 52.0 解决
Unsupported major.minor version 52.0
----------------------biu~biu~biu~~~在下问答机器人小D,这是我依靠自己的聪明才智给出的答案,如果不正确,你来咬我啊!

xiongzirui
xiongzirui   2016.04.18 09:06

是jdk版本的问题,我也遇到过,你试试换个jdk版本试试,我遇到过这个问题

xiongzirui
xiongzirui   2016.04.18 09:08

应该是jdk版本高了,换低版本jdk试试

xiongzirui
xiongzirui   2016.04.18 09:13

这个可能是你先用过高版本的jdk,所以eclipse编译级别为1.8,选中你的java工程,然后从菜单选中Project=>Properties=>Java Complier 选1.7试试

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
eclipse运行项目报错:Unsupported major.minor version 52.0
从Android Studio项目跳回到Eclipse跑项目,编译后报错,如下图所示: 看了下报错信息,主要是:Unsupported major.minor version 52.0.意思是说不支持52.0版本.我再网上查了很多资料,都没有合适的回答,看到一个老外的总结,简单又详细(原文出处:https://stackoverflow.com/questions/22489
eclipse 运行时异常 Unsupported major.minor version 52.0 原因
编程中遇到此异常Unsupported major.minor version 52.0  (1.8jdk jar包与 1.8以下低版本jdk不匹配) 经百度查找原因后,发现是工程中某个jar包的版本(jar包编译时的所用的jdk版本)高于工程build path中jdk的版本; 在将build path中jdk的版本调整与jar包匹配后,解决异常。
Android Eclipse:Unsupported major.minor version 52.0
Unsupported major.minor version 52.0
eclipse报 Unsupported major.minor version 52.0错解决办法
前几天在AS中升级了android sdk,今天用eclipse编译时竟然报错了, com/android/dx/command/dexer/Main : Unsupported major.minor version 52.0。 在网上搜了不少解决办法,基本都是把jdk版本改成1.7,或者安装1.8然后把工程统一改成1.8版本。 可是,我希望的是基于1.7版本编译的,因为我要向第三方提供j
eclipse 报错Unsupported major.minor version 52.0
错误详情: 解决办法: 1.确定jdk环境配置 a) 原因:从高版本JDK换成低版本JDK报错Unsupported major.minor version 52.0(major.minor version 52.0是jdk1.7) b)  出现这个情况是我把Properties中java build path-->Libraries中的JVM8换成JVM7 之后运行就报错了
eclipse运行android工程时出现Unsupported major.minor version 52.0错误
最近在运行工程时意外出现Unsupported major.minor version 52.0的错误 具体现象是:eclipse编译是不报错的,但是在运行android工程时,在最后的lauching阶段时会弹出错误的提示窗口: 在网上搜的关于Unsupported major.minor version 52.0问题的解决方案都是建议修改jdk版本的,但是仔细想一想其实不是
linux Jetty安装后启动报错-UnsupportedClassVersionError---Unsupported major.minor version 52.0
linux 上第一次装Jetty后。 运行报错如下 Exception in thread "main" java.lang.UnsupportedClassVersionError: org/eclipse/jetty/start/Main : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defin
Unsupported major.minor version 52.0错误分析及解决
昨天有个java小程序在本地(windows)下跑着没有问题,但是到了ubantu上用 java  -jar  XXX.jar  执行总是报 Unsupported major.minor version 52.0  的错误。 经过百度发现是ubantu安装的JDK版本过低的原因(ubantu:1.6 ;  windows:1.7,低版本不能兼容高版本)。 所以只能卸载ubantu上的
gradle 构建错误:Unsupported major.minor version 52.0 解决办法
GitHub 上 clone 了一个项目,构建时报了这个错,Unsupported major.minor version 52.0 这个 major.minor 是什么鬼?stackoverflow 上一个回答说 The issue is because of Java version mismatch. Referring to the Wikipedia Java Class Refer
org/eclipse/jetty/server/Handler : Unsupported major.minor version 52.0
记录在java中使用jetty是遇到的错误 jdk版本与jetty版本不匹配问题 Exception in thread "main" java.lang.UnsupportedClassVersionError: org/eclipse/jetty/server/Handler : Unsupported major.minor version 52.0 at java.la