为什么我asp.net的环境变量已经设置好了,VS2013的网站程序还运行不起来

我已经设置好了,运行的时候还是显示这样的代码:

HTTP 错误 403.14 - Forbidden

Web 服务器被配置为不列出此目录的内容。

最可能的原因:
•没有为请求的 URL 配置默认文档,并且没有在服务器上启用目录浏览。

可尝试的操作:
•如果不希望启用目录浏览,请确保配置了默认文档并且该文件存在。
• 启用目录浏览。 1.转到 IIS Express 安装目录。
2.运行 appcmd set config /section:system.webServer/directoryBrowse /enabled:true 以在服务器级别启用目录浏览。
3.运行 appcmd set config ["SITE_NAME"] /section:system.webServer/directoryBrowse /enabled:true 以在网站级别启用目录浏览。

•确认网站或应用程序配置文件中的 configuration/system.webServer/directoryBrowse@enabled 属性已设置为 true。

详细错误信息:

模块
DirectoryListingModule

通知
ExecuteRequestHandler

处理程序
StaticFile

错误代码
0x00000000

请求的 URL
http://localhost:15584/

物理路径
C:\Users\89703\Desktop\web\aspnet_client\asp.net-学生成绩管理系统

登录方法
匿名

登录用户
匿名

请求跟踪目录
C:\Users\89703\Documents\IISExpress\TraceLogFiles\ASP.NET-学生成绩管理系统(1)

更多信息:
当没有在 URL 中指定文档,没有为网站或应用程序指定默认文档,或者没有为网站或应用程序启用目录列表时,便会出现此错误。此设置可能是有意禁用的,以保护服务器内容的安全。
查看更多信息 »

查看全部
Simon_ever
Eason_ever
2016/04/22 12:29
  • asp.net
  • 点赞
  • 收藏
  • 回答
    私信

1个回复