androidstudio 问题 怎么解决?为什么

androidstudio 问题 minSdk(API 23,N Preview )!=deviceSdk(API 23)为什么怎么办
大神大神,急救。前几天学android studio ,不知道为什么运行android 应用的时候总是这样,为什么?怎么解决?
图片说明
刚刚开始学android,想调试一下小程序Hello World,不知道为什么出现这样的情况,求大神指教。
原码贴上:
package sixping.com.codeview;

import android.app.Activity;
import android.os.Bundle;
import android.view.View;
import android.view.ViewGroup;
import android.widget.Button;
import android.widget.LinearLayout;
import android.widget.TextView;

public class MainActivity extends Activity {
//当第一次创建该Activity时回调该方法
@Override
public void onCreate(Bundle savedInstanceState){
super.onCreate(savedInstanceState);
//创建一个线性布局管理器
LinearLayout layout=new LinearLayout(this);
//设置该Activity显示Layout
super.setContentView(layout);
layout.setOrientation(LinearLayout.VERTICAL);
//创建一个TextView
final TextView show =new TextView(this);
//创建一个按钮
Button bn =new Button(this);
bn.setText(R.string.app_name);
bn.setLayoutParams(new ViewGroup.LayoutParams(ViewGroup.LayoutParams.WRAP_CONTENT,ViewGroup.LayoutParams.WRAP_CONTENT));
//向layout容器中添加TextView
layout.addView(show);
//向layout容器中添加按钮
layout.addView(bn);
//为按钮绑定一个事件监听器
bn.setOnClickListener(new View.OnClickListener(){
@Override
public void onClick(View v){
show.setText("Hello , Andriod , "+new java.util.Date());
}
});

}

}

不管哪一个程序,运行的时候都是这样的,为何?
百度了一下,也不知道咋办。求大神指教啊。

3个回答

你选的最低版本太高了,你的模拟器或者真机的Android版本低于你项目的最低版本,所以不行,最低版本应该要小于或者等于你运行环境的版本。

这个问题就好像这个 3.1(你选的可运行最低sdk版本) != 3(你的模拟器sdk版本)一样,把build.gradle中的minSdkVersion改低一点应该就行了

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问