pkhnshdp
2016-04-28 03:22
采纳率: 0%
浏览 1.7k

dynamic web转成maven项目,mvc版本太高导致拦截器报错

原项目是可以运行,把mvc版本改成3.0也可以正常使用,是什么原因
图片说明
图片说明
图片说明
图片说明

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • pkhnshdp 2016-04-28 03:26

    补充:
    org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 24 in XML document from ServletContext resource [/WEB-INF/yc-servlet.xml] is invalid; nested exception is org.xml.sax.SAXParseException; systemId: http://www.springframework.org/schema/mvc/spring-mvc-4.2.xsd; lineNumber: 24; columnNumber: 20; cos-all-limited.1.2: An ''all'' model group must appear in a particle with '{'min occurs'}'='{'max occurs'}'=1, and that particle must be part of a pair which constitutes the '{'content type'}' of a complex type definition.

    Caused by: org.xml.sax.SAXParseException; systemId: http://www.springframework.org/schema/mvc/spring-mvc-4.2.xsd; lineNumber: 24; columnNumber: 20; cos-all-limited.1.2: An ''all'' model group must appear in a particle with '{'min occurs'}'='{'max occurs'}'=1, and that particle must be part of a pair which constitutes the '{'content type'}' of a complex type definition.

    评论
    解决 无用
    打赏 举报
  • pkhnshdp 2016-05-04 10:17

    自己解决,maven出现问题首先检查有没有jar包版本冲突~,换个jar包就OK了

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题