hezejining
hezejining
采纳率0%
2016-05-29 11:42 阅读 1.8k

opencv3.1.0交叉编译 使用摄像头 编译出错

opencv3.1.0交叉编译:

宿主机:ubuntu 14.04
交叉编译工具:gcc-4.6.2-glibc-2.13-linaro

在使用Cmake-gui配置时,因为要使用摄像头(OV3640)取图像,进行图像处理,所以将Operating System填为Linux, 并将WITH_V4L勾选上,之后执行make命令,总是编译错误,提示许多的库找不到,如下图中所示; 如果将Operating System填为arm-linux,没有勾选WITH_V4L,则可以make编译通过,但在arm开发板上用OpenCV打不开摄像头,isOpened ()返回值是false。请帮忙分析问题原因,希望给提供些正确的解决办法,非常感激!

勾选WITH_V4L 编译错误信息勾选WITH_V4L 编译错误信息
cmake-gui 配置为Linux
cmake-gui 配置为arm-linux

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

1条回答 默认 最新

  • xyrmgzt xyrmgzt 2016-10-07 17:39

    叉编译 使用摄像头 编译出错
    opencv3.1.0交叉编译:
    宿主机:ubuntu 14.04
    交叉编译工具:gcc-4.6.2-glibc-2.13-linaro
    在使用Cmake-gui配置时,因为要使用摄像头(OV3640)取图像,进行图像处理,所以将Operating System填为Linux, 并将WITH_V4L勾选上,之后执行make命令,总是编译错误,提示许多的库找不到,如下图中所示; 如果将Operating System填为arm-linux,没有勾选WITH_V4L,则可以make编译通过,但在arm开发板上用OpenCV打不开摄像头,isOpened ()返回值是false。请帮忙分析问题原因,希望给提供些正确的解决办法,非常感激!

    点赞 评论 复制链接分享

相关推荐