_柳子 2013-10-08 10:43 采纳率: 50%
浏览 5777
已采纳

.NoClassDefFoundError: org/eclipse/jdt/internal/compiler/ast/Expression

项目是struts2.3.15+spring3,搭建后,用jetty正常启动后,访问jsp时Caused by: java.lang.ClassNotFoundException: org.eclipse.jdt.internal.compiler.ast.Expression的问题。
部分maven配置:

         <dependency>
        <groupId>org.mortbay.jetty</groupId>
        <artifactId>jetty</artifactId>
        <version>${jetty.version}</version>
    </dependency>               
    <dependency>
        <groupId>org.mortbay.jetty</groupId>
        <artifactId>jsp-2.1-jetty</artifactId>
        <version>${jetty.version}</version>
    </dependency>
    <dependency>
        <groupId>org.mortbay.jetty</groupId>
        <artifactId>jsp-2.1-glassfish</artifactId>
        <version>2.1.v20091210</version>
    </dependency>
    <dependency>
        <groupId>org.mortbay.jetty</groupId>
        <artifactId>jsp-api-2.1-glassfish</artifactId>
        <version>2.1.v20091210</version>
    </dependency>
</dependencies>
<properties>
    <jetty.version>6.1.26</jetty.version>
</properties>

<!-- jetty -->

org.mortbay.jetty
maven-jetty-plugin
${jetty.version}

<!-- Log to the console. -->

<!-- This doesn't do anything for Jetty, but is a workaround for a
Maven bug that prevents the requestLog from being set. -->
true

10

src/main/java
src/main/webapp/WEB-INF
src/main/resources

求解,是jetty版本过低导致的么?
servlet版本是2.5 用的IDE是eclipse3.6
求解 谢谢各位大大

  • 写回答

1条回答 默认 最新

  • _柳子 2013-10-09 02:35
    关注

    问题已解决,由于本地.m2下没清理以往曾用过的jetty高版本jar包,导致包冲突的低级问题,清理.m2重新下载依赖即可

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥15 怎样采集全国最新个体工商户数据
  • ¥20 我是一名大学生,想学习java是自学还是报培训班呢
  • ¥15 pycharm该如何爬取网易云歌曲下的评论?
  • ¥15 java调用sap webservice问题
  • ¥20 如何完全复现何恺明resnet论文里的结果,有代码吗,获得论文中的结果(如下图)
  • ¥15 mysql如果表行行数小于1000条还需要分区吗
  • ¥20 有关matlab自定义特殊算符的问题
  • ¥15 第15届蓝桥杯选拔赛斗鱼养殖场
  • ¥15 在vivado的FIFO使用中,FIFO有没有提供可以输出内部存储空间状态的端口?
  • ¥15 C++ QT内存数据匹配对比指导