LAIWENJIEJIJIALI
vall.lai
2016-06-02 06:28
采纳率: 100%
浏览 3.0k
已采纳

Eclipse环境下使用android.support.design包的一些问题

最近在看NavigationView,所以涉及到了Design这个包,因为习惯上用eclipse所以就在github上找了些例子看,最后就用了这个例程
导入到我自己的工作目录下,也添加了下面这3个包
android support library v7 appcompat.
android design support library.
cardview library
完成后没有任何报错,但一运行就出现这个问题
Could not find class 'android.support.design.internal.NavigationMenuView', referenced from method android.support.design.internal.NavigationMenuPresenter.getMenuView
详细的logcat如下
图片说明
图片说明
图片说明
图片说明
请问弄过这个包和类的帮我看看是哪的问题

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • LAIWENJIEJIJIALI
    vall.lai 2016-06-03 02:11
    已采纳

    问题已解决,在eclipse下使用android.support.design包需要导入下面这些包
    android support library v7 appcompat.
    android design support library.
    cardview library
    recycleview library
    应该说我这个项目需要这些吧,后面两个包其实都算是v7包里的?
    图片说明
    design包是依赖于 v7 appcompat包的,但是我都导入了也没报重定义,这个我也不知道,不过去掉也是可以运行的。

    点赞 评论

相关推荐