请问这是什么异常?怎么解决?

用Spring+myBatis整合发生的异常
图片说明

这是映射文件:
图片说明

5个回答

应该是代码编译版本的问题,查查你的jdk版本,编译版本,估计可能是使用的jdk和编译版本不匹配

mengqingyu555
暮云收尽溢清寒 jdk7以上就可以,应该没有冲突
4 年多之前 回复
haowuwenhua
haowuwenhua 请问tomcat8.0跟JDK8.0配合使用有没有冲突?
4 年多之前 回复

spring配置的问题,没有找到你的dao实现类。

You most likely have conflicting Spring dependencies on your classpath. It's probably an old spring-asm JAR.

Run mvn dependency:tree -Dincludes=:spring*:: and check for conflicts. The best way to avoid these is to put a dependency on the spring-framework-bom in your project's dependencyManagement section, as follows

    <dependency>
        <groupId>org.springframework</groupId>
        <artifactId>spring-framework-bom</artifactId>
        <version>4.0.3.RELEASE</version>
        <type>pom</type>
        <scope>import</scope>
    </dependency>

These versions are supported.

贴出你的sql映射文件看看。

haowuwenhua
haowuwenhua 映射文件贴出了,帮忙看看
4 年多之前 回复

你的spring配置文件中有注入AdminDao吗?

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问