muerbingsha
sharkdeng2020
2016-06-12 06:09

ubuntu 14.04 装gtk2.0出错

我用sudo apt-get install libgtk2.0-dev想安装gtk,但出现以下错误:

Reading package lists... Done
Building dependency tree

Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgtk2.0-dev : Depends: libglib2.0-dev (>= 2.27.3) but it is not going to be installed
Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
Depends: libatk1.0-dev (>= 1.29.2) but it is not going to be installed
Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

查了网上,有1)sudo apt-get update。试过,没用

有人知道怎么解决吗?非常感谢!


  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

2条回答

为你推荐

换一换