zhkx123
zhkx123
采纳率83.3%
2016-06-28 10:06 阅读 2.7k
已采纳

dagger2编译失败问题 无法运行

正在学习dagger2 ,但是写好一个例子,运行时 失败 请问是什么原因???

报的异常如下:

Error:Execution failed for task ':app:transformClassesWithDexForDebug'.

com.android.build.api.transform.TransformException: com.android.ide.common.process.ProcessException: java.util.concurrent.ExecutionException: com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command 'C:\Program Files\Java\jdk1.7.0_79\bin\java.exe'' finished with non-zero exit value 3
build.gradle的配置如下 :

apply plugin: 'com.android.application' apply plugin: 'com.neenbedankt.android-apt' android {
compileSdkVersion 23 buildToolsVersion "23.0.3" defaultConfig { applicationId "com.example.app.simpledagger" minSdkVersion 15 targetSdkVersion 23 versionCode 1 versionName "1.0" multiDexEnabled true }
buildTypes {
release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' }
}
}
buildscript {
repositories {
jcenter()
}
dependencies {
classpath 'com.neenbedankt.gradle.plugins:android-apt:1.4' }
}

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
testCompile 'junit:junit:4.12' // compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.google.dagger:dagger:2.5' compile 'com.google.dagger:dagger-compiler:2.5' provided 'org.glassfish:javax.annotation:10.0-b28' }

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

1条回答 默认 最新

  • 已采纳
    zhkx123 zhkx123 2016-06-29 08:12

    知道原因了 要把 classpath 'com.neenbedankt.gradle.plugins:android-apt:1.4' 这句放到项目的build.gradle 而不是module的build.gradle

    基于 Android studio

    点赞 评论 复制链接分享

相关推荐