php7连接oracle11g问题

官网下载最新的php7.0连接oracle11g数据库连接不上什么问题啊,php里ext少了那么扩展。怎么连接得上啊?
下载缺少的放ext里面在php.ini开启,还是连接不上。oracle的客户端是免安装版的已经配置环境变量,plsqldev是可以访问oracle的。apache也配置对了php。php7.0只有一个php_oci8_12c.dll这个扩展。
$conn = ocilogon('user','abc123','127.0.0.1:1521/orcl');
就会提示不存在这个函数,到底还有哪里要配置,麻烦大神指点指点

2个回答

同样的问题,请问解决了没

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
如何使用PHP 7连接到Oracle 11?

<div class="post-text" itemprop="text"> <p>The problem is, i have an application that the client demands it runs under Oracle DB.</p> <p>I already have Client 11c installed, as well as Oracle Database.</p> <p>My PHP was built using the following configuration:</p> <pre><code>"--with-pdo-oci=c:\php-snap-build\deps_aux\oracle\x64\instantclient_12_1\sdk,shared" </code></pre> <p>So i copied the instant client to this folder, and put it in the system path as well.</p> <p>Still i'm getting:</p> <pre><code>PS C:\php&gt; php -m PHP Warning: PHP Startup: Unable to load dynamic library 'pdo_oci' (tried: ./ext\pdo_oci (The specified module could not be found.), ./ext\php_pdo_oci.dll (%1 is not a valid Win32 application.)) in Unknown on line 0 </code></pre> <p>When trying to run php -m with display_startup_errors = on</p> <p>I've tried download other PHP Binaries and looked up on every possible corner of the internet.</p> <p>Can anyone help me solve this?</p> <p>P.S. PDO is a must.</p> <p>Thanks in advance!</p> </div>

使用php 5.6连接到远程oracle数据库

<div class="post-text" itemprop="text"> <p>I have two machines:</p> <ol> <li>Windows 7 x64</li> <li>Windows server 2012 R2 x64</li> </ol> <p>In the first machine I installed:</p> <ul> <li>Apache 2.4 TS VC11</li> <li>PHP 5.6.19 TS VCC</li> <li><a href="http://windows.php.net/downloads/pecl/releases/oci8/2.0.8/" rel="nofollow">php_oci8-2.0.8-5.6-ts-vc11-x64</a></li> </ul> <p>I connect to local/remote oracle databases without problem. </p> <p>The second machine is a fresh server installation, it does not have local oracle dabatases, nothing. The idea is to connect to a remote oracle instace. So I made the same installation (apache and php with same versions as first machine), but the first error I found was that the oci8_11g extension is not loaded. My question is, do I need to install some "driver" or "client" for oracle in this server? The apache instance and php work as expected except with error mentioned.</p> </div>

PHP ODBC连接到Oracle,没有UTF-8

<div class="post-text" itemprop="text"> <p>I am having a problem to get UTF-8 support, when i try to connect to Oracle throught ODBC Data Source with PHP <code>odbc_connect()</code>.</p> <p>Also all of this is being done under 32bits. I am using oracle XE DB for testing and instaclient11_2 32bit drivers, ODBC Data source 32it +placed on WAMP32bit server.</p> <p>Althougt i have same result with Oracle 12c DB and client Home 10g 32bit drivers.</p> <p>@TODAY Tested this all with 64bit instanclient drivers, added ODBC 64DataSource on 64bit WAMP Server. Still no luck to display chars corretly...</p> <pre><code>&lt;html&gt; &lt;head&gt; &lt;meta http-equiv="Content-Type" content="text/html; charset=utf-8" /&gt; &lt;/head&gt; &lt;body&gt; &lt;?php $connect = odbc_connect("XEXDB", "username", "password"); $query = "SELECT col, 'čaļi' FROM TESST"; $result = odbc_exec($connect, $query); while(odbc_fetch_row($result)){ $name = odbc_result($result, 1); $surname = odbc_result($result, 2); echo "$name, $surname &lt;br/&gt;"; } odbc_close($connect); ?&gt; </code></pre> <p> </p> <p>Result i get from this code:</p> <pre><code>?A?IS, A?aA?i Gunt?rs Salts, A?aA?i </code></pre> <p>But should be:</p> <pre><code>ĶAĶIS, čaļi Guntārs Šalts, čaļi </code></pre> <p>I cant find how to write <code>$dsn</code> for <code>odbc_connect()</code> to force <code>charset=utf-8</code>, so far no luck to get working $conn_string with <code>charset=utf-8</code>.</p> <p>Also tried to use <code>utf8_encode()</code> and <code>utf8_decode()</code>(using this was me being desperate).</p> <p>Does anyone have had similar problem, or maybe someone have some suggestions i could try?</p> </div>

无法使用PHP与XAMPP连接到Oracle Database 11g

<div class="post-text" itemprop="text"> <p>Installed XAMMP and PHP 5.6.31 using Oracle instaclient_11_2 already in the C:\drive. Edited and enabled <code>extension=php_oci8_11g.dll</code> in <code>php.ini</code>. Installed <code>php_oci8_11g.dll</code> in <code>C:\xampp\php\ext</code>.</p> <p>What did i miss? </p> <p>PHP returns: </p> <blockquote> <p>Fatal error: Call to undefined function oci_connect() in C:\xampp\htdocs\OC\oci8.php on line 3</p> </blockquote> <pre><code>&lt;?php $conn = oci_connect('hr', 'hr', 'localhost/orcl'); if (!$conn) { $e = oci_error(); trigger_error(htmlentities($e['message'], ENTS_QUOTES),E_USER_ERROR); } else echo "connection successful"; ?&gt; </code></pre> </div>

PHP连接到远程Oracle DB

<div class="post-text" itemprop="text"> <p>I am having trouble connecting to a remote oracle DB from PHP. I have been following instructions on the web and when I try to install oci8, I get the following error (last 3 lines):</p> <pre><code>sudo pecl install oci8-1.3.4.tgz [sudo] password for denny: downloading oci8-1.3.4.tgz ... Starting to download oci8-1.3.4.tgz (134,240 bytes) .............................done: 134,240 bytes 10 source files, building running: phpize Configuring for: PHP Api Version: 20121113 Zend Module Api No: 20121212 Zend Extension Api No: 220121212 Please provide the path to the ORACLE_HOME directory. Use 'instantclient,/path/to/instant/client/lib' if you're compiling with Oracle Instant Client [autodetect] : /opt/oracle/instantclient building in /tmp/pear/temp/pear-build-rootGYzIDo/oci8-1.3.4 running: /tmp/pear/temp/oci8/configure --with-oci8=/opt/oracle/instantclient checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for a sed that does not truncate output... /bin/sed checking for cc... cc checking whether the C compiler works... yes checking for C compiler default output file name... a.out checking for suffix of executables... checking whether we are cross compiling... no checking for suffix of object files... o checking whether we are using the GNU C compiler... yes checking whether cc accepts -g... yes checking for cc option to accept ISO C89... none needed checking how to run the C preprocessor... cc -E checking for icc... no checking for suncc... no checking whether cc understands -c and -o together... yes checking for system library directory... lib checking if compiler supports -R... no checking if compiler supports -Wl,-rpath,... yes checking build system type... x86_64-unknown-linux-gnu checking host system type... x86_64-unknown-linux-gnu checking target system type... x86_64-unknown-linux-gnu checking for PHP prefix... /usr checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib checking for PHP extension directory... /usr/lib/php5/20121212 checking for PHP installed headers prefix... /usr/include/php5 checking if debug is enabled... no checking if zts is enabled... no checking for re2c... no configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers. checking for gawk... gawk checking for Oracle (OCI8) support... yes, shared checking PHP version... 5.5.9, ok checking Oracle Install Directory... /opt/oracle/instantclient checking for ANSI C header files... yes checking for sys/types.h... yes checking for sys/stat.h... yes checking for stdlib.h... yes checking for string.h... yes checking for memory.h... yes checking for strings.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for unistd.h... yes checking size of long int... 8 checking if we're on a 64-bit platform... yes checking OCI8 libraries dir... configure: error: Oracle (OCI8) required libraries not found ERROR: `/tmp/pear/temp/oci8/configure --with-oci8=/opt/oracle/instantclient' failed </code></pre> <p>I downloaded the oracle instantclient, for linux 64-bit, from the oracle website (<a href="http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html" rel="nofollow">http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html</a>) and unzipped in the folder /opt/oracle. some help will be appreciated.</p> </div>

急!重赏!LINUX+PHP环境上连接ORACLE数据库提示权限拒绝的问题

在LINUX CentOS6.5+PHP5.6环境下,要连接使用Oracle 11g 现在有: (1)D机:数据库服务器,为Oracle 11g (2)C1台式机:安装有 LINUX CentOS6.5+PHP5.6环境和OCI8 (3)C2笔记本机:LINUX CentOS6.5+PHP5.6环境和OCI8 (4)一个PHP WEB程序 在C2机上,PHP WEB程序连接使用D机 oracle正常。 在C1机上,同样的PHP WEB程序连接使用D机 oracle 时,即使OCI8文件已经给最高权限文件和777,还是一直提示: SQLSTATE[HY000]:pdo_oci_handle_factory:ORA-12546:TNS:permission denied (/root/PDO_OCI-1.0/oci_driver.c:463) 请问应该如何解决?![图片说明](https://img-ask.csdn.net/upload/201803/14/1521036171_238370.png)

php用oci_connect()无密码连接oracle 提示权限不足

感谢浏览! Centos 6.2 php 5.3.6 oracle 11g oci8.so 1.4.4 用oci_connect("system","JCB410","VPMSDBS",null,OCI_DEFAULT); (VPMSDBS 为$ORACLE_SID) 和oci_connect("/","","php_ora_usr",null,OCI_CRED_EXT); (php_ora_usr 为wallet连接串) 均可以连接上 但用oci_connect("/","","VPMSDBS",null,OCI_CRED_EXT+OCI_SYSDBA); 链接时提示:oci_connect():ORA-01031:insufficient privileges

使用PHP连接到Oracle

<div class="post-text" itemprop="text"> <p>I am trying to connect to Oracle database which is not on my PC. I have installed Xampp, PHP and Oracle instant Client. I have added a windows environmental path to C:\instantclient_11_1. The Oci8 is enabled too when I check from phpinfo(). I have added the extension extension_dir = C:\php-5.4.0\ext to the php.ini and also enabled extension=php_oci8_11g.dll. Then when I try to connect to the database using the code below:</p> <pre><code> &lt;?php $conn = oci_connect('username', 'password'); $query = 'select table_name from user_tables'; ?&gt; </code></pre> <p>It says Warning: oci_connect(): ORA-12560: TNS:protocol adapter error. Could anyone help?</p> </div>

php(xampp)的oracle连接问题

<div class="post-text" itemprop="text"> <p>I need to connect oracle 11g database with my xampp server and I need both local and remote connection. For that what I did is first I installed the oracle 11g express edition and the downloaded the <code>instantclient-basic-nt-11.2.0.4.0</code> and placed the extracted folder <code>instantclient_11_2</code> in <code>C:\</code> then I set the environment variable (system variables) and my path value looks like this <code>path=C:\oraclexe\app\oracle\product\11.2.0\server\bin;C:\instantclient_11_2</code>.</p> <p>Then I removed the <code>;</code> before <code>extension=php_oci8.dll</code> and <code>extension=php_oci8_11g.dll</code> from the <code>php.ini</code> file. Then first I tried to connect with my local database:</p> <pre><code>$tns_turjo = '(DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.0.13)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = XE)))'; // tns of another pc $tns_ishrak = '(DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.0.18)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = XE)))'; // tns of my pc $conn = oci_connect('system', 'cibl123*#', $tns_turjo); if($conn) { echo "connected"; } else { echo "not"; } </code></pre> <p>When I pass <code>$tns_ishrak</code> it echoes <code>connected</code> but when I try to access the oracle database of another pc i.e. use the <code>$tns_turjo</code> then it echoes <code>not</code> and the error is </p> <pre><code>Message: oci_connect(): ORA-12170: TNS:Connect timeout occurred </code></pre> <p>I have also changed the username and password while connecting to another pc.</p> <p>N.B. After enabling the .dll extensions from the php.ini file whenever I start the Apache I get a pop up warning in xampp which is <code>Module 'oci8' is already loaded</code> </p> <p>How can I solve the remote connection issue?</p> </div>

从PHP oci8连接到oracle数据库

<div class="post-text" itemprop="text"> <p>I'm trying to access the ORACLE database from PHP, i'm using WampServer Version 2.2 Apache 2.4.2 – PHP 5.4.3 and oracle 11g. I tried many ways including :</p> <pre><code>&lt;?php if ($conn = oci_connect('sys as sysdba', '12345', '//localhost/orcl')) { print 'Successfully connected to Oracle Database!'; } else { $errmsg = oci_error(); print 'Oracle connection failed' . $errmsg['message']; } ?&gt; </code></pre> <p>i get the following error every time i execute:</p> <pre><code>Fatal error: Call to undefined function OCILogon() in C:\wamp\www\IDS\Index.php on line 3 </code></pre> <p>Does anyone know how to solve this ??</p> </div>

用PHP连接Oracle数据库服务器

<div class="post-text" itemprop="text"> <p>I'm developing a website in PHP that interacts with Oracle10g remote server database. I've googled on this topic a lot and couldn't find a solution, though i got some idea on tnsnames.ora file. I've installed WAMP in my machine. What are steps to connect to Oracle remote database?? Can any one explain it step by step?? I created a site which connects to MySQL datebase a year ago which wasn't this much tough.</p> <pre><code>$con = oci_connect('username', 'password', '//server ip:port/service name'); </code></pre> <p>It's throwing "Call to undefined function oci_connect()" error.</p> </div>

无法使用PHP连接到oracle

<div class="post-text" itemprop="text"> <p>I've searched everywhere in google for a solution but I'm still unable to connect to oracle using PHP.</p> <p>I have the following in my php file</p> <pre><code>$conn = oci_connect("username","password", "sid"); </code></pre> <p>However, when ever I try and access the php page, I am getting the same error </p> <pre><code>Fatal error: Call to undefined function oci_connect() in C:\xampp\htdocs\consult.php on line 5. </code></pre> <p>In XAMPP folders I've looked at the php.ini file and removed the leading semicolon so that I'm left with <code>extension=php_oci8_11g.dll</code>.</p> <p>I restarted XAMPP, and I'm getting oci8.dll doesn't exist. I then downloaded oracle instant client but I'm slightly confused as to which folder it is supposed to be placed in.</p> </div>

使用oracle 10g和php在单个数据库连接中执行多个查询

<div class="post-text" itemprop="text"> <p>I want to run multiple sql queries in a single database connection using oracle 10g and php. Here for every sql query queries I have to create database connection. Is there any way to run multiple sql queries in a single database connection or we have to fetch data this way only? Because when we have to run 50 queries, we have to write 50 times like below. </p> <pre><code>&lt;?php include("mydb.php"); // run query $sql6 = "select * from dat where to_char(WD,'dd/mm')='19/08'"; $stid6=oci_parse($conn, $sql6); // set array $arr6 = array(); if(!$stid6){ $e=oci_error($conn); trigger_error(htmlentities($e[message],ENT_QUOTES),E_USER_ERROR); } $r6=oci_execute($stid6); if(!$r6){ $e=oci_error($stid6); trigger_error(htmlentities($e[message],ENT_QUOTES),E_USER_ERROR); } // look through query while($row = oci_fetch_array($stid6,OCI_ASSOC)){ // add each row returned into an array $arr6[] = array(($row['WD']) , (float)$row['DATA']); } oci_free_statement($stid6); oci_close($conn); ?&gt; &lt;?php include("mydb.php"); // run query $sql7 = "select * from dat where to_char(WD,'dd/mm')='11/03'"; $stid7 = oci_parse($conn, $sql7); // set array $arr7 = array(); if(!$stid7){ $e=oci_error($conn); trigger_error(htmlentities($e[message],ENT_QUOTES),E_USER_ERROR); } $r7=oci_execute($stid7); if(!$r7){ $e=oci_error($stid7); trigger_error(htmlentities($e[message],ENT_QUOTES),E_USER_ERROR); } // look through query while($row = oci_fetch_array($stid7,OCI_ASSOC)){ // add each row returned into an array $arr7[] = array(($row['WD'])) , (float)$row['DATA']); } oci_free_statement($stid7); oci_close($conn); ?&gt; ................ ................ </code></pre> <p>*Pardon me, I forgot to mention that we have store day-wise data in different array. I mean to say that 11/03's data will store in arr1 and 19/08's data will be stored in arr2. Not in same array.</p> </div>

用jdbc:oracle:oci方式连接数据库时出现UnsatisfiedLinkError错误

我win7 64位系统,jdk是64位的1.7版本,oracle装的是32的10g,客户端跟服务器端都装了 ,我在用jdbc:oracle:oci方式连接数据库时连接失败,而用jdbc:oracle:thin方式就行,错误如下: java.lang.IllegalStateException: Failed to load ApplicationContext at org.springframework.test.context.TestContext.getApplicationContext(TestContext.java:308) at org.springframework.test.context.support.DependencyInjectionTestExecutionListener.injectDependencies(DependencyInjectionTestExecutionListener.java:109) at org.springframework.test.context.support.DependencyInjectionTestExecutionListener.prepareTestInstance(DependencyInjectionTestExecutionListener.java:75) at org.springframework.test.context.TestContextManager.prepareTestInstance(TestContextManager.java:321) at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.createTest(SpringJUnit4ClassRunner.java:211) at org.springframework.test.context.junit4.SpringJUnit4ClassRunner$1.runReflectiveCall(SpringJUnit4ClassRunner.java:287) at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15) at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.methodBlock(SpringJUnit4ClassRunner.java:289) at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.runChild(SpringJUnit4ClassRunner.java:231) at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:49) at org.junit.runners.ParentRunner$3.run(ParentRunner.java:193) at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:52) at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:191) at org.junit.runners.ParentRunner.access$000(ParentRunner.java:42) at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:184) at org.springframework.test.context.junit4.statements.RunBeforeTestClassCallbacks.evaluate(RunBeforeTestClassCallbacks.java:61) at org.springframework.test.context.junit4.statements.RunAfterTestClassCallbacks.evaluate(RunAfterTestClassCallbacks.java:70) at org.junit.runners.ParentRunner.run(ParentRunner.java:236) at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.run(SpringJUnit4ClassRunner.java:174) at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:86) at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:459) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:675) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:382) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:192) Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'sqlSessionFactory' defined in class path resource [beans.xml]: Invocation of init method failed; nested exception is java.lang.UnsatisfiedLinkError: E:\Ebook\JavaSE\develop\Oracle\product\10.2.0\client_1\BIN\ocijdbc10.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1420) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:519) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:456) at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:293) at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222) at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:290) at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:192) at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:567) at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:895) at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:425) at org.springframework.test.context.support.AbstractGenericContextLoader.loadContext(AbstractGenericContextLoader.java:84) at org.springframework.test.context.support.AbstractGenericContextLoader.loadContext(AbstractGenericContextLoader.java:1) at org.springframework.test.context.TestContext.loadApplicationContext(TestContext.java:280) at org.springframework.test.context.TestContext.getApplicationContext(TestContext.java:304) ... 24 more Caused by: java.lang.UnsatisfiedLinkError: E:\Ebook\JavaSE\develop\Oracle\product\10.2.0\client_1\BIN\ocijdbc10.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965) at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890) at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1880) at java.lang.Runtime.loadLibrary0(Runtime.java:849) at java.lang.System.loadLibrary(System.java:1088) at oracle.jdbc.driver.T2CConnection$1.run(T2CConnection.java:3135) at java.security.AccessController.doPrivileged(Native Method) at oracle.jdbc.driver.T2CConnection.loadNativeLibrary(T2CConnection.java:3131) at oracle.jdbc.driver.T2CConnection.logon(T2CConnection.java:221) at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:414) at oracle.jdbc.driver.T2CConnection.<init>(T2CConnection.java:132) at oracle.jdbc.driver.T2CDriverExtension.getConnection(T2CDriverExtension.java:78) at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:801) at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:38) at org.apache.commons.dbcp.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:582) at org.apache.commons.dbcp.BasicDataSource.validateConnectionFactory(BasicDataSource.java:1556) at org.apache.commons.dbcp.BasicDataSource.createPoolableConnectionFactory(BasicDataSource.java:1545) at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:1388) at org.apache.commons.dbcp.BasicDataSource.getConnection(BasicDataSource.java:1044) at org.apache.ibatis.mapping.VendorDatabaseIdProvider.getDatabaseProductName(VendorDatabaseIdProvider.java:76) at org.apache.ibatis.mapping.VendorDatabaseIdProvider.getDatabaseName(VendorDatabaseIdProvider.java:61) at org.apache.ibatis.mapping.VendorDatabaseIdProvider.getDatabaseId(VendorDatabaseIdProvider.java:49) at org.mybatis.spring.SqlSessionFactoryBean.buildSqlSessionFactory(SqlSessionFactoryBean.java:395) at org.mybatis.spring.SqlSessionFactoryBean.afterPropertiesSet(SqlSessionFactoryBean.java:295) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1477) at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1417) ... 37 more 这个有什么解决办法吗

求解oracle数据库一条sql查询出来

Oracle数据库表a有area,value,date三个字段,存放着两个地区每日的统计数据: Area Value date 海淀 12 2012-01-01 朝阳 19 2012-01-01 海淀 14 2012-01-02 请写出一条SQL语句得到如下格式结果: “日期、海淀统计数、朝阳统计数、总数” 如:2012-01-01、12、19、31

在oracle数据库,使用sqlplus输入查询命令后没有报错、不显示查询结果、也无法继续输入其他SQL命令。

请解答一下。谢谢! ![图片说明](https://img-ask.csdn.net/upload/202004/25/1587791475_531243.png) ``` 使用SELECT FOR UPDATE语句加锁。 --打开SQL*Plus客户端(会话1) SQL> UPDATE test SET name ='赵六' WHERE id=4; SQL> ROLLBACK; --再打开另一个SQL*Plus客户端(会话2) SQL> SELECT * FROM test FOR UPDATE NOWAIT; SQL> SELECT * FROM test FOR UPDATE WAIT 3; SQL> SELECT * FROM test FOR UPDATE; SQL> ROLLBACK; ```

无法解析ORA-12154:TNS:无法解析指定的连接标识符

<div class="post-text" itemprop="text"> <p>I am not able to solve this error I am getting only from the Web Browser. I am trying to connect to a remote Oracle DB using PDO_ODBC in PHP. I think all is well configured, because when I try to connect using sqlplus or isql all is OK! When I try to connect from the Web Browser, firstly it gives a successful connection but with only a simply refresh of the page I got the error in object.</p> <p>This is all my environment:</p> <pre><code>odbcinst -j unixODBC 2.3.1 DRIVERS............: /etc/odbcinst.ini SYSTEM DATA SOURCES: /etc/odbc.ini FILE DATA SOURCES..: /etc/ODBCDataSources USER DATA SOURCES..: /var/www/html/.odbc.ini SQLULEN Size.......: 8 SQLLEN Size........: 8 SQLSETPOSIROW Size.: 8 /etc/odbc.ini [esecns_test] Driver = OracleODBC-11g DSN = OracleODBC-11g ServerName = ESECNS_TEST UserID = **** Password = **** /etc/odbcinst.it [OracleODBC-11g] Description = Oracle ODBC driver for Oracle 11g Driver = /usr/lib/oracle/12.2/client64/lib/libsqora.so.12.1 Setup = FileUsage = 1 CPTimeout = 5 CPReuse = 5 Driver Logging = 7 [ODBC] Trace = Yes TraceFile = /tmp/odbc.log ForceTrace = Yes Pooling = No DEBUG = 1 Example driver definitions # Driver from the postgresql-odbc package # Setup from the unixODBC package [PostgreSQL] Description = ODBC for PostgreSQL Driver = /usr/lib/psqlodbcw.so Setup = /usr/lib/libodbcpsqlS.so Driver64 = /usr/lib64/psqlodbcw.so Setup64 = /usr/lib64/libodbcpsqlS.so FileUsage = 1 # Driver from the mysql-connector-odbc package # Setup from the unixODBC package [MySQL] Description = ODBC for MySQL Driver = /usr/lib/libmyodbc5.so Setup = /usr/lib/libodbcmyS.so Driver64 = /usr/lib64/libmyodbc5.so Setup64 = /usr/lib64/libodbcmyS.so FileUsage = 1 /etc/oracle/tnsnames.ora ESECNS_TEST = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.213.24)(PORT = 1521)) ) (CONNECT_DATA = (SERVICE_NAME = xxxxxx.xxxxxx.it) ) ) -bash-4.2$ ldd libsqora.so.12.1 linux-vdso.so.1 =&gt; (0x00007ffeed87c000) libdl.so.2 =&gt; /usr/lib64/libdl.so.2 (0x00007f5cc7a19000) libm.so.6 =&gt; /usr/lib64/libm.so.6 (0x00007f5cc7716000) libpthread.so.0 =&gt; /usr/lib64/libpthread.so.0 (0x00007f5cc74fa000) libnsl.so.1 =&gt; /usr/lib64/libnsl.so.1 (0x00007f5cc72e1000) librt.so.1 =&gt; /usr/lib64/librt.so.1 (0x00007f5cc70d8000) libaio.so.1 =&gt; /usr/lib64/libaio.so.1 (0x00007f5cc6ed6000) libresolv.so.2 =&gt; /usr/lib64/libresolv.so.2 (0x00007f5cc6cbc000) libclntsh.so.12.1 =&gt; /usr/lib/oracle/12.2/client64/lib/libclntsh.so.12.1 (0x00007f5cc3216000) libclntshcore.so.12.1 =&gt; /usr/lib/oracle/12.2/client64/lib/libclntshcore.so.12.1 (0x00007f5cc2c48000) libodbcinst.so.2 =&gt; /usr/lib64/libodbcinst.so.2 (0x00007f5cc2a36000) libc.so.6 =&gt; /usr/lib64/libc.so.6 (0x00007f5cc2674000) libgcc_s.so.1 =&gt; /usr/lib64/libgcc_s.so.1 (0x00007f5cc245e000) /lib64/ld-linux-x86-64.so.2 (0x00007f5cc7ee1000) libmql1.so =&gt; /usr/lib/oracle/12.2/client64/lib/libmql1.so (0x00007f5cc21e7000) libipc1.so =&gt; /usr/lib/oracle/12.2/client64/lib/libipc1.so (0x00007f5cc1db3000) libnnz12.so =&gt; /usr/lib/oracle/12.2/client64/lib/libnnz12.so (0x00007f5cc166a000) libons.so =&gt; /usr/lib/oracle/12.2/client64/lib/libons.so (0x00007f5cc141c000) libltdl.so.7 =&gt; /usr/lib64/libltdl.so.7 (0x00007f5cc1211000) -bash-4.2$ printenv XDG_SESSION_ID=381 HOSTNAME=cmapps-test TERM=xterm SHELL=/bin/bash HISTSIZE=1000 SSH_CLIENT=xx.xxx.xxx.xx 61528 22 SSH_TTY=/dev/pts/2 USER=cmapps TWO_TASK=//xxx.xxx.xxx.xxx:1521/listener LD_LIBRARY_PATH=/usr/lib64:/usr/lib/oracle/12.2/client64/lib LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36: TNS_ADMIN=/etc/oracle MAIL=/var/spool/mail/cmapps PATH=/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin PWD=/usr/lib/oracle/12.2/client64/lib LANG=en_US.UTF-8 HISTCONTROL=ignoredups SHLVL=1 HOME=/var/www/html LOGNAME=cmapps SSH_CONNECTION=xx.xxx.xxx.xx 61528 192.168.180.18 22 LESSOPEN=||/usr/bin/lesspipe.sh %s XDG_RUNTIME_DIR=/run/user/1000 ORACLE_HOME=/usr/lib/oracle/12.2/client64 _=/usr/bin/printenv OLDPWD=/var/www/html isql -v ESECNS_TEST +---------------------------------------+ | Connected! | | | | sql-statement | | help [tablename] | | quit | | | +---------------------------------------+ SQL&gt; sqlplus64 *****/******@ESECNS_TEST SQL*Plus: Release 12.2.0.1.0 Production on Mon May 8 15:18:26 2017 Copyright (c) 1982, 2016, Oracle. All rights reserved. Connesso a: Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production With the Partitioning, OLAP, Data Mining and Real Application Testing options SQL&gt; </code></pre> <p><a href="https://i.stack.imgur.com/8btjU.png" rel="nofollow noreferrer">Connection OK</a></p> <p><a href="https://i.stack.imgur.com/FiH4b.png" rel="nofollow noreferrer">Connection error after refresh page</a></p> </div>

连接到oracle:使用PDO工作但不使用oci_connect

<div class="post-text" itemprop="text"> <p><strong>Working code-</strong></p> <pre><code>$dbh = new PDO('oci:dbname=localhost/XE', 'hr', 'hr'); $s = $dbh-&gt;prepare("select * from Employees"); $s-&gt;execute(); while (($r = $s-&gt;fetch(PDO::FETCH_ASSOC)) != false) { echo htmlentities($r['FIRST_NAME']) . " " . $r['LAST_NAME'] . "&lt;br&gt;"; } </code></pre> <p><strong>Not working code</strong> <strong><em>(Error-Call to undefined function oci_connect(), oci_new_connect())</em></strong></p> <pre><code>/*Using oci_connect */ $conn=oci_connect("hr","hr","localhost/XE"); If (!$conn) echo 'Failed to connect to Oracle'; else echo 'Succesfully connected with Oracle DB'; oci_close($conn); /*Using oci_new_connect*/ $c = oci_new_connect('hr', 'hr', 'localhost/XE'); $s = oci_parse($c, 'select city from locations'); oci_execute($s); while (($res = oci_fetch_array($s, OCI_ASSOC)) != false) { echo htmlentities($res['CITY']) . "&lt;br&gt;"; } </code></pre> <p>phpinfo are as <a href="https://i.stack.imgur.com/4Abbg.png" rel="nofollow noreferrer">phpinfo details</a> I have placed instantclient for 11g in c and set PATH variable also</p> <hr> <p><strong>Tried every instantclient extensions one by one-</strong> </p> <ol> <li>extension=php_oci8.dll, </li> <li>extension=php_oci8_11g.dll,</li> <li>extension=php_oci8_12c.dll</li> </ol> <p><strong>I am using Oracle 11g</strong></p> <p>Tried also- <a href="https://stackoverflow.com/questions/21249858/how-to-enable-extensions-for-oci8-oracle-in-php-ini-php-warning-php-startup">this</a> and <a href="https://stackoverflow.com/questions/25519686/install-and-configure-oci8-to-connect-oracle-to-php">this also</a></p> </div>

左外连接的条件谓词评估较晚,导致性能问题。 Oracle 8i

<div class="post-text" itemprop="text"> <p>This is on Oracle 8i (sorry, no control over this) and PHP 7.</p> <p>I am building a search tool. It's a simple form with 3 fields, using HTTP Post method. PHP then does some checks on the 3 fields' values, determines if they are valid and then sends the values off to the SQL query. The query looks something like this; remember its 8i so no ANSI join here :</p> <pre><code>SELECT reports_table.*, documents_table.*, cases_table.* FROM reports_table, documents_table, cases_table WHERE reports_table.report_id = documents_table.report_id AND reports_table.report_id = cases_table.report_id(+) -- Report Number filtering AND reports_table.report_no = CASE WHEN $report_no_isvalid = 1 THEN '$report_no' -- Oracle expects datatype varchar2 ELSE reports_table.report_no END -- Document Number filtering AND documents_table.document_no = CASE WHEN $doc_no_isvalid = 1 THEN $doc_no -- Oracle expects datatype number ELSE documents_table.document_no END -- Case Number filtering AND cases_table.case_no = CASE WHEN $case_no_isvalid = 1 THEN '$case_no' -- Oracle expects datatype varchar2 ELSE cases_table.case_no END </code></pre> <p>The user is required to enter at least a Report Number, or a Case Number. The full numbers are required, i.e. no wildcard search is allowed. The <code>reports_table</code> is very large. When searching by Report Number, the database takes a very long time as if the CASE evaluation that acts on the validity of the Report Number, i.e. this section of code here</p> <pre><code>AND reports_table.report_no = CASE WHEN $report_no_isvalid = 1 THEN '$report_no' -- Oracle expects datatype varchar2 ELSE reports_table.report_no END </code></pre> <p>is being evaluated after the joining operation. It seems to be indeed evaluated though, because if I add another simple predicate in the WHERE clause to limit the scope on the Report Number, the database answers very fast, with the expected result. e.g. lets say the Report Number I'm searching for is 'R123456', if I add <code>AND reports_table.report_no LIKE 'R1234%'</code>, as a predicate outside of the CASE statement, the performance is good. Otherwise it is extremely slow, as if Oracle is scanning the whole <code>reports_table</code> in trying to make the join.</p> <p>I would like to find a way to tell Oracle to ensure its looking at the conditional CASE filter on the Report Number when performing the join but I have no idea how. Or maybe I should avoid altogether that kind of conditional restriction on the join, and if so, what technique could I use to achieve what I'm trying to do?</p> </div>

大学四年自学走来,这些私藏的实用工具/学习网站我贡献出来了

大学四年,看课本是不可能一直看课本的了,对于学习,特别是自学,善于搜索网上的一些资源来辅助,还是非常有必要的,下面我就把这几年私藏的各种资源,网站贡献出来给你们。主要有:电子书搜索、实用工具、在线视频学习网站、非视频学习网站、软件下载、面试/求职必备网站。 注意:文中提到的所有资源,文末我都给你整理好了,你们只管拿去,如果觉得不错,转发、分享就是最大的支持了。 一、电子书搜索 对于大部分程序员...

在中国程序员是青春饭吗?

今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...

springboot+jwt实现token登陆权限认证

一 前言 此篇文章的内容也是学习不久,终于到周末有时间码一篇文章分享知识追寻者的粉丝们,学完本篇文章,读者将对token类的登陆认证流程有个全面的了解,可以动态搭建自己的登陆认证过程;对小项目而已是个轻量级的认证机制,符合开发需求;更多精彩原创内容关注公主号知识追寻者,读者的肯定,就是对作者的创作的最大支持; 二 jwt实现登陆认证流程 用户使用账号和面发出post请求 服务器接受到请求后使用私...

技术大佬:我去,你写的 switch 语句也太老土了吧

昨天早上通过远程的方式 review 了两名新来同事的代码,大部分代码都写得很漂亮,严谨的同时注释也很到位,这令我非常满意。但当我看到他们当中有一个人写的 switch 语句时,还是忍不住破口大骂:“我擦,小王,你丫写的 switch 语句也太老土了吧!” 来看看小王写的代码吧,看完不要骂我装逼啊。 private static String createPlayer(PlayerTypes p...

女程序员,为什么比男程序员少???

昨天看到一档综艺节目,讨论了两个话题:(1)中国学生的数学成绩,平均下来看,会比国外好?为什么?(2)男生的数学成绩,平均下来看,会比女生好?为什么?同时,我又联想到了一个技术圈经常讨...

总结了 150 余个神奇网站,你不来瞅瞅吗?

原博客再更新,可能就没了,之后将持续更新本篇博客。

副业收入是我做程序媛的3倍,工作外的B面人生是怎样的?

提到“程序员”,多数人脑海里首先想到的大约是:为人木讷、薪水超高、工作枯燥…… 然而,当离开工作岗位,撕去层层标签,脱下“程序员”这身外套,有的人生动又有趣,马上展现出了完全不同的A/B面人生! 不论是简单的爱好,还是正经的副业,他们都干得同样出色。偶尔,还能和程序员的特质结合,产生奇妙的“化学反应”。 @Charlotte:平日素颜示人,周末美妆博主 大家都以为程序媛也个个不修边幅,但我们也许...

MySQL数据库面试题(2020最新版)

文章目录数据库基础知识为什么要使用数据库什么是SQL?什么是MySQL?数据库三大范式是什么mysql有关权限的表都有哪几个MySQL的binlog有有几种录入格式?分别有什么区别?数据类型mysql有哪些数据类型引擎MySQL存储引擎MyISAM与InnoDB区别MyISAM索引与InnoDB索引的区别?InnoDB引擎的4大特性存储引擎选择索引什么是索引?索引有哪些优缺点?索引使用场景(重点)...

如果你是老板,你会不会踢了这样的员工?

有个好朋友ZS,是技术总监,昨天问我:“有一个老下属,跟了我很多年,做事勤勤恳恳,主动性也很好。但随着公司的发展,他的进步速度,跟不上团队的步伐了,有点...

我入职阿里后,才知道原来简历这么写

私下里,有不少读者问我:“二哥,如何才能写出一份专业的技术简历呢?我总感觉自己写的简历太烂了,所以投了无数份,都石沉大海了。”说实话,我自己好多年没有写过简历了,但我认识的一个同行,他在阿里,给我说了一些他当年写简历的方法论,我感觉太牛逼了,实在是忍不住,就分享了出来,希望能够帮助到你。 01、简历的本质 作为简历的撰写者,你必须要搞清楚一点,简历的本质是什么,它就是为了来销售你的价值主张的。往深...

程序员写出这样的代码,能不挨骂吗?

当你换槽填坑时,面对一个新的环境。能够快速熟练,上手实现业务需求是关键。但是,哪些因素会影响你快速上手呢?是原有代码写的不够好?还是注释写的不够好?昨夜...

外包程序员的幸福生活

今天给你们讲述一个外包程序员的幸福生活。男主是Z哥,不是在外包公司上班的那种,是一名自由职业者,接外包项目自己干。接下来讲的都是真人真事。 先给大家介绍一下男主,Z哥,老程序员,是我十多年前的老同事,技术大牛,当过CTO,也创过业。因为我俩都爱好喝酒、踢球,再加上住的距离不算远,所以一直也断断续续的联系着,我对Z哥的状况也有大概了解。 Z哥几年前创业失败,后来他开始干起了外包,利用自己的技术能...

优雅的替换if-else语句

场景 日常开发,if-else语句写的不少吧??当逻辑分支非常多的时候,if-else套了一层又一层,虽然业务功能倒是实现了,但是看起来是真的很不优雅,尤其是对于我这种有强迫症的程序"猿",看到这么多if-else,脑袋瓜子就嗡嗡的,总想着解锁新姿势:干掉过多的if-else!!!本文将介绍三板斧手段: 优先判断条件,条件不满足的,逻辑及时中断返回; 采用策略模式+工厂模式; 结合注解,锦...

离职半年了,老东家又发 offer,回不回?

有小伙伴问松哥这个问题,他在上海某公司,在离职了几个月后,前公司的领导联系到他,希望他能够返聘回去,他很纠结要不要回去? 俗话说好马不吃回头草,但是这个小伙伴既然感到纠结了,我觉得至少说明了两个问题:1.曾经的公司还不错;2.现在的日子也不是很如意。否则应该就不会纠结了。 老实说,松哥之前也有过类似的经历,今天就来和小伙伴们聊聊回头草到底吃不吃。 首先一个基本观点,就是离职了也没必要和老东家弄的苦...

2020阿里全球数学大赛:3万名高手、4道题、2天2夜未交卷

阿里巴巴全球数学竞赛( Alibaba Global Mathematics Competition)由马云发起,由中国科学技术协会、阿里巴巴基金会、阿里巴巴达摩院共同举办。大赛不设报名门槛,全世界爱好数学的人都可参与,不论是否出身数学专业、是否投身数学研究。 2020年阿里巴巴达摩院邀请北京大学、剑桥大学、浙江大学等高校的顶尖数学教师组建了出题组。中科院院士、美国艺术与科学院院士、北京国际数学...

为什么你不想学习?只想玩?人是如何一步一步废掉的

不知道是不是只有我这样子,还是你们也有过类似的经历。 上学的时候总有很多光辉历史,学年名列前茅,或者单科目大佬,但是虽然慢慢地长大了,你开始懈怠了,开始废掉了。。。 什么?你说不知道具体的情况是怎么样的? 我来告诉你: 你常常潜意识里或者心理觉得,自己真正的生活或者奋斗还没有开始。总是幻想着自己还拥有大把时间,还有无限的可能,自己还能逆风翻盘,只不是自己还没开始罢了,自己以后肯定会变得特别厉害...

男生更看重女生的身材脸蛋,还是思想?

往往,我们看不进去大段大段的逻辑。深刻的哲理,往往短而精悍,一阵见血。问:产品经理挺漂亮的,有点心动,但不知道合不合得来。男生更看重女生的身材脸蛋,还是...

为什么程序员做外包会被瞧不起?

二哥,有个事想询问下您的意见,您觉得应届生值得去外包吗?公司虽然挺大的,中xx,但待遇感觉挺低,马上要报到,挺纠结的。

当HR压你价,说你只值7K,你该怎么回答?

当HR压你价,说你只值7K时,你可以流畅地回答,记住,是流畅,不能犹豫。 礼貌地说:“7K是吗?了解了。嗯~其实我对贵司的面试官印象很好。只不过,现在我的手头上已经有一份11K的offer。来面试,主要也是自己对贵司挺有兴趣的,所以过来看看……”(未完) 这段话主要是陪HR互诈的同时,从公司兴趣,公司职员印象上,都给予对方正面的肯定,既能提升HR的好感度,又能让谈判气氛融洽,为后面的发挥留足空间。...

面试:第十六章:Java中级开发

HashMap底层实现原理,红黑树,B+树,B树的结构原理 Spring的AOP和IOC是什么?它们常见的使用场景有哪些?Spring事务,事务的属性,传播行为,数据库隔离级别 Spring和SpringMVC,MyBatis以及SpringBoot的注解分别有哪些?SpringMVC的工作原理,SpringBoot框架的优点,MyBatis框架的优点 SpringCould组件有哪些,他们...

早上躺尸,晚上干活:硅谷科技公司这么流行迟到?

硅谷科技公司上班时间OPEN早已不是什么新鲜事,早九晚五是常态,但有很多企业由于不打卡,员工们10点、11点才“姗姗来迟”的情况也屡见不鲜。 这种灵活的考勤制度为人羡慕,甚至近年来,国内某些互联网企业也纷纷效仿。不过,硅谷普遍弹性的上班制度是怎么由来的呢?这种“流行性迟到”真的有那么轻松、悠哉吗? 《动态规划专题班》 课程试听内容: 动态规划的解题要领 动态规划三大类 求最值/计数/可行性 常...

面试阿里p7,被按在地上摩擦,鬼知道我经历了什么?

面试阿里p7被问到的问题(当时我只知道第一个):@Conditional是做什么的?@Conditional多个条件是什么逻辑关系?条件判断在什么时候执...

终于懂了TCP和UDP协议区别

终于懂了TCP和UDP协议区别

Python爬虫,高清美图我全都要(彼岸桌面壁纸)

爬取彼岸桌面网站较为简单,用到了requests、lxml、Beautiful Soup4

无代码时代来临,程序员如何保住饭碗?

编程语言层出不穷,从最初的机器语言到如今2500种以上的高级语言,程序员们大呼“学到头秃”。程序员一边面临编程语言不断推陈出新,一边面临由于许多代码已存在,程序员编写新应用程序时存在重复“搬砖”的现象。 无代码/低代码编程应运而生。无代码/低代码是一种创建应用的方法,它可以让开发者使用最少的编码知识来快速开发应用程序。开发者通过图形界面中,可视化建模来组装和配置应用程序。这样一来,开发者直...

面试了一个 31 岁程序员,让我有所触动,30岁以上的程序员该何去何从?

最近面试了一个31岁8年经验的程序猿,让我有点感慨,大龄程序猿该何去何从。

大三实习生,字节跳动面经分享,已拿Offer

说实话,自己的算法,我一个不会,太难了吧

程序员垃圾简历长什么样?

已经连续五年参加大厂校招、社招的技术面试工作,简历看的不下于万份 这篇文章会用实例告诉你,什么是差的程序员简历! 疫情快要结束了,各个公司也都开始春招了,作为即将红遍大江南北的新晋UP主,那当然要为小伙伴们做点事(手动狗头)。 就在公众号里公开征简历,义务帮大家看,并一一点评。《启舰:春招在即,义务帮大家看看简历吧》 一石激起千层浪,三天收到两百多封简历。 花光了两个星期的所有空闲时...

Java岗开发3年,公司临时抽查算法,离职后这几题我记一辈子

前几天我们公司做了一件蠢事,非常非常愚蠢的事情。我原以为从学校出来之后,除了找工作有测试外,不会有任何与考试有关的事儿。 但是,天有不测风云,公司技术总监、人事总监两位大佬突然降临到我们事业线,叫上我老大,给我们组织了一场别开生面的“考试”。 那是一个风和日丽的下午,我翘着二郎腿,左手端着一杯卡布奇诺,右手抓着我的罗技鼠标,滚动着轮轴,穿梭在头条热点之间。 “淡黄的长裙~蓬松的头发...

大胆预测下未来5年的Web开发

在2019年的ReactiveConf 上,《Elm in Action》的作者Richard Feldman对未来5年Web开发的发展做了预测,很有意思,分享给大家。如果你有机会从头...

立即提问
相关内容推荐