android中运行程序出错

一头雾水!图片说明

6个回答

java.lang.UnsupportedClassVersionError: PR/Sort : Unsupported major.minor version 52.0这个错误是由于高版本的java project使用了低版本的来运行。

我出现这个情况是我把Properties中java build path-->Libraries中的JVM8换成JVM7

之后运行就报错了

解决方法:
在Properties-->JAVA Compiler-中的Compiler compliance level从1.8改成1.7,之后就可以运行了。

是不是版本太高了???

qq_32454729
zzfyh 什么版本太高了。
4 年多之前 回复

如android—19,你clean一下看看

version 52.0的错误是指原先项目是jdk8编译,却运行在jdk7上。只要将项目编译和运行的jdk版本保持一致即可

你看一这个帖子跟你的问题一样,试试看
http://bbs.csdn.net/topics/391922682

把SDK升级一下试试

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问