Ubuntu 16.04两个软件出现依赖问题导致无法安装或删除软件

在Ubuntu16.04上安装了xmind,有提示说有安装错误,但却能打开xmind,故开始没在
意,后面再装了teamviewer,提示出错,有不满足的以来,然后我就准备卸载了teamviewer,
出现了一下情况,
图片说明

卸载不了teamviewer,去卸载xmind,又出现
图片说明

再试下了是否能安装或卸载其他软件均出现又不满足的依赖,
图片说明遇到这种情况,在不重装的前提下该如何解决?还请大神解惑~~

1个回答

问题已经解决!
sudo apt-get -f autoremove
似乎是会帮我纠正依赖,会删除一些包,同时会安装一些新的包。
就是不知道会不会存在隐患,但至少问题解决了,两个软件都能打开了,其他软件也能安装了!

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问