2 chengshouguo chengshouguo 于 2012.10.24 15:17 提问

ns-3编译运行出现错误
ns3

ns-3新手,无法编译运行scratch目录的*.cc脚本,提示program 'scratch/*'not found,available program are:......,该怎么解决啊?谢谢

2个回答

wangyaninglm
wangyaninglm   Ds   Rxr 2015.01.12 10:44
wangyaninglm
wangyaninglm   Ds   Rxr 2015.01.12 10:44
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
NS-3脚本的编译运行
<br />原文地址:http://hi.baidu.com/czlaner/blog/item/77a0a4ce9903a90493457e06.html<br />-----------------------------------------------------------------------------------------------------------------<br />一、环境支持<br /> 如上文(NS-3入门[1]概念引入 )所述,编译/运行NS-3脚本需要保证L
Ubuntu安装NS-3方法和遇到的问题
今天在Ubuntu14.04 LTS上安装NS-3.21 安装方法(中文):点击打开链接 官方安装教程(英文):点击打开链接 官网教程很详细,当然废话也很多,没必要看那么多,直接看中文教程最迅速。 1.安装ns-3之前,需要安装各种依赖包,见教程 sudo apt-get install xxxxx 2.下载ns-3安装包,通过浏览器去官网下载,或者利用各种下载工具(比如:tarball
ns-3快速上手-开发环境搭建篇(译)
ns-3快速上手-开发环境搭建篇(译) 0 前言 在现代网络通信技术的教学和科研中,迫切希望有一种先进的网络仿真技术。在网络模拟工具的研究和开发方面国内所做的工作较少,但是国外早已出现了很多研究成果和仿真工具,如ns-2、OMNet++、OPNET、GloMoSim、GTNetS、QualNet、Yans、NCTUNS、SSFNet、JiST和SimPy等。ns-3是在广泛汲取现有优秀开源
ns-3 的下载、编译以及 Eclipse 的相关配置
0. 写在前面对于初次接触Linux系统的人来说,ns-3 的安装似乎并不友好。但事实上只要按部就班地来做,其安装过程也没有看上去的那么复杂。本文将官方 Wiki 中的安装过程稍作梳理,希望能为初学者带来一些方便。同时由于官方 Wiki 中的描述已经足够详细,因此本文中将会出现大段引用并且不打算进行翻译,望请见谅。1. 安装 ns-31.1 环境配置本节参考官方 Wiki 中 Installatio
使用WAF编译NS3, DCE
使用bake编译,由于bake支持的DCE和ns3的版本较老,所以采用waf来编译ns3,dce OS: CentOS6.5 预备条件:暂时无 说明:暂时未考虑使用pybindgen,所以未编译是物。 编译步骤: ns3 1 下载最新ns3 # Download ns-3 hg clone http://code.nsnam.org/ns-3.23 2 编译ns3,
使用eclipse编译ns-3
使用eclipse编译ns-3 1. 概述 习惯可视化编程界面的读者可能不适应命令行下编译调试程序,实际上ns-3程序使用任何一个你熟悉的C++代码编译器都可以,ns-3中源文件(.cc)就是C++程序。这里给大家介绍一个比较优秀的IDE集成开发环境eclipse(就是比较占内存),它支持如JAVA、C/C++、Python、PHP等多种语言,而且跨平台。详细情况请参考:https
使用eclipse编译ns3
一:安装eclipse 二:配置ns3编译环境,建议参考官方文档 三:使用举例:将写好的脚本文件first.cc复制到scratch目录下,终端编译运行即可
在ns-3中运行程序
在ns-3中运行程序 一、运行c++代码 直接运行: 首先编译  ./waf 然后执行 ./waf --run program-name program-name是要执行的程序名。 查看当前有哪些程序可以执行: http://blog.csdn.net/barcodegun/article/details/6899522 二、运行 python代码 ./w
Linux安装NS3
Linux安装NS3
ubuntu安装ns3.26
follow教程https://www.nsnam.org/wiki/index.php/Installation#Manual_installation 1.先安装依赖的包 minimal requirements for C++ (release): This is the minimal set of packages needed to run ns-3 from a rele