weixin_39775976
weixin_39775976
2020-12-01 20:51

AppImage does not run on Ubuntu xenial

Describe the bug AppImage does not run on Ubuntu xenial

To Reproduce Steps to reproduce the behavior: 1. Run Ubuntu xenial 2. Try to run the GDLauncher AppImage

Expected behavior Works.

Possible solutions Build on a system no newer than the oldest still-supported Ubuntu LTS release, which currently is xenial.

Operating System: - Ubuntu - xenial

Additional context Reference: https://github.com/AppImage/appimage.github.io/pull/1084

该提问来源于开源项目:gorilla-devs/GDLauncher

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

6条回答

  • weixin_39588445 weixin_39588445 5月前

    Did you make it executable? Right click > go to permissions and click the executable box Or: open a terminal and type sudo chmod +x gdlaunchername.appimage

    点赞 评论 复制链接分享
  • weixin_39775976 weixin_39775976 5月前

    Yes, thank you, I did this. I get:

    
    Error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.22' not found (required by /tmp/.org.chromium.Chromium.vJZtcB)
    
    点赞 评论 复制链接分享
  • weixin_39588445 weixin_39588445 5月前

    It looks like you're missing a dependency. You need to install Libstdc++6: sudo apt-get install libstdc++6 that should do the trick

    点赞 评论 复制链接分享
  • weixin_39775976 weixin_39775976 5月前

    This is not how AppImages work. Please have a look at https://github.com/AppImage/AppImageKit/wiki/Creating-AppImages/cc2441518975caca23e9ce2dba6f08a22c678d1e#libstdcso6. Thanks a lot!

    点赞 评论 复制链接分享
  • weixin_39588445 weixin_39588445 5月前

    You are completely right! That's what you get when the dev is a windows normie lol. fix pwease?

    点赞 评论 复制链接分享
  • weixin_39568659 weixin_39568659 5月前

    Ubuntu Xenial is ancient. If they were to link using a super old GLIB it will break newer modern OSes

    点赞 评论 复制链接分享

相关推荐