Zfanxu
取你猪头
2013-11-16 04:13
采纳率: 100%
浏览 2.4k
已采纳

新人求助:关于IOS APP向下兼容的问题

开发环境:xcode4.6.3

SDK版本:IOS 6.1

问题描述: 在上述环境下开发的软件(APP),经过测试在IOS6.1以上的系统和真机上运行都是没问题的,但是如何在老版本的系统中(IOS6.1以下),正常编译执行?

同事的iphone4 系统是4.5的,就运行不了,开发的软件!如何让我的软件向下兼容那个而又不彻底重构代码的情况下,解决这个问题呢?

小弟我刚学IOS才一个月,希望各位大师指点迷津!不胜感激

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • chenydtest02
    chenydtest02 2015-05-29 03:08
    已采纳

    注意是否是第三方库引用的问题

    点赞 评论
  • u013243469
    __block小凡 2014-11-26 02:45

    点击工程文件,选择TARGETS中你的工程项目,然后General里面的Deployment Info中的Deployment Target 设置为4.0

    点赞 评论
  • sinat_30587679
    sinat_30587679 2015-08-13 14:47

    ARC和第三方框架问题

    点赞 评论

相关推荐