weixin_39977934
weixin_39977934
2020-12-01 22:57

search goes blank, but doesn't let go

Description

I found this trying out 3.1, but from the look of it, may well be in 3.0.x also.

The problem is that if you use the Search ui field to try to find an Entry, for example, the Search field goes blank but Search remains in force, should you go on to look at other categories of the Entry, etc..

Steps to reproduce

  1. Open Entries in the CP
  2. enter a Search term and use it. I was looking for possibles via in: trashed, but it does the same for any search text.
  3. See what you see: zero or more Entries
  4. As one would naturally think, choose a category of Entry -- nothing. Which actually makes sense, in some ways, but...
  5. ...the Search field has gone blank, so you have no idea why you see nothing,
  6. With or without realizing, click Entries again, and all you expect returns to normal view.

Now, another good question on this is whether Craft should indeed refresh to not have the Search restrictor in use, just as it is actually presently showing, when you click on an Element category after a search -- fully revert. I think there can be a good argument this is what a non-programmer is expecting...

Additional info

  • Craft version: 3.1x in test, others suspected

该提问来源于开源项目:craftcms/cms

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

7条回答

  • weixin_39857792 weixin_39857792 5月前
    1. As one would naturally think, choose a category of Entry -- nothing. Which actually makes sense, in some ways, but...
    2. ...the Search field has gone blank, so you have no idea why you see nothing,

    I’m not sure I’m following you here. Are you doing anything in either of these steps?

    点赞 评论 复制链接分享
  • weixin_39977934 weixin_39977934 5月前

    Well, let's try another way of stating the steps. It's really simple. And I did just try it again.

    1. bring up Entries, with several Sections in their Groups available (e.g. Singles, Channels, Structures)
    2. view the sections
    3. type something unfindable in the Search field
    4. note all of the entries disappear
    5. click on a different section in the sidebar

    you don't see any sections come into view but the Search has gone blank again, so you have no clue why not

    I'm suggesting not to correct that the Search went blank, but to let it blank and auto-refresh for the selected Group.

    Because clicking that way is a natural move;, especially if you had looked away from the screen. So it should get some action, but showing the content, not clearing the Search field. As that the Search field would be still in force would be unexpected, and probably not seen.

    Sleep after all, now. Software, as you know.

    点赞 评论 复制链接分享
  • weixin_39857792 weixin_39857792 5月前

    Thanks, able to reproduce that, but only in Craft 3.1, not 3.0. Will fix.

    点赞 评论 复制链接分享
  • weixin_39977934 weixin_39977934 5月前

    Great to hear -- thanks, Brandon

    点赞 评论 复制链接分享
  • weixin_39977934 weixin_39977934 5月前

    ...and apologies that the steps were a bit misleading in some nouns -- it was indeed quite late.... ;)

    点赞 评论 复制链接分享
  • weixin_39857792 weixin_39857792 5月前

    Fixed via 1ce08ef0601343c5d56adf3f5e92e0459c61d734

    点赞 评论 复制链接分享
  • weixin_39977934 weixin_39977934 5月前

    👍

    点赞 评论 复制链接分享

相关推荐