weixin_39636696
weixin_39636696
2020-12-02 03:30

In Splunk the 'cluster_name' variable is not populating with actual name of cluster but instead with default value of cluster_name

What happened: The cluster_name variable value is not populating with the actual name of the cluster instead default value of cluster_name is in the field when querying in Splunk.

What you expected to happen: The actual name of the cluster to be showing under cluster_name variable in Splunk.

How to reproduce it (as minimally and precisely as possible): Deployed Splunk connect using Helm charts via https://github.com/splunk/splunk-connect-for-kubernetes/tree/develop/helm-chart/splunk-connect-for-kubernetes.

Anything else we need to know?: Using latest Splunk connect for kubernetes 1.4.1 release.

Environment: - Kubernetes version (use kubectl version): GitVersion:"v1.15.7-gke.32" - Ruby version (use ruby --version): Not installed - OS (e.g: cat /etc/os-release): Ubuntu 18.04.4 LTS - Splunk version: 7.3.0 - Others:

该提问来源于开源项目:splunk/splunk-connect-for-kubernetes

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

8条回答

  • weixin_39918043 weixin_39918043 5月前

    Thanks . Make sense to me. Created a Jira ticket https://jira.splunk.com/browse/ADDON-27949. Will plan it in future.

    点赞 评论 复制链接分享
  • weixin_39717367 weixin_39717367 5月前

    Hey did you try setting the value https://github.com/splunk/splunk-connect-for-kubernetes/blob/develop/helm-chart/splunk-connect-for-kubernetes/values.yaml#L41 ?

    点赞 评论 复制链接分享
  • weixin_39892842 weixin_39892842 5月前

    hi, do we have an estimated timeline when this will be fixed? i have the same issue as r6ricer with the same released version

    点赞 评论 复制链接分享
  • weixin_39858132 weixin_39858132 5月前

    Could you share the values.yaml file you are using. I would like to know in which case it fails to populate cluster_name field with the value set in the https://github.com/splunk/splunk-connect-for-kubernetes/blob/develop/helm-chart/splunk-connect-for-kubernetes/values.yaml#L41

    点赞 评论 复制链接分享
  • weixin_39892842 weixin_39892842 5月前

    does the helm take cluster_name as a parameter? I wonder how does L41 takes a different cluster_name as user indicated. is it that I shall overwrite the values in my_values.yml global: kubernetes: clusterName: thanks

    点赞 评论 复制链接分享
  • weixin_39612726 weixin_39612726 5月前

    yes fo course....here is the spec...not sure what L41 is? This seems to simply be a values.yaml config error.

    https://github.com/splunk/splunk-connect-for-kubernetes/blob/69a5fa2091401214d53e9fb4e2a7db755cc87d33/helm-chart/splunk-connect-for-kubernetes/values.yaml#L41

    kubernetes.cluster_name is avail in all sections of the chart (global and local sub chart configs)

    Here is how I set it....i haven't been using global, I've been setting in each chart...global works.

    https://mattymo.io/code/mattymo/splunk_toronto_usergroup_may_2020#deploy-splunk-connect-for-kubernetes

    点赞 评论 复制链接分享
  • weixin_39892842 weixin_39892842 5月前

    thanks . i confirmed that if i pass in the the right value to helm, it will work. you can close this ticket

    点赞 评论 复制链接分享
  • weixin_39858132 weixin_39858132 5月前

    Thank you!

    点赞 评论 复制链接分享

相关推荐