2 a910822 a910822 于 2013.12.26 16:01 提问

应用VS2010运行ILSpy 的源码时,显示有个组件与VS当前版本不兼容

用VS2010运行ILSpy的源码时,提示ICSharpCode.Decompiler.Tests(incompatible)这个组件与当前VS版本不兼容,请问能不能在什么地方找到一个能够通过编译的源代码,或者有其他的什么方法让这个源代码运行起来,我的ILSpy源代码是2.1.0.1603版本的

1个回答

oyljerry
oyljerry   Ds   Rxr 2015.01.06 00:03

用2010编译一下源码。

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
使用vs2015打开以前版本的.sln工程不兼容的问题
1.如图,使用vs2015打开以前的vs版本创建的工程时,提示不兼容,工程下显示不了文件信息: 2.在网上搜索了许久,找到了许多五花八门的办法,总结有下面几种: 1)下载vs project converter,我按照说明下载该软件安装以后,电脑上没有任何效果 2)下载Visual Studio 20XX Tools for Unity,该插件安装以后,同样没有效果,后来才知
此项目与visual studio的当前版本不兼容
1、打开  DisplayControl.csproj  文件 2、查看  {b69e3092-b931-443c-abe7-7e7b65f2a37f};{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC} 3、搜索到 b69e3092-b931-443c-abe7-7e7b65f2a37f 为 .NET Micro Framework 4、下载并安装.NET Mic
此项目与Visual Studio的当前版本不兼容的报错.
问题再现:今天从网上荡了一个程序,程序是用visual studio 2013开发的,放在本地运行报此项目与Visual Studio的当前版本不兼容。 本地是visual studio 2010. 解决办法: 用记事本打开解决方案文件“解决方案名.sln”,然后修改最上面两行为如下代码: Microsoft Visual Studio Solution File, Format
安装VS2010sp1显示兼容性问题
安装VS2010SP1的时候总是显示兼容性问题。 失败对话框,提示兼容性问题。在安装exe文件的属性窗口中,修改兼容性属性,如下图: 在“兼容模式”中,修改“以兼容模式运行这个程序” 然后,就可以安装了。 网上没有,记录一下吧。
此项目与Visual Studio的当前版本不兼容的报错
原文地址:http://blog.csdn.net/CCmonitor/article/details/75817734 问题再现:今天从网上荡了一个程序,程序是用visual studio 2013开发的,放在本地运行报此项目与Visual Studio的当前版本不兼容。 本地是visual studio 2010. 解决办法: 用记事本打开解决方案文件“解决方案名.sl
SQL Server与VS2010不兼容的问题
本来电脑有个08的SQL Server的ISO文件,然后因为网络编程和软件开发基础(.NET)要用到VS2010,所以在前几天就成功安装了VS2010。哪知道,当要用到SQL Server的时候,发现SQL Server连接失败,这下郁闷了,刚开始以为是前几天因为C盘可用空间太少而乱删文件的原因,多亏了在一位师兄的帮助下才知道原来是SQL Server与VS2010不兼容的问题。    对于SQ
VS2010中程序编译生成都是正确的,直接生成的exe也是正确的,就是在VS中运行出现错误
VS2010中程序编译生成都是正确的,直接生成的exe也是正确的,就是在VS中运行出现错误原因: 有可能你在VS程序配置过程中,指定的输出文件名和系统配置过程中生成的文件名不同。在这个时候,要检查两个地方的文件名称是不是匹配得上。
更改VS解决方案高版本号为兼容的版本号
在打开高版本的VS解决方案时,提示版本不兼容,解决办法是将高版本的VS版本号解决方案更改为兼容更低版本号的VS,本文是将VS的最低版本从VS2010的版本号改为VS2008的版本号。也可以尝试新建工程,然后添加工程文件,解决版本兼容问题。如果实在没办法解决的话,就尝试安装最新的VS平台吧。 Microsoft – 官方网站 Visual Studio下载地址 https://www.
安装VS2010,出现“某些组件必须安装在 目录下,请检查是否有足够的写入权限以及足够的空间”的可能原因
其中 joeblackzqq转帖如下:“安装VS2010旗帜版时,我用的安装文件是一个ISO文件,用虚拟光驱加载的,但是在安装时却出现了错误:“某些组件必须安装在 目录下,请检查是否有足够的写入权限以及足够的空间”?这可怎么办呢? 我试着更改了安装目录,不管我选择其他盘符或者默认的C盘,都还是同样的错误!于是我上网搜索了下,终于找到了解决办法: 打开虚拟光驱后,将里面的所有文件都复制到硬盘上,如F...
oppo手机安装应用失败,提示版本不兼容
本人使用的是oppo r9s的测试机, 发现通过usb build应用到手机上后,应用无法卸载干净。 每次都提示卸载成功,但在设置-应用管理 里面还能看到。导致无法安装相同签名的apk,即使是应用市场安装同一个应用时,也会导致失败。 后来发现实oppo手机的卸载存在bug,好像是有一个应用软件的表没有做更新,导致卸载后的apk还会出现在所有应用中,这一问题困扰了我许久,终于最后找到了解决办法: