weixin_39789979
2020-12-02 23:08 阅读 0

MySQL 10061 issue

Hello, I've created all files excactly as it was explained , but i'm getting strange problem , Logon is connecting to MySQL without any problems,

but World.exe giving the following error : [Arcemu]MySQLDatabase: Connection failed due to: Can't connect to MySQL server on 'localhost' (10061)

this sql server is installed on Dedicated server and i got forums running on this mysql server, i tried to use different mysql sql users and pw / creating new users to test , always same problem

willing to get a fast respond,

Regards

该提问来源于开源项目:arcemu/arcemu

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

23条回答 默认 最新

  • weixin_39929961 weixin_39929961 2020-12-02 23:08

    How is this an Arcemu bug? You probably just forgot to set the right host in the world config file...

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    WorldDatabase Hostname = "localhost" Username = "ArcAdmin" Password = "xxxxx" Name = "wowworld" Port = "3306" CharacterDatabase Hostname = "localhost" Username = "ArcAdmin" Password = "xxxxx" Name = "wowchar" Port = "3306"

    点赞 评论 复制链接分享
  • weixin_39929961 weixin_39929961 2020-12-02 23:08

    Strange. Maybe you have a connection limit on your mysql server? Can you connect with anything else, but the world server? ( While the logon is running )

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    yeah, already i can log on forums, i can login with SQLyog

    SHOW STATUS LIKE 'Open_files';

    +---------------+-------+ | Variable_name | Value | +---------------+-------+ | Open_files | 78 | +---------------+-------+

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    mysql> show variables like +-----------------+-------+ | Variable_name | Value | +-----------------+-------+ | max_connections | 151 | +-----------------+-------+

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    i tried to install server again on my laptop and got same problem as dedicated server error

    点赞 评论 复制链接分享
  • weixin_39929961 weixin_39929961 2020-12-02 23:08

    As I've already said, it's strange. One thing is sure, it's not an Arcemu issue. The world and logon servers use the same database facilities, so if it was an issue with Arcemu, it would show up on both.

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    same idea , because i installed server on 2 different computers and its same problem , so 1 of my setup is wrong in both , or problem in Arcemu :D , would u like me to post all my conf files or u check it through teamviewer ?

    点赞 评论 复制链接分享
  • weixin_39929961 weixin_39929961 2020-12-02 23:08

    Why would I care to do anything on your computer with team viewer? You may however post your config files. Someone will surely read them...

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    Logon Conf are fine and it's connecting to DB without problems

    btw my dedicated server and computer are 64bit , in case if it may cause any of these problems

    点赞 评论 复制链接分享
  • weixin_39929961 weixin_39929961 2020-12-02 23:08

    http://pastebin.com/

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    World Conf File : http://pastebin.com/AnRAzkfw

    realm http://pastebin.com/djw6gpwU

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    this user have access permission to all mysql databases, and i also connected with it to test, it doesn't have problem using SQLyog

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    http://forums.mysql.com/read.php?11,9293,20486 try this

    点赞 评论 复制链接分享
  • weixin_39789101 weixin_39789101 2020-12-02 23:08

    Try to replace 'localhost' by '127.0.0.1' Maybe it helps, maybe not.

    And try to start the world.exe only, without the logon.exe. Check what happens.

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    nothing change , also logon.exe is connecting with same username & pw & host

    点赞 评论 复制链接分享
  • weixin_39995108 weixin_39995108 2020-12-02 23:08

    I see your log level is set to 0

    <LogLevel File="0"

    might want to set it to a different value to get more details.

    点赞 评论 复制链接分享
  • weixin_39789101 weixin_39789101 2020-12-02 23:08

    If the world.exe is running stand-alone and produces such an error than at least it's not a connection limit problem.

    However it's very strange.

    You can start the mySQL server with some log file options. Maybe you will find there an answer.

    Did you switched off your firewall (that maybe blocks your socket connections) ? And you don't have a strange user rights system ?

    点赞 评论 复制链接分享
  • weixin_39929961 weixin_39929961 2020-12-02 23:08

    Can you also post your logon.conf please? Thanks! Also what OS are you on?

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    Logon Conf:

    http://pastebin.com/2a035BJD

    I'm using Windows Server 2008 R2 64bit -- Dedicated Server Windows 7 64bit -- PC

    problem occurs on both PC and Dedicated Server

    点赞 评论 复制链接分享
  • weixin_39929961 weixin_39929961 2020-12-02 23:08

    Well I use those too at times, and it works fine for me. So check the event log, I have a feeling that Windows blocks world.exe for whatever reason.

    点赞 评论 复制链接分享
  • weixin_39789979 weixin_39789979 2020-12-02 23:08

    is it possible to send me link for ur world.exe ? maybe i've problem in my build or so :\

    点赞 评论 复制链接分享
  • weixin_39785400 weixin_39785400 2020-12-02 23:08

    Try "mysql -u DBUSERNAME -h DBSERVERNAME -p", if it connects there's something wrong with your config, if not there's something wrong with your mysql user permissions.

    点赞 评论 复制链接分享

相关推荐