2 max xjf Max_XJF 于 2016.09.08 10:16 提问

android studio 新建项目运行报错

Logcat 报错如下:

09-08 10:11:56.694 6639-6639/? E/AndroidRuntime: FATAL EXCEPTION: main
Process: com.max.myapplication, PID: 6639
java.lang.RuntimeException: Unable to start activity ComponentInfo{com.max.myapplication/com.max.myapplication.MainActivity}: java.lang.IllegalStateException: This app has been built with an incorrect configuration. Please configure your build for VectorDrawableCompat.
at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2219)
at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2269)
at android.app.ActivityThread.access$800(ActivityThread.java:135)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1196)
at android.os.Handler.dispatchMessage(Handler.java:102)
at android.os.Looper.loop(Looper.java:136)
at android.app.ActivityThread.main(ActivityThread.java:5045)
at java.lang.reflect.Method.invokeNative(Native Method)
at java.lang.reflect.Method.invoke(Method.java:515)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:779)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:595)
at dalvik.system.NativeStart.main(Native Method)
Caused by: java.lang.IllegalStateException: This app has been built with an incorrect configuration. Please configure your build for VectorDrawableCompat.
at android.support.v7.widget.AppCompatDrawableManager.checkVectorDrawableSetup(AppCompatDrawableManager.java:692)
at android.support.v7.widget.AppCompatDrawableManager.getDrawable(AppCompatDrawableManager.java:186)
at android.support.v7.widget.TintTypedArray.getDrawableIfKnown(TintTypedArray.java:77)
at android.support.v7.app.AppCompatDelegateImplBase.(AppCompatDelegateImplBase.java:83)
at android.support.v7.app.AppCompatDelegateImplV7.(AppCompatDelegateImplV7.java:146)
at android.support.v7.app.AppCompatDelegateImplV11.(AppCompatDelegateImplV11.java:28)
at android.support.v7.app.AppCompatDelegateImplV14.(AppCompatDelegateImplV14.java:41)
at android.support.v7.app.AppCompatDelegate.create(AppCompatDelegate.java:193)
at android.support.v7.app.AppCompatDelegate.create(AppCompatDelegate.java:173)
at android.support.v7.app.AppCompatActivity.getDelegate(AppCompatActivity.java:511)
at android.support.v7.app.AppCompatActivity.onCreate(AppCompatActivity.java:71)
at com.max.myapplication.MainActivity.onCreate(MainActivity.java:10)
at android.app.Activity.performCreate(Activity.java:5231)
at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1104)
at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2163)
at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2269) 
at android.app.ActivityThread.access$800(ActivityThread.java:135) 
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1196) 
at android.os.Handler.dispatchMessage(Handler.java:102) 
at android.os.Looper.loop(Looper.java:136) 
at android.app.ActivityThread.main(ActivityThread.java:5045) 
at java.lang.reflect.Method.invokeNative(Native Method) 
at java.lang.reflect.Method.invoke(Method.java:515) 
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:779) 
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:595) 
at dalvik.system.NativeStart.main(Native Method) 
09-08 10:11:58.562 6639-6639/? I/Process: Sending signal. PID: 6639 SIG: 9
**

2个回答

Max_XJF
Max_XJF   2016.09.08 10:30

已解决,把MainActivity的AppCompatActivity改成Activity

kaifali
kaifali 怎么修改啊?求指教。我把MainActivity.java里的AppCompatActivity都改成Activity就报错
接近 2 年之前 回复
v587095554
v587095554   2016.10.21 13:47

产生的原因是:com.android.support:appcompat-v7与rasterized vectors不兼容,gradle2.0及其之上,library的资源没有栅格化,所以不会发生这个问题
http://www.cnblogs.com/davidgu/p/5973846.html

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
AndroidStudio刚安装完新建项目之后就报错无法运行
因为google宣布将专注于AndroidStudio而不再支持eclipse,所以从现在起开始转到AndroidStudio,但是刚安装完新建了一个项目想测试一下运行效果的,结果项目报错无法运行。百度了一下发现出现这个错误的人挺多的。错误代码如下:Gradle sync failed: Plugin is too old, please update to a more recent versio
打开android studio新建项目时报错的可能的解决办法
在C:\Users\Administrator\.gradle目录下创建gradle.properties文件,文件内容为:org.gradle.jvmargs=-Xmx512m
android studio1.4新建工程运行出错
之前一直用的是android studio1.0,昨天下载了android studio 1.4的进行了安装,在新建工程的时候发现可以直接创建android 5.0的一些样式,如下图: 于是就创建了Navigation Drawer Activity 看看效果,特别期待了运行了程序。可是问题来了,程序一进来就崩溃了,报如下错误 看错误找不到abc_ic_
使用最新的Android studio 2.3.3创建新工程时出错了
当前的studio使用的是gradle 3.3 版本,这个目前在studio目录和./gradle目录已经配置好了,所以可以排除不是gradle配置的问题. 由于我的build-tool升级到了26.0.1,然后sdk版本默认使用的是26的. 这样创建新工程的时候,首先是出现这个问题: java.io.IOException: Cannot run program "/home/androi
关于Android Studio新建项目运行报错
Error:Execution failed for task ':app:transformClassesWithDexForDebug'. > com.Android.build.api.transform.TransformException: Java.lang.RuntimeException: com.android.ide.common.process.ProcessExc
Android studio新建activity运行出错解决方法
新建activity分以下几部: (1)在 /src/main/res/layout/ 中新建activity_second.xml (2)在 /src/main/java 中新建 SecondActivity.java ,且内容如下:public class SecondActivity extends Activity{ protected void onCreate(Bundle
Android Studio中,新建项目出现依赖问题
由于公司网络都是内部服务器代理,然后访问网络,导致SDK有些依赖不能下载,所以新建项目出现如下问题: Error:(24, 13) Failed to resolve: com.android.support:appcompat-v7:24.+ Error:(23, 17) Failed to resolve: junit:junit:4.12 这两个依赖作用分别是: support:ap
关于Android studio报junit错误的问题
概述前不久,打开以前的Android项目,报了一个 错: Exception in thread “main” Java.lang.NoClassDefFoundError: junit/textui/ResultPrinter ,详细信息如下:Exception in thread "main" java.lang.NoClassDefFoundError: junit/textui/Result
android studio 问题集
android studio 问题集 :Android SDK更新超时 Android Studio首次新建项目时加载缓慢 Android Studio的目录结构 Library Project的导入
解决Android Studio 不能启动或新建项目的情况
对于android studio 0.3.x 及以下的版本,安装或启动过程出现任何问题可以查看这篇博客。http://www.cnblogs.com/timeng/archive/2013/05/17/3084185.html 。        对于android studio 0.4.x 的版本, 安装了android studio 之后,按照上文所述的那篇博文下载安装gradle,配