XjingweiU
飞天小代码
采纳率50%
2016-09-11 03:56 浏览 1.5k
已采纳

出现Unable to satisfy the following requirements:

之前正常运行的项目今天打开运行出现库引用失败的问题,于是便pod insatll,但是又是各种下列问题,写上SDK的版本好也不好用。
✗ pod install

Analyzing dependencies
[!] The version of CocoaPods used to generate the lockfile (1.1.0.beta.1) is higher than the version of the current executable (1.0.1). Incompatibility issues may arise.
[!] Unable to satisfy the following requirements:

  • AFNetworking required by Podfile
  • AFNetworking (= 3.1.0) required by Podfile.lock

Specs satisfying the AFNetworking, AFNetworking (= 3.1.0) dependency were found, but they required a higher minimum deployment target.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

2条回答 默认 最新

  • 已采纳
    XjingweiU 飞天小代码 2016-09-11 04:00

    于是乎便Google出了这个http://blog.csdn.net/l2i2j2/article/details/51184386
    按此修改后,再pod install就好了

    点赞 评论 复制链接分享
  • XjingweiU 飞天小代码 2016-09-11 04:03

    图片说明
    添加上platform :ios, '8.0',重新安装即解决问题

    点赞 评论 复制链接分享

相关推荐