2 qq 32215819 qq_32215819 于 2016.09.11 12:25 提问

java的jre和jdk都是正常的,但是创建swing的项目是就报出下面两个错误,请问怎么解决

描述 资源 路径 位置 类型
无法解析类型 java.io.ObjectInputStream。从必需的 .class 文件间接引用了它 countydialog.java /RPGGame/src/demo 第 1 行 Java 问题
描述 资源 路径 位置 类型
由于项目的构建路径不完整,所以未构建该项目。找不到 java.io.ObjectInputStream 的类文件。修正构建路径,然后尝试构建此项目 RPGGame 未知 Java 问题
要真正具体的解决方法,不要像百度上说什么jre有问题,重新配置就好了那种毫无意义的答案。

1个回答

GOODLUCKYGO
GOODLUCKYGO   2016.09.11 16:40
已采纳

这个可能是JDK版本的问题,重新安装JDK最新的版本就可以,然后重新,部署安装。

qq_32215819
qq_32215819 jdk重新装了一下没报错了
接近 2 年之前 回复
qq_32215819
qq_32215819 因为jdk好像已经是最新了
接近 2 年之前 回复
qq_32215819
qq_32215819 我的eclipse版本号是3.4的,jdk是1.8.0的,请问一下就是要换高版本号的eclipse吗
接近 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
j2ee的web工程,为工程的java build path中配置jre,和为tomcat配置jre,原来是不一样的。
j2ee的web工程,为工程的java build path中配置jre,和为tomcat配置jre,原来是不一样的。 为工程的java build path中配置jre: 为tomcat配置jre: ---------总结 :
Maven项目build path的时候Libraries下 JRE版本是1.5,但我实际的JRE是1.7,为什么?
问题描述: 在构建maven WEB项目的时候,我的JDK是1.7 ,在Eclipse中也确认了版本是1.7 。 但是当我创建了一个Maven WEB项目的时候,在对这个项目进行build path管理的时候,发现Libraries目录下的JRE竟然是1.5版本。如下图: 原因分析: Maven项目依赖的环境变量、依赖jar文件等一切环境,都是通过pom.xml和用户特性设置文件se
永久的解决新建maven项目时,所用的jdk版本不对的问题
在新建maven项目时,默认使用jre system library的版本是jdk1.5 如下图所示是会显示jre system library是1.5 遇到上述问题可以在maven的配置文件中指定jdk的编译环境: 如下配置步骤: 1、在eclipse中找到maven的setting配置文件 2、找到该配置文件,在profiles
jdk安装完为什么会有两个JRE
jre 和 jdk 有什么区别? 为什么安装 jdk 后会有两套 jre?(一套一般在c:\program files\java\jre 下,一套自己选择的 jdk 安装路径下,如:c:\program files\java\jdk1.6\jre JRE 提供了 JAVA 程序运行的必要环境平台; jdk 提供了 java 的编程环境,它包含编译调试的环境功能,包含 JRE ;
解决Eclipse使用JRE而非JDK的办法
首先是配置好各种JAVA_HOME等环境变量,其次在eclipse.ini文件中-vmargs参数前添加: -vm C:/Java/jdk1.7.0_79/bin JDK安装路径最好没有空格、特殊字符等,注意上面需要分两行写。 还不行,再改下面的试下: 注意:Eclipse 4.4有问题,目前大家的解决办法都是回退到低版本
解决eclipse中项目红叉/红感叹号的方法——Jre系统库
-
Eclipse一个项目涉及到的JRE和JDK
1、全局prefrence--java-complier:选择1.7 2、项目根目录,右键bulid path--config build path--libarary:增加指定jre 3、接上面,在preference的java complier,可以选择使用全局的设置(enable project specific settings)或者也可以自己定义单个项目的设置:可以使用executi
window7 环境变量是JAVA JDK1.8和项目调用jre1.7多个版本问题
JDK 1.8安装 下载JDK1.8 jdk 1.8下载地址 点击JDK按钮 点击接受 因为我的window7系统是64位的,所以选择x64 安装JDK1.8 打开jdk-8u45-windows-x64.exe 安装一路默认即可 环境变量配置1.8 我的电脑-属性-
关于打包jre版本不兼容问题的处理
版本上线的时候,发生了jre版本不兼容问题.我本地是jdk7,服务器上是jdk6.经过了一番资料的查找,最终解决了问题.现在把经过记录一下 1)首先我们本地也需要jdk6的版本,最好把path变量也修改为我们要打包的jdk版本(这点应该不需要,不过我本人需要有这么一步) 2)在eclipse上安装jre6,具体为  :Window --> Preferences -- >Jav
java中的两个jre区别
对于java初学者来说,往往不懂区分jdk和jre的区别,实际上这两个东西差别很大的,有必要了解一下:        简单的说JDK是面向开发人员使用的SDK,它提供了Java的开发环境和运行环境。SDK是Software Development Kit 一般指软件开发包,可以包括函数库、编译程序等。 JDK就是Java Development Kit JRE是Java Runtime En