2 chen hua feng chen_hua_feng 于 2016.09.13 09:51 提问

ios开发 pod search出错,an error occurred 1C

$ pod search view

――― MARKDOWN TEMPLATE ―――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

Command

/usr/local/bin/pod search view

Report

  • What did you do?

  • What did you expect to happen?

  • What happened instead?

Stack

   CocoaPods : 1.0.1
        Ruby : ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin15]
    RubyGems : 2.6.6
        Host : Mac OS X 10.11.6 (15G31)
       Xcode : 7.3.1 (7D1014)
         Git : git version 2.7.4 (Apple Git-66)
Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ 4818af852c120dedc0dc1ab689e43e53cd619b3b

Plugins

cocoapods-deintegrate : 1.0.1
cocoapods-plugins     : 1.0.0
cocoapods-search      : 1.0.0
cocoapods-stats       : 1.0.0
cocoapods-trunk       : 1.0.0
cocoapods-try         : 1.1.0

Error

JSON::ParserError - 757: unexpected token at 'mq4-x"],"zeromq-dev":["zeromq4-x"],"zeromq-dev@lists.zeromq.org":["zeromq4-x"],"cloudidauthsdk":["cloudidauthsdk"],"cloudidloginsdk":["cloudidloginsdk"],"mmediasdk":["mmediasdk"]}}'
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/json/common.rb:155:in `parse'
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/json/common.rb:155:in `parse'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-1.0.1/lib/cocoapods-core/source/manager.rb:251:in `stored_search_index'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-1.0.1/lib/cocoapods-core/source/manager.rb:187:in `updated_search_index'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-1.0.1/lib/cocoapods-core/source/manager.rb:118:in `search_by_name'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-search-1.0.0/lib/cocoapods-search/command/search.rb:87:in `local_search'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-search-1.0.0/lib/cocoapods-search/command/search.rb:63:in `run'
/Library/Ruby/Gems/2.0.0/gems/claide-1.0.0/lib/claide/command.rb:334:in `run'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/lib/cocoapods/command.rb:50:in `run'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-1.0.1/bin/pod:55:in `<top (required)>'
/usr/local/bin/pod:22:in `load'
/usr/local/bin/pod:22:in `<main>'

――― TEMPLATE END ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

[!] Oh no, an error occurred.

Search for existing GitHub issues similar to yours:
https://github.com/CocoaPods/CocoaPods/search?q=757%3A+unexpected+token+at+%27mq4-x%22%5D%2C%22zeromq-dev%22%3A%5B%22zeromq4-x%22%5D%2C%22zeromq-dev%40lists.zeromq.org%22%3A%5B%22zeromq4-x%22%5D%2C%22cloudidauthsdk%22%3A%5B%22cloudidauthsdk%22%5D%2C%22cloudidloginsdk%22%3A%5B%22cloudidloginsdk%22%5D%2C%22mmediasdk%22%3A%5B%22mmediasdk%22%5D%7D%7D%27&type=Issues

If none exists, create a ticket, with the template displayed above, on:
https://github.com/CocoaPods/CocoaPods/issues/new

Be sure to first read the contributing guide for details on how to properly submit a ticket:
https://github.com/CocoaPods/CocoaPods/blob/master/CONTRIBUTING.md

Don't forget to anonymize any private data!

1个回答

zqbnqsdsmd
zqbnqsdsmd   2016.11.14 23:38
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
Cocopods 在使用pod install时报错整理
前天在是使用CocoPods时,使用pod install是报错,出现TEMPLATE END是其实有好几种错误。https://github.com/CocoaPods/CocoaPods/search?q=invalid+byte+sequence+in+US-ASCII&type=Issues这是一种,https://github.com/CocoaPods/CocoaPods/search
CocoaPods 安装 使用及常见错误
CocoaPods 安装 使用 1.开启 terminal 2.移除现有 Ruby 默认源 $ gem sources --remove https://rubygems.org/ 3.使用新的源 $ gem sources -a https://ruby.taobao.org/ 4.验证新源是否替换成功 $ gem sources -l 5.安装 CocoaPods $ s
pod install 报错 [!] Oh no, an error occurred.
今天在写react-native与原生Swift交互的demo时,新建了一个xcode工程SwiftRnApp执行pod install时报错――― TEMPLATE END ―――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――― [!] Oh no, an error occurred. Search for exis...
使用cocoapods遇到的一个问题,记录
问题: 今天回家,从服务器clone一份代码出来,因为用了cocoapods作为第三方库管理,也没多想,就直接pod install了,然后,问题就来了: ――― MARKDOWN TEMPLATE ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――― ### Report * What did you do? * W
使用CocoaPods版本v0.38.x,执行pod install 遇到错误的解决办法
运行pod install或者pod update时,提示An error occurred while processing the post-install hook of the Podfile.undefined method `project` for #<Pod::Installer:0x007fc26112aa68>
cocoapods 执行 pod search 命令失败解决办法
今天换了新的iMac,重新下载cocoapods,之前的步骤网上太多了。自行百度。 按照往常的方法一样安装Cocoapods,在安装的过程中遇到了一切问题,按照传统的命令sudo gem install cocoapods出现了如下的错误: ERROR: While executing gem ... (Errno::EPERM) Operation not permit
对于CocoaPods的简单理解,实践安装使用过程和常见问题
(本文是自己通过其他文章进行的自我编辑和简单修改,请大家凑活看看) 一、什么是CocoaPods CocoaPods是iOS项目的依赖管理工具,该项目源码在Github上管理。开发iOS项目不可避免地要使用第三方开源库,CocoaPods的出现使得我们可以节省设置和第三方开源库的时间。 在使用CocoaPods之前,开发项目需要用到第三方开源库的时候,我们需要 1.把开源库的源代码复制
CocoaPods: pod search 搜索类库失败的解决办法
执行pod setup 其实在你安装CocoaPods执行pod install时,系统会默认操作pod setup,然而由于中国强大的墙可能会pod setup不成功。这时就需要手动执行pod setup指令,如下:终端输入:pod setup会出现Setting up CocoaPods master repo,稍等几十秒,最底下会输出Setup completed。说明执行po
把框架上传cocoapods遇到的一个问题
[!] Oh no, an error occurred. Search for existing GitHub issues similar to yours: https://github.com/CocoaPods/CocoaPods/search?q=Malformed+version+number+string+v1.0&type=Issues
drupal7 导入翻译出错 An AJAX HTTP error occurred 现象解决办法
drupal7 导入翻译出错 An AJAX HTTP error occurred 现象解决办法