2 jiahuat jiahuat 于 2016.09.21 09:27 提问

Xcode8 升级后,无法打开Storyboard

工程有多个storyboard,如:MainStoryboard(系统自建的),***Stroyboard(自己新建的); 在升级Xcode8 后,MainStoryboard可以正常打开,***Stroyboard不能正常打开了:报错:The document “***storyboard" could not be opened. Unrecognized file content.
感谢任何帮助!(应该不会是多个提交冲突引起的)

2个回答

qq_36196874
qq_36196874   2016.09.21 10:38

不会充突,我的就没事

jiahuat
jiahuat 看来这个是有些是正常的,有些出问题了
接近 2 年之前 回复
jiahuat
jiahuat   2016.09.22 13:37

问题解决了,结果出错的那个sotyboard,那个“S” 是大写的,改为小写的“s”就好了。

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
XCode7打开XCode8项目的Storyboard
XCode8升级之后新建的项目,Storyboard默认在低版本的XCode中是打不开的,会提示如下错误 但是由于新版的XCode8刚出来不久,不是很稳定,有些程序员还是喜欢用6或者7,下面是解决方法。右键你要打开的那个Storyboard,选择“Open As”---> “Source Code”,然后看到Storyboard的源码,是XML格式的,找到<capability name="doc
XCode9 打开StoryBoard崩溃问题解决办法
在XCode8时代创建了一个Swift的项目使用的是StoryBoard开发, 升级到XCode9之后,今天打开的时候,一点击StoryBoard就会崩溃看了崩溃日志:UNCAUGHT EXCEPTION (NSInternalInconsistencyException): Could not find class named UIImage 意思说是找不到一个名为UIImage的类 这样根本
XCode8升级到Xcode9(操作系统为iOS11)后原来的工程中遇到的问题
1.无法识别check_compile_time,导致工程无法编译不过。 原来的工程中使用了QNNetDiag第三方库. QNNPing.m中使用check_compile_time,所以编译时报下面的错误。 本来就是编译时的断言,暂时去掉就可以了。就是有问题断言条件成立,那么应用就会crash,所以在发布版本有断言本来就没有什么好处,只有调试时才有用,提前暴露问题。所以去掉这些断言没有什么影
xcode8 导致storyboard页面显示不全
在xode8中,所有的view都是1000*1000 的frame 每当我们在awakeFromNib,viewDidLoad方法中有涉及到frame,bounds,center数据改变时,就会出现模拟器页面显示不全的问题。 当然 swift,object-c 都会出现这个问题 有一个方法 super.layoutIfNeeded() 可以解决我们的烦恼!番外:项目中第一次出现这个问题时在viewD
ios开发之正确删除storyboard
删除storyboard的正确方法 一般情况下,我们有时候不想用storyboard,但是直接删除的话,Xcode就会报错。那我今天就来讲一下,正确删除storyboard的方法。 第一步,直接将工程中的storyboard直接删除掉,这样你觉得就OK了?你错了,我们还需要第二步。 第二步,找到plist文件,将plist文件中的Main storyboard file base
解决低版本的xcode不能打开xcode8.0
//原文地址:http://write.blog.csdn.net/postedit?ticket=ST-296000-IokigVZ2qAMBGZBT46td-passport.csdn.net 14号的凌晨看了WWDC2016,到底有什么更新就不在这里说啦,早上过来公司就登陆开发者账号看了看这些beta版的新品,顺便更新了系统,下载安装了Xcode8,期待正式版发布。 同时也遇到一
解决使用高版本Xcode打开StoryBoard后低版本Xcode打不开问题
因为我的Mac上装了Xcode5.0.2和Xcode6.1两个版本,有时候使用的时候,不小心会搞错,前段时间因为用Xcode6.1打开了工程里面的Storyboard,但是用Xcode5.0.2再打开运行的时候,就发现会报错了,目前我知道有两种解决办法,如果看到这篇文章的朋友,还有另外的方法,请给我留言,我会补充上去,谢谢大家!首先,第一种办法,也是最常用的办法,就是在使用Xcode6.1打开Sto
升级xCode9 导航栏变化及一些小技巧
code9已在9月20号推出, 相信很多人充满期待, 那么新版Xcode给我们带来哪些新东西呢? 下载后发现很多人哀声载道, 很大一部分是不适应新的编译器, 那么我们我们该如何去调整呢? 耐心看完本文或许你能找到一些答案! 1.模拟器的变化 相信很多人不太习惯新版模拟器, 那么如何恢复呢, 看下图:是不是切换很随意. 2.Jump to Definition 点击
xcode升级到8.0后Qt编译失败的解决办法
xcode升级的8以后,笔者发现Qt编译不了了。原因在于Qt查找xcrun而现在应该找xcodebuild。 步骤1: 打开文件: Qt_install_folder/5.7/clang_64/mkspecs/features/mac/default_pre.prf 步骤2: 用 isEmpty($$list($$system("/usr/bin/xcrun -find x
iOS 解决xcode8中的xib冲突
iOS xcode8冲突 xib冲突