2 ffffatass Ffffatass 于 2016.09.23 11:00 提问

Struts2的配置问题,Tomcat加载就报错

![![![![图片说明](https://img-ask.csdn.net/upload/201609/23/1474599459_447497.png)图片说明](https://img-ask.csdn.net/upload/201609/23/1474599450_937679.png)图片说明](https://img-ask.csdn.net/upload/201609/23/1474599440_107426.png)图片说明](https://img-ask.csdn.net/upload/201609/23/1474599426_516941.png)图片说明

6个回答

Ffffatass
Ffffatass   2016.09.23 10:59

Jar包和XML应该都是正常的

<?xml version="1.0" encoding="UTF-8"?>
xmlns="http://java.sun.com/xml/ns/javaee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">


index.jsp


struts2
org.apache.struts2.dispatcher.FilterDispatcher


struts2
/*

u013076997
u013076997   2016.09.23 11:02

从报错内容来看是spring的一个jar包没有引入吧

Ffffatass
Ffffatass   2016.09.23 10:59


struts2
org.apache.struts2.dispatcher.FilterDispatcher


struts2
/*

Ffffatass
Ffffatass   2016.09.23 11:04

我把所有包引入还是会报错
严重: Exception starting filter struts2
Unable to load configuration. - bean - jar:file:/C:/Program%20Files/Apache%20Software%20Foundation/Tomcat%207.0/webapps/web/WEB-INF/lib/struts2-codebehind-plugin-2.3.30.jar!/struts-plugin.xml:29:122

qq_27905183
qq_27905183   2016.09.23 11:45

貌似是导入的包和Struts当前版本不匹配

Ffffatass
Ffffatass 什么意思?我导入的包就是下载版本里的包
接近 2 年之前 回复
cs1075341779
cs1075341779   2016.09.23 11:46

报错显示的是spring-context包未找到或者冲突

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
导入struts2框架项目无法运行tomcat
导入的项目框架和自建的项目运行环境可能不同,所以导入的struts2框架环境无法运行,自建项目搭建的框架才行.同样的配置,你自建一个项目拷过去就行.
Tomcat和Struts2的问题解决(2)
 struts2+Tomcat3.2,试验一个sturts2的helloworld工程。出现如下问题,找不到struts-tags.tld.而实际上次tld存在于struts2-core-2.0.9.jar中的META_INF中,应该能自动找到的,从网上搜资料也没有搜到。最后没办法了,换成了Tomcat5.5!Good,Success!!!Location: /Struts2_HelloWor
IDEA中创建struts2工程时,tomcat服务器启动一直出错
刚开始采用自动的下载的jar包,后一直包严重警告,启动错误什么的自动下载的jar包如图,一直启动错误,找了很多错误然后发现可能是jar包的问题,后来自己下载jar包,如图所示并且移动了lib位置,其实移动不移动无所谓,你在project struts中添加好路径就行,这样一来服务器能正常启动了不过我为了测试又建立了一个空白的struts工程,采用自动下载的jar包这样有启动tomcat 顺利成功,...
Struts2.5版本之后Tomcat启动报错问题
初次学习Struts2,本着学习最新版本知识的原则,使用了Struts2.5.5版本。使用2.1版本没有问题,但是2.5版本果然会报错,完全靠自学。。。我真是解决两个小时啊!对新手来说上手坑真的比较多。。。 1.导入lib,我们只需要导入一些最小依赖包,下面列出的是我导入的 commons-fileupload-1.3.2.jar commons-io-2.4.jar commons-la
采用共享jar包部署struts2+spring集成项目会遇到的问题
比如tomcat下边有个lib,放着我们需要的struts2 + spring 集成jar包(一定要struts2和spring集成),即共享给所有webapp使用,如图: 此时tomcat启动时,会先加载a项目,再加载b项目(一定要是这个顺序才会出现问题,比如tomcat是通过list file顺序部署的)。(关于tomcat的classloader请参考:http://tomcat.
tomcat启动或,struts2需要加载哪些配置文件,加载顺序
1.struts-default.xml 2.struts-plugin.xml 3.自己的struts配置文件
IDEA 配置 Tomcat与Struts2时报错
Struts2 ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging
tomcat单独启动正常,在myeclipse中启动时加载不完也不报错
这问题碰到几次了,网上搜到好多解决方法,但每次都没解决,最后发现问题所在了: myeclipse中断点的问题,删除断点就正常启动了! 我去,也着实汗了一把,其他的解决方法自行百度吧! 为了自己长点记性!
运行struts2程序时核心加载包struts2-core-2.3.15.1.jar报严重错误
以下是我在做struts2时遇到的问题,因花了好长时间才解决,贴出来给有需要的人一点帮助 cause by:Unable to load configuration. - bean - jar:file:/D:/apache-tomcat-6.0.362/webapps/beidao/WEB-INF/lib/struts2-core-2.3.15.1.jar!/struts-default.xm
tomcat项目加载报错
项目加载到tomcat出先Redeploy错误的解决办法。