梅明子
2016-10-22 14:56
采纳率: 91.9%
浏览 901
已采纳

启动 eclipse 报错问题,急!

启动时弹出这个错误:Failed to load the JNI shared jvm.dll
网上找了下都说要么是版本问题,或者不存在那个jvm,dll文件,但我特意去仔细查看了下都是正常的啊,到底是什么原因呢?求大神们解救啊!
下面是启动时的错误
图片说明
下面是查看...bin/jer/bin是否存在jvm.dll文件
图片说明
下面是查看...jer7/bin是否存在jvm.dll文件
图片说明
下面是查看jdk的版本确实是32位的啊!(不出现64就默认位32位)
图片说明
下面是查看eclipse版本确实也是32位的啊!那就不应该存在说是版本的问题吧!
图片说明

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • 梅明子 2016-10-22 15:05
    已采纳

    好吧,发现一个很严重又很无语的问题,仔细再三查看了下eclipse版本之后发现那里后面是带64的,所以说明eclipse是64位的,而jdk是32位的,因此推断应该还是版本的问题,下载64位的jdk试试先!

    打赏 评论
  • 梅明子 2016-10-22 15:25

    OK了!还真是这个版本的问题,无语啊!真是太不细心了,没注意到eclipse.ini文件中那个win32.x86后面还有个64。=。=///

    打赏 评论
  • 写程序的娃 2016-10-23 01:31

    呵呵,楼主自己搞定了。

    打赏 评论
  • niaonao 2016-10-23 02:54

    嘻嘻
    遇见错误何尝不是一种好事
    自己解决错误更是一种进步

    打赏 评论

相关推荐 更多相似问题