ssm框架新版本使用报错

我用的win10+MyEclipse2016+jdk1.8+spring4.2.4+MyBatis3.3的ssm框架的web应用总是在访问action时报错

 HTTP Status 500 - Request processing failed; nested exception is org.springframework.transaction.CannotCreateTransactionException: Could not open JDBC Connection for transaction; nested exception is org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Access denied for user 'root'@'localhost' (using password: YES))

,但是在低版本的jdk和lib下项目没有任何问题,换成新版本就出错了,找了好长时间没有找到答案,大家有没有遇到过,或者可以用的ssm高版本的lib分享一下

3个回答

可能跟jdk1.8有关,会不会版本太高了

baij1230
baij1230 回复呜呜呜啦啦啦: 不过基本上要求都是1.7
3 年多之前 回复
u013360850
呜呜呜啦啦啦 要求配置的版本就是1.8
3 年多之前 回复

看着像是数据库的权限不对。mysql的话需要调整访问权限。

u013360850
呜呜呜啦啦啦 数据库没有问题,其他的项目同样配置可以正常使用,问题应该在于包的配置上
3 年多之前 回复

数据库账户名密码的问题吧,,

u013360850
呜呜呜啦啦啦 不是数据库,高版本的包邮问题
3 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问