用Eclipse 启动 tomcat 报错 求大神 给小弟解答一下,感激不尽

十二月 07, 2016 5:02:16 下午 org.apache.catalina.core.AprLifecycleListener init
严重: An incompatible version 1.1.30 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.32
十二月 07, 2016 5:02:16 下午 org.apache.catalina.core.AprLifecycleListener init
严重: An incompatible version 1.1.30 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.32
十二月 07, 2016 5:02:16 下午 org.apache.catalina.core.AprLifecycleListener init
严重: An incompatible version 1.1.30 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.32
十二月 07, 2016 5:02:16 下午 org.apache.catalina.core.AprLifecycleListener init
严重: An incompatible version 1.1.30 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.32
十二月 07, 2016 5:02:16 下午 org.apache.tomcat.util.digester.SetPropertiesRule begin
警告: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:毕设准备' did not find a matching property.
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Server version: Apache Tomcat/7.0.73
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Server built: Nov 7 2016 21:27:23 UTC
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Server number: 7.0.73.0
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: OS Name: Windows 7
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: OS Version: 6.1
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Architecture: x86
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Java Home: D:\Program Files
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: JVM Version: 1.8.0_91-b14
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: JVM Vendor: Oracle Corporation
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: CATALINA_BASE: C:\Users\Administrator\workspace.metadata.plugins\org.eclipse.wst.server.core\tmp0
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: CATALINA_HOME: C:\Program Files\Apache Software Foundation\Tomcat 7.0
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dcatalina.base=C:\Users\Administrator\workspace.metadata.plugins\org.eclipse.wst.server.core\tmp0
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dcatalina.home=C:\Program Files\Apache Software Foundation\Tomcat 7.0
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dwtp.deploy=C:\Users\Administrator\workspace.metadata.plugins\org.eclipse.wst.server.core\tmp0\wtpwebapps
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Djava.endorsed.dirs=C:\Program Files\Apache Software Foundation\Tomcat 7.0\endorsed
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dfile.encoding=GBK
十二月 07, 2016 5:02:16 下午 org.apache.catalina.core.AprLifecycleListener init
严重: An incompatible version 1.1.30 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.32
十二月 07, 2016 5:02:16 下午 org.apache.coyote.AbstractProtocol init
信息: Initializing ProtocolHandler ["http-bio-8080"]
十二月 07, 2016 5:02:16 下午 org.apache.coyote.AbstractProtocol init
信息: Initializing ProtocolHandler ["ajp-bio-8009"]
十二月 07, 2016 5:02:16 下午 org.apache.catalina.startup.Catalina load
信息: Initialization processed in 436 ms
十二月 07, 2016 5:02:16 下午 org.apache.catalina.core.StandardService startInternal
信息: Starting service Catalina
十二月 07, 2016 5:02:16 下午 org.apache.catalina.core.StandardEngine startInternal
信息: Starting Servlet Engine: Apache Tomcat/7.0.73
十二月 07, 2016 5:02:17 下午 org.apache.catalina.util.SessionIdGeneratorBase createSecureRandom
信息: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [211] milliseconds.
十二月 07, 2016 5:02:17 下午 org.apache.coyote.AbstractProtocol start
信息: Starting ProtocolHandler ["http-bio-8080"]
十二月 07, 2016 5:02:17 下午 org.apache.coyote.AbstractProtocol start
信息: Starting ProtocolHandler ["ajp-bio-8009"]
十二月 07, 2016 5:02:17 下午 org.apache.catalina.startup.Catalina start
信息: Server startup in 531 ms

4个回答

你的tomcat下载的不完整,建议你重新下载一个,并配置好到开发工具上

很明确了版本问题啊

http://archive.apache.org/dist/tomcat/tomcat-connectors/native/1.1.32/binaries/

去下载这个版本替换吧,tomcat安装目录bin下应该有tcnative-1.dll把新版本替换它

如果还不行说明系统环境搜索的不是bin下,还不行试试放system32或者jdk的bin下,最好搜下这个文件在哪个位置替换掉

qq_19811781
qq_19811781 都替换了,还报错。
接近 3 年之前 回复

An incompatible version 1.1.30 of the APR based Apache Tomcat Native library is installed, while Tomcat requires version 1.1.32
版本问题

下载了,能替换的都替换了,还是不行。

qq381332153
noWayBinding 这个错误信息其实不影响tomcat部署使用的。还不行试试加环境变,添加CATALINA_HOME,指向你的Tomcat根目录,PATH路径中添加%CATALINA_HOME%\bin。最后把tcnative-1.dll放到你的tomcat的bin下。还不行就别管了
接近 3 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!