有关postgres 中流复制工具pg_basebackup问题

在从库上执行命令:
pg_basebackup -D /home/pgdata -Fp -Xs -v -P -h 192.168.75.134 -U repuser -p 5432

出现某文件权限问题:
pg_basebackup: starting background WAL receiver
24/28038 kB (100%), 1/1 tablespace

pg_basebackup: could not get transaction log end position from server: ERROR: could not open file "./.pg_hba.conf.swp": Permission denied
各位大神怎么解决?

4个回答

我也碰到了这个问题 请问楼主你后来解决了吗

主服务器 pg_hba.conf文件 配置 如下格式
host replication apigee existing_slave_ip/32 trust
host replication apigee new_slave_ip/32 trust
我最开始设置24 出现同样问题,修改成32 就成功了。

在数据库配置文件夹中:/var/lib/pgsql/10/data
#ll -a
#rm -rf pg_hba.conf.swp

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
postgresql9.6流复制从库启动找不到所需的检查点记录

做postgresql流复制的时候,从库在使用pg_basebackup命令后启东时报错。 这是日志内容 ``` [postgres@node2 pg_log]$ cat postgresql-2020-03-26_155810.log LOG: database system was interrupted; last known up at 2020-03-26 15:45:46 CST LOG: entering standby mode LOG: trigger file found: /tmp/trigger_file0 LOG: invalid checkpoint record FATAL: could not locate required checkpoint record HINT: If you are not restoring from a backup, try removing the file "/psql/data/backup_label". LOG: startup process (PID 10511) exited with exit code 1 LOG: aborting startup due to startup process failure LOG: database system is shut down ``` 这是recovery.confde内容 ``` standby_mode = 'on' primary_conninfo = 'user=stream_replication password=123 host=node1 port=5432 sslmode=disable sslcompression=1' trigger_file = '/tmp/trigger_file0' recovery_target_timeline = 'latest' ``` 有没有大佬指点一下

我可以在php / postgres pg_escape_string中添加char限制吗? 如果是这样的话?

<div class="post-text" itemprop="text"> <p>I've this php code:</p> <pre><code> $reg_number = strtoupper(pg_escape_string($_SESSION['regiter'][2]['serial'])); </code></pre> <p>I need to set $reg_number field to max 10 char adding the limit to this string</p> <p>Thank you if you provide me the code</p> <p><strong>EDIT</strong></p> <p>I need that $reg_number must equal to 10 or under 10 char. (in my postgres db the field is char limit to 10...sorry)</p> <p>"cutted" results is ok</p> </div>

在PHP和Postgres中使用pg_query_params传递DESC或ASC

<div class="post-text" itemprop="text"> <pre><code>$query = "SELECT field1, field2, field3, date_created, id FROM database WHERE field1 LIKE $1 OR field2 LIKE $1 ORDER BY date_created $2 LIMIT $3 OFFSET $4"; $result = pg_query_params($this-&gt;pgConnect($this-&gt;database_conn_string), $query, array('%' . $this-&gt;input . '%', $this-&gt;order, $this-&gt;numberOfItems, $this-&gt;selectField1FromDatabaseSearchOffset())); return $result; </code></pre> <p>I'm not getting any sort of useful error, just that the error is with $2, which will be either set to DESC or ASC., the error goes away if I stop trying to pass in this so it's clearly a problem passing in the order in this way however I have no idea why and how I would do it in a secure manner. The value comes in from a url parameter, put through 'htmlspecialchars' then passed to this.</p> <p>Update- should mention it does work if I put it directly in $query i.e. like:</p> <pre><code>$query = "SELECT field1, field2, field3, date_created, id FROM database WHERE field1 LIKE $1 OR field2 LIKE $1 ORDER BY date_created $this-&gt;order LIMIT $2 OFFSET $3"; </code></pre> <p>Though I don't think this is a secure way to do it, plus not very consistent!</p> </div>

php .postgres 9.1中的Pg_dump错误

<div class="post-text" itemprop="text"> <p>I can not do the backup because windows throws error and I do not know how to solve it I need to backup postgres using php and windows. This is the command used.</p> <pre><code>**exec('pg_dump --dbname=postgresql://username:root@localhost:5432/sicanar &gt; dbbackup.sql',$output); print_r($output);** </code></pre> <p>But windows throws this error</p> <p>The entry point for the icon_open procedure is not found in the C: \ WINDOWS \ System32 \ libintl.dll library</p> <p><a href="https://i.stack.imgur.com/ABYMm.png" rel="nofollow noreferrer">this error</a></p> </div>

麻烦大神 详解下 Postgresql 9.5版本后的 pg_xlog 原理,以及如何计算可保存的最大文件数等

麻烦大神 详解下 Postgresql 9.5版本后的 pg_xlog 原理,以及如何计算可保存的最大文件数等

PHP5 + PostgreSQL - pg_fetch_row()返回字符串而不是数组

<div class="post-text" itemprop="text"> <p>PHP5 + PostgreSQL (ubuntu 12.04) according to the doco returns an array for pg_fetch_row(). By my test results indicate that it's returning a string, is there some configuration option for this?</p> <pre><code>$db = openDatabase(&lt;blah&gt;); $query = "SELECT (id,serial,tag) FROM devices ORDER BY tag ASC"; $result = pg_query($db,$query); if ($result) { while ($row = pg_fetch_row($result)) echo "IN: $row[0] - $row[1] - $row[2]"; } </code></pre> <p>I expect to see </p> <pre><code>IN: &lt;value&gt; - &lt;value&gt; - &lt;value&gt; </code></pre> <p>But I get </p> <pre><code>IN: (&lt;value&gt;,&lt;value&gt;,&lt;value&gt;) - - </code></pre> <p>I guess this means pg_fetch_row() is returning a string not an array?!</p> <p>e.g. the actual run:</p> <pre><code>IN: (10,7426573,________) - - IN: (7,6862,FMUX-TAG) - - IN: (9,6914082,L6) - - </code></pre> <p>It seems a simple problem, but I can't find an answer. I know I can parse the result, but that's kludgey.</p> </div>

postgresql service找不到以及psql找不到,为什么?小白求答

系统是deepin15,安装postgresql12 -- ![图片说明](https://img-ask.csdn.net/upload/202003/18/1584522305_709352.png) 这是我/home/postgres/.bash_profile -- 我是按照这篇文章进行配置的 -- https://www.cnblogs.com/acker-ploy/p/11978953.html -- 但是 ``` root@chen-PC:/# service postgresql start Failed to start postgresql.service: Unit postgresql.service not found. ``` 然后进入postgres用户 ``` root@chen-PC:/# su - postgres $ psql -su: 1: psql: not found $ ``` /usr/local/postgresql/bin ``` clusterdb logfile pg_ctl pg_restore postmaster createdb pg_archivecleanup pg_dump pg_rewind psql createuser pg_basebackup pg_dumpall pg_test_fsync reindexdb dropdb pgbench pg_isready pg_test_timing vacuumdb dropuser pg_checksums pg_receivewal pg_upgrade ecpg pg_config pg_recvlogical pg_waldump initdb pg_controldata pg_resetwal postgres ``` ------- ![图片说明](https://img-ask.csdn.net/upload/202003/18/1584522862_645676.png) 问题出在哪里啊?两天了还没有搞清楚,网上也没有相同的情况!!!求求各位大佬

得到致命错误:调用未定义的函数pg_connect

<div class="post-text" itemprop="text"> <p>I'm developing my first program with php. I searched a lot of forums and about 3 or 4 hours, but got nothing.</p> <p>Here is my index.php code:</p> <pre><code>&lt;html&gt; &lt;head&gt; &lt;title&gt;first program&lt;/title&gt; &lt;/head&gt; &lt;body&gt; &lt;h1&gt; program loaded successfully&lt;/h1&gt; &lt;?php echo extension_loaded('pgsql') ? 'yes':'no'; echo pg_connect("host=localhost port=5432 dbname=test user=postgres password=root"); ?&gt; &lt;/body&gt; </code></pre> <p> When I load this page I see this:</p> <pre><code>program loaded successfully no Fatal error: Call to undefined function pg_connect() in D:\courses\web programing\hw2\cinema\index.php on line 9 </code></pre> <p>I installed php-5.4.14-Win32-VC9-x86 on my windows and run my project with this comment:</p> <pre><code>php.exe" -S localhost:80 -t "D:\courses\web programing\hw2\cinema" </code></pre> <p>I have php.ini-development and php.ini-production in php folder and Uncommented extension=php_pgsql.dll, extension=php_pdo_pgsql.dll in both files. I'm using postgresql 9.2</p> <p>So where is my mistake?</p> </div>

PHP到Postgres - 致命错误:调用未定义的函数pg_connect()

<div class="post-text" itemprop="text"> <p>I've just set Postgres up on my Mac (El Capitan) and I am trying to connect to it via PHP... however, when I submit a sample form, I get "Fatal error: Call to undefined function pg_connect()". I've been researching this on Stack (which is how I got this far), but I'm not sure where I need to go from here.</p> <p>Here's how I've put this together so far...</p> <ul> <li><p>I use homebrew, and I ran <code>brew install php55-pdo-pgsql</code>.</p></li> <li><p>I updated my Apache httpd.conf file, replacing <code>LoadModule php5_module libexec/apache2/libphp5.so</code> with <code>LoadModule php5_module /usr/local/opt/php55/libexec/apache2/libphp5.so</code>.</p></li> <li><p>I restarted Apache.</p></li> </ul> <p>I'm not sure if it's helpful here or not, but here's the PHP...</p> <pre><code>$name = $_POST['name']; $species = $_POST['species']; $conn = pg_connect("host=localhost dbname=menagerie user=root password=****"); pg_query($conn, "INSERT INTO pet (name, species) VALUES ('$name', '$species')"); </code></pre> <p>What have I overlooked? Thanks very much.</p> </div>

pg_query_params不允许带引号的占位符

<div class="post-text" itemprop="text"> <p>I'm working on a postgreSQL query that is searching for a column that is contained in a geometry and it works perfectly if run it through pgAdmin but I cannot make it works with <code>pg_query_params</code> through PHP</p> <p>this is the working query</p> <pre><code>select a.full_address from streets a, gisgeometry b where b."Name" ILIKE ANY ('{%Barnet%}') AND ST_CONTAINS(b.sp_geometry,a.wkb_geometry) and a.full_address ilike '%high street%' group by a.full_address ORDER BY a.full_address LIMIT 100; </code></pre> <p>if asked through PHP i can make it work with <code>pg_query</code></p> <pre><code>$result = pg_query($connect,'select a.full_address from streets a, gisgeometry b where b."Name" ILIKE ANY ('.$bbox.') AND ST_CONTAINS(b.sp_geometry,a.wkb_geometry) and a.full_address ilike '.$pattern.' group by a.full_address ORDER BY a.full_address LIMIT 100;'); </code></pre> <p>not with <code>pg_query_params</code></p> <pre><code>$result = pg_query_params($connect,'select a.full_address from streets a, gisgeometry b where b."Name" ILIKE ANY ($1) AND ST_CONTAINS(b.sp_geometry,a.wkb_geometry) and a.full_address ilike $2 group by a.full_address ORDER BY a.full_address LIMIT 100;', array($bbox, $pattern)); </code></pre> <p>I do of course sanitation and everything in PHP and with <code>pg_query</code> I can make it works in this way (I mean add the single quotes around the variables)</p> <pre><code> $pattern = fixtags($_POST['findthis']); $pattern = str_replace(" ", "%", $pattern); ## add single quotes and % around the pattern $pattern = "'%".$pattern."%'"; $bbox = fixtags($_POST['ext']); $bbox = explode(",", $bbox); foreach ($bbox as &amp;$value) { $value = "%$value%"; } $bbox = implode(",", $bbox); ## add single quotes and {} around the pattern $bbox = "'{". $bbox ."}'"; </code></pre> <p>with <code>$pattern = "%".$pattern."%";</code> and <code>$bbox = "{". $bbox ."}";</code> without single quotes or with quotes as above the error is:</p> <pre><code>Got error 'PHP message: PHP Warning: pg_query_params(): Query failed: ERROR: array value must start with &amp;quot;{&amp;quot; or dimension information in ...php on line 367 PHP message: .. </code></pre> </div>

执行后事务保持在pg_stat_activity状态

<div class="post-text" itemprop="text"> <p>I'm quite new to both PostgreSQL and golang. Mainly, I am trying to understand the following:</p> <ul> <li>Why did I need the Commit statement to close the connection and the other two <code>Close</code> calls didn't do the trick?</li> <li>Would also appreciate pointers regarding the right/wrong way in which I'm going about working with cursors.</li> </ul> <hr> <p>In the following function, I'm using <code>gorp</code> to make a CURSOR, query my Postgres DB row by row and write each row to a writer function:</p> <pre><code>func(txn *gorp.Transaction, q string, params []interface{}, myWriter func([]byte, error)) { cursor := "DECLARE GRABDATA NO SCROLL CURSOR FOR " + q _, err := txn.Exec(cursor, params...) if err != nil { myWriter(nil, err) return } rows, err := txn.Query("FETCH ALL in GRABDATA") if err != nil { myWriter(nil, err) return } defer func() { if _, err := txn.Exec("CLOSE GRABDATA"); err != nil { fmt.Println("Error while closing cursor:", err) } if err = rows.Close(); err != nil { fmt.Println("Error while closing rows:", err) } else { fmt.Println(" Closed rows without error", " ") } if err = txn.Commit(); err != nil { fmt.Println("Error on commit:", err) } }() pointers := make([]interface{}, len(cols)) container := make([]sql.NullString, len(cols)) values := make([]string, len(cols)) for i := range pointers { pointers[i] = &amp;container[i] } for rows.Next() { if err = rows.Scan(pointers...); err != nil { myWriter(nil, err) return } stringLine := strings.Join(values, ",") + " " myWriter([]byte(stringLine), nil) } } </code></pre> <p>In the <code>defer</code> section, I would initially, only <code>Close</code> the <code>rows</code>, but then I saw that <code>pg_stat_activity</code> stay open in <code>idle in transaction</code> state, with the <code>FETCH ALL in GRABDATA</code> query.</p> <p>Calling <code>txn.Exec("CLOSE &lt;cursor_name&gt;")</code> didn't help. After that, I had a <code>CLOSE GRABDATA</code> query in <code>idle in transaction</code> state...</p> <p>Only when I started calling <code>Commit()</code> did the connection actually close. I thought that maybe I need to call Commit to execute anything on the transation, but if that's the case - how come I got the result of my queries without calling it?</p> </div>

postgresql 密码口令无法输入 psql pg_dump 都无法输入

哪位大神帮忙一下![图片说明](https://img-ask.csdn.net/upload/201611/02/1478080604_105965.png) ![图片说明](https://img-ask.csdn.net/upload/201611/02/1478080618_242631.png)

postgre SQL初学,restore dvdrental 数据库时报错,请教如何解决?

postgre SQL初学,restore dvdrental时报错,请教如何解决?感谢! 有没有完好的PostgreSQL数据库资源供练习?最好还是dvdrental,在complete SQL bootcamp教程里使用的范例数据库 pg_restore: connecting to database for restore pg_restore: implied data-only restore pg_restore: processing data for table "public.actor" pg_restore: while PROCESSING TOC: pg_restore: from TOC entry 3057; 0 16757 TABLE DATA actor postgres pg_restore: error: could not execute query: 错误: 关系 "public.actor" 不存在 Command was: COPY public.actor (actor_id, first_name, last_name, last_update) FROM stdin; pg_restore: error: could not find header for file "3057.dat" in tar archive

警告:pg_query()期望参数1为字符串,资源在[关闭]中给出

<div class="post-text" itemprop="text"> <p>I wanted to show my database but I have this error:</p> <blockquote> <p>Warning: pg_query() expects parameter 1 to be string, resource given in</p> </blockquote> <pre><code>&lt;?php session_start(); pg_connect("host=localhost port=5432 dbname=base_test user=postgres password=123456") or die('Could not connect: ' . pg_last_error()); $q=pg_query("select timestamp, outdoor, indoor from align_data"); $query=pg_query($q); $n=pg_num_rows($query); for($i=0; $i&lt;$n; $i++) { $f=pg_fetch_row($query1); echo("['".$f[0]."', ".$f[1].", ".$f[2]."], "); } ?&gt; </code></pre> </div>

使用php将txt文件导入postgres时出现问题

<div class="post-text" itemprop="text"> <p>I am trying to import a txt/csv file into my postgres database from php using "\copy" command. I cannot use COPY instead of \copy as I need it to execute as a psql client. My code is:</p> <pre><code>$query = '\\'.'copy data1 FROM "data1.txt" WITH CSV HEADER DELIMITER AS "," QUOTE AS "^"'; $result = pg_query($conn,$query); if (!$result) { echo "cannot copy data "; } else { echo "SUCCESS!"; } </code></pre> <p>When I run this php file, I get this error:</p> <pre><code>PHP Warning: pg_query(): Query failed: ERROR: syntax error at or near "\" LINE 1: \copy data1 FROM "data1.txt" WITH ... ^ in script.php on line 30 </code></pre> </div>

PostgreSQL函数pg_ping()的目的是什么?

<div class="post-text" itemprop="text"> <p>According to the manual ( <a href="https://php.net/pg_ping" rel="nofollow noreferrer">https://php.net/pg_ping</a> ):</p> <pre><code>pg_ping() pings a database connection and tries to reconnect it if it is broken. </code></pre> <p>Aaaalright... So where would one ever do that? Is this for many-hours-long while (1) loops which only very rarely makes a query? How long is the timeout normally? Why is there a timeout at all? Should I change some setting? I don't understand the purpose of this feature/function. I can't find any sensible example or explanation as to when it would ever be used, or why.</p> <p>Please explain.</p> </div>

pg_send_query_params返回TRUE但失败

<div class="post-text" itemprop="text"> <p>I have a PHP script which inserts a row into a Postgres DB. It works fine on my test server (Postgres 9.1) but fails on my new shared host (Postgres 8.4).</p> <pre><code>$query = "INSERT INTO " . $table . " VALUES (DEFAULT, $1, $2, CURRENT_TIMESTAMP::TIMESTAMP(0), $3, $4, ST_Point($4, $3))"; $result = pg_send_query_params($dbconn, $query, array($is_happy, $rate, $lat, $lon)); </code></pre> <p>The <code>$result</code> is always TRUE but no row is inserted.</p> <p>I also tried:</p> <pre><code>$result = pg_get_result($dbconn); </code></pre> <p>But experienced the same behaviour.</p> <p>Following @CraigRinger's transaction suggestion below I also tried both:</p> <pre><code>$query = "BEGIN;INSERT INTO " . $table . " VALUES (DEFAULT, $1, $2, CURRENT_TIMESTAMP::TIMESTAMP(0), $3, $4, ST_Point($4, $3));COMMIT;"; $result = pg_send_query_params($dbconn, $query, array($is_happy, $rate, $lat, $lon)); </code></pre> <p>and</p> <pre><code>pg_send_query($dbconn, "BEGIN;"); $query = "INSERT INTO " . $table . " VALUES (DEFAULT, $1, $2, CURRENT_TIMESTAMP::TIMESTAMP(0), $3, $4, ST_Point($4, $3));"; $result = pg_send_query_params($dbconn, $query, array($is_happy, $rate, $lat, $lon)); pg_send_query($dbconn, "COMMIT;"); </code></pre> <p>And still got the same behaviour.</p> <p>If I run the INSERT query in phpPgAdmin a row is inserted. I am also able to get the results from this query in a PHP script:</p> <pre><code>"SELECT relid FROM pg_stat_user_tables" </code></pre> <p>What does this mean when the INSERT query result is true but no row is inserted? What could be the problem and how might I approach resolving this? </p> <p><strong>Edit</strong></p> <p>I can <code>INSERT</code> rows using phpPgAdmin and then <code>SELECT</code> these rows from a PHP script.</p> <p>Here is a full PHP script that fails (it is stripped of POST gathering and validation that exists in my full script). The <code>rest.php</code> script simply holds connection vars and a response function. This <code>rest.php</code> script works with my <code>SELECT</code> script:</p> <pre><code>&lt;?php require "KLogger.php"; require "rest.php"; ini_set("error_reporting", E_ALL ^ E_NOTICE); ini_set("display_errors", 0); ini_set("log_errors", 1); $log = KLogger::instance(dirname(__FILE__), KLogger::DEBUG); $log_id = "AM".time(); $log-&gt;logInfo($log_id . " *** " . $_SERVER['REMOTE_ADDR']); $lat = '51.510199'; $lon = '-0.129654'; $rate = '10'; $is_happy = 't'; $dbconn = pg_connect("host=" . $host . " dbname=" . $db . " user=" . $user . " password=" . $pw); if(!$dbconn) { $log-&gt;logInfo($log_id . " No connection: " . pg_last_error()); sendResponse(500, "Internal Server Error"); } else { $query = "INSERT INTO " . $table . " VALUES (DEFAULT, $1, $2, CURRENT_TIMESTAMP::TIMESTAMP(0), $3, $4, ST_Point($4, $3));"; $result = pg_send_query_params($dbconn, $query, array($is_happy, $rate, $lat, $lon)); if(!$result) { $log-&gt;logInfo($log_id . " No Result: " . pg_last_error()); sendResponse(500, "Internal Server Error"); } else { $log-&gt;logInfo($log_id . " sendResponse(200)"); sendResponse(200, "OK"); } } pg_close($dbconn); ?&gt; </code></pre> </div>

Golang lib / pg无法连接到Postgres

<div class="post-text" itemprop="text"> <p>I have such code:</p> <pre><code>package main import ( "database/sql" "fmt" "log" _ "github.com/lib/pq" ) func main() { db, err := sql.Open("postgres", "user=postgres dbname=vagrant sslmode=disable") if err != nil { log.Fatal(err) } rows, err := db.Query("SELECT 3+5") if err != nil { log.Fatal(err) } fmt.Println(rows) } </code></pre> <p>And its result is:</p> <pre><code>[vagrant@localhost go-postgres]$ go run test.go 2015/12/19 11:03:53 pq: Ident authentication failed for user "postgres" exit status 1 </code></pre> <p>But I can access postgres:</p> <pre><code>[vagrant@localhost go-postgres]$ psql -U postgres vagrant psql (9.4.4) Type "help" for help. vagrant=# </code></pre> <p>And I don't have any troubles with using Rails app with postgres. </p> <p>Anyone has an idea?</p> <p>EDIT: Here is my pg_hba.conf:</p> <pre><code>local all all trust host all all 127.0.0.1/32 ident host all all ::1/128 ident </code></pre> <p>EDIT2:</p> <p>I found this in my postgres logs:</p> <pre><code>&lt; 2015-12-19 12:13:05.094 UTC &gt;LOG: could not connect to Ident server at address "::1", port 113: Connection refused &lt; 2015-12-19 12:13:05.094 UTC &gt;FATAL: Ident authentication failed for user "postgres" &lt; 2015-12-19 12:13:05.094 UTC &gt;DETAIL: Connection matched pg_hba.conf line 84: "host all all ::1/128 ident" </code></pre> <p>I think it will really help ;)</p> </div>

Postgres pg_delete和“DELETE FROM ...”之间的差异

<div class="post-text" itemprop="text"> <p>PHP: pg_delete : <a href="http://php.net/manual/es/function.pg-delete.php" rel="nofollow noreferrer">http://php.net/manual/es/function.pg-delete.php</a></p> <p>and use: "Delete From . . ."</p> <p>What is the difference between both sequences? wich one is more efficient? ¿Wich one have less probable to get errors?</p> </div>

在中国程序员是青春饭吗?

今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...

技术大佬:我去,你写的 switch 语句也太老土了吧

昨天早上通过远程的方式 review 了两名新来同事的代码,大部分代码都写得很漂亮,严谨的同时注释也很到位,这令我非常满意。但当我看到他们当中有一个人写的 switch 语句时,还是忍不住破口大骂:“我擦,小王,你丫写的 switch 语句也太老土了吧!” 来看看小王写的代码吧,看完不要骂我装逼啊。 private static String createPlayer(PlayerTypes p...

华为初面+综合面试(Java技术面)附上面试题

华为面试整体流程大致分为笔试,性格测试,面试,综合面试,回学校等结果。笔试来说,华为的难度较中等,选择题难度和网易腾讯差不多。最后的代码题,相比下来就简单很多,一共3道题目,前2题很容易就AC,题目已经记不太清楚,不过难度确实不大。最后一题最后提交的代码过了75%的样例,一直没有发现剩下的25%可能存在什么坑。 笔试部分太久远,我就不怎么回忆了。直接将面试。 面试 如果说腾讯的面试是挥金如土...

和黑客斗争的 6 天!

互联网公司工作,很难避免不和黑客们打交道,我呆过的两家互联网公司,几乎每月每天每分钟都有黑客在公司网站上扫描。有的是寻找 Sql 注入的缺口,有的是寻找线上服务器可能存在的漏洞,大部分都...

讲一个程序员如何副业月赚三万的真实故事

loonggg读完需要3分钟速读仅需 1 分钟大家好,我是你们的校长。我之前讲过,这年头,只要肯动脑,肯行动,程序员凭借自己的技术,赚钱的方式还是有很多种的。仅仅靠在公司出卖自己的劳动时...

win10暴力查看wifi密码

刚才邻居打了个电话说:喂小灰,你家wifi的密码是多少,我怎么连不上了。 我。。。 我也忘了哎,就找到了一个好办法,分享给大家: 第一种情况:已经连接上的wifi,怎么知道密码? 打开:控制面板\网络和 Internet\网络连接 然后右击wifi连接的无线网卡,选择状态 然后像下图一样: 第二种情况:前提是我不知道啊,但是我以前知道密码。 此时可以利用dos命令了 1、利用netsh wlan...

上班一个月,后悔当初着急入职的选择了

最近有个老铁,告诉我说,上班一个月,后悔当初着急入职现在公司了。他之前在美图做手机研发,今年美图那边今年也有一波组织优化调整,他是其中一个,在协商离职后,当时捉急找工作上班,因为有房贷供着,不能没有收入来源。所以匆忙选了一家公司,实际上是一个大型外包公司,主要派遣给其他手机厂商做外包项目。**当时承诺待遇还不错,所以就立马入职去上班了。但是后面入职后,发现薪酬待遇这块并不是HR所说那样,那个HR自...

总结了 150 余个神奇网站,你不来瞅瞅吗?

原博客再更新,可能就没了,之后将持续更新本篇博客。

副业收入是我做程序媛的3倍,工作外的B面人生是怎样的?

提到“程序员”,多数人脑海里首先想到的大约是:为人木讷、薪水超高、工作枯燥…… 然而,当离开工作岗位,撕去层层标签,脱下“程序员”这身外套,有的人生动又有趣,马上展现出了完全不同的A/B面人生! 不论是简单的爱好,还是正经的副业,他们都干得同样出色。偶尔,还能和程序员的特质结合,产生奇妙的“化学反应”。 @Charlotte:平日素颜示人,周末美妆博主 大家都以为程序媛也个个不修边幅,但我们也许...

如果你是老板,你会不会踢了这样的员工?

有个好朋友ZS,是技术总监,昨天问我:“有一个老下属,跟了我很多年,做事勤勤恳恳,主动性也很好。但随着公司的发展,他的进步速度,跟不上团队的步伐了,有点...

我入职阿里后,才知道原来简历这么写

私下里,有不少读者问我:“二哥,如何才能写出一份专业的技术简历呢?我总感觉自己写的简历太烂了,所以投了无数份,都石沉大海了。”说实话,我自己好多年没有写过简历了,但我认识的一个同行,他在阿里,给我说了一些他当年写简历的方法论,我感觉太牛逼了,实在是忍不住,就分享了出来,希望能够帮助到你。 01、简历的本质 作为简历的撰写者,你必须要搞清楚一点,简历的本质是什么,它就是为了来销售你的价值主张的。往深...

带了6个月的徒弟当了面试官,而身为高级工程师的我天天修Bug......

即将毕业的应届毕业生一枚,现在只拿到了两家offer,但最近听到一些消息,其中一个offer,我这个组据说客户很少,很有可能整组被裁掉。 想问大家: 如果我刚入职这个组就被裁了怎么办呢? 大家都是什么时候知道自己要被裁了的? 面试软技能指导: BQ/Project/Resume 试听内容: 除了刷题,还有哪些技能是拿到offer不可或缺的要素 如何提升面试软实力:简历, 行为面试,沟通能...

!大部分程序员只会写3年代码

如果世界上都是这种不思进取的软件公司,那别说大部分程序员只会写 3 年代码,恐怕就没有程序员这种职业。

离职半年了,老东家又发 offer,回不回?

有小伙伴问松哥这个问题,他在上海某公司,在离职了几个月后,前公司的领导联系到他,希望他能够返聘回去,他很纠结要不要回去? 俗话说好马不吃回头草,但是这个小伙伴既然感到纠结了,我觉得至少说明了两个问题:1.曾经的公司还不错;2.现在的日子也不是很如意。否则应该就不会纠结了。 老实说,松哥之前也有过类似的经历,今天就来和小伙伴们聊聊回头草到底吃不吃。 首先一个基本观点,就是离职了也没必要和老东家弄的苦...

HTTP与HTTPS的区别

面试官问HTTP与HTTPS的区别,我这样回答让他竖起大拇指!

程序员毕业去大公司好还是小公司好?

虽然大公司并不是人人都能进,但我仍建议还未毕业的同学,尽力地通过校招向大公司挤,但凡挤进去,你这一生会容易很多。 大公司哪里好?没能进大公司怎么办?答案都在这里了,记得帮我点赞哦。 目录: 技术氛围 内部晋升与跳槽 啥也没学会,公司倒闭了? 不同的人脉圈,注定会有不同的结果 没能去大厂怎么办? 一、技术氛围 纵观整个程序员技术领域,哪个在行业有所名气的大牛,不是在大厂? 而且众所...

程序员为什么千万不要瞎努力?

本文作者用对比非常鲜明的两个开发团队的故事,讲解了敏捷开发之道 —— 如果你的团队缺乏统一标准的环境,那么即使勤劳努力,不仅会极其耗时而且成果甚微,使用...

为什么程序员做外包会被瞧不起?

二哥,有个事想询问下您的意见,您觉得应届生值得去外包吗?公司虽然挺大的,中xx,但待遇感觉挺低,马上要报到,挺纠结的。

当HR压你价,说你只值7K,你该怎么回答?

当HR压你价,说你只值7K时,你可以流畅地回答,记住,是流畅,不能犹豫。 礼貌地说:“7K是吗?了解了。嗯~其实我对贵司的面试官印象很好。只不过,现在我的手头上已经有一份11K的offer。来面试,主要也是自己对贵司挺有兴趣的,所以过来看看……”(未完) 这段话主要是陪HR互诈的同时,从公司兴趣,公司职员印象上,都给予对方正面的肯定,既能提升HR的好感度,又能让谈判气氛融洽,为后面的发挥留足空间。...

面试:第十六章:Java中级开发(16k)

HashMap底层实现原理,红黑树,B+树,B树的结构原理 Spring的AOP和IOC是什么?它们常见的使用场景有哪些?Spring事务,事务的属性,传播行为,数据库隔离级别 Spring和SpringMVC,MyBatis以及SpringBoot的注解分别有哪些?SpringMVC的工作原理,SpringBoot框架的优点,MyBatis框架的优点 SpringCould组件有哪些,他们...

面试阿里p7,被按在地上摩擦,鬼知道我经历了什么?

面试阿里p7被问到的问题(当时我只知道第一个):@Conditional是做什么的?@Conditional多个条件是什么逻辑关系?条件判断在什么时候执...

终于懂了TCP和UDP协议区别

终于懂了TCP和UDP协议区别

Python爬虫,高清美图我全都要(彼岸桌面壁纸)

爬取彼岸桌面网站较为简单,用到了requests、lxml、Beautiful Soup4

无代码时代来临,程序员如何保住饭碗?

编程语言层出不穷,从最初的机器语言到如今2500种以上的高级语言,程序员们大呼“学到头秃”。程序员一边面临编程语言不断推陈出新,一边面临由于许多代码已存在,程序员编写新应用程序时存在重复“搬砖”的现象。 无代码/低代码编程应运而生。无代码/低代码是一种创建应用的方法,它可以让开发者使用最少的编码知识来快速开发应用程序。开发者通过图形界面中,可视化建模来组装和配置应用程序。这样一来,开发者直...

面试了一个 31 岁程序员,让我有所触动,30岁以上的程序员该何去何从?

最近面试了一个31岁8年经验的程序猿,让我有点感慨,大龄程序猿该何去何从。

大三实习生,字节跳动面经分享,已拿Offer

说实话,自己的算法,我一个不会,太难了吧

程序员垃圾简历长什么样?

已经连续五年参加大厂校招、社招的技术面试工作,简历看的不下于万份 这篇文章会用实例告诉你,什么是差的程序员简历! 疫情快要结束了,各个公司也都开始春招了,作为即将红遍大江南北的新晋UP主,那当然要为小伙伴们做点事(手动狗头)。 就在公众号里公开征简历,义务帮大家看,并一一点评。《启舰:春招在即,义务帮大家看看简历吧》 一石激起千层浪,三天收到两百多封简历。 花光了两个星期的所有空闲时...

美团面试,问了ThreadLocal原理,这个回答让我通过了

他想都想不到,ThreadLocal我烂熟于心

大牛都会用的IDEA调试技巧!!!

导读 前天面试了一个985高校的实习生,问了他平时用什么开发工具,他想也没想的说IDEA,于是我抛砖引玉的问了一下IDEA的调试用过吧,你说说怎么设置断点...

面试官:你连SSO都不懂,就别来面试了

大厂竟然要考我SSO,卧槽。

立即提问
相关内容推荐