python Django调用数据库出错

显示没有backens.mysql模块,手动调用backens也显示没有,但很明显是有这个文件的
调用Django其他模块没问题,说明路径没问题。
我在stackoverflow等网站上看的是说我的版本有问题,但不知道是python版本还是Django版本,我的python必须要用2.7(服务器要求)
数据库配置没问题。
问题1
问题
求大牛指导解决方法

4个回答

你使用django的话默认是要求使用ORM框架的。你的mysql数据需要提供api才能够使用django的ORM框架。所以请确保你按照了

 pip install mysql-python

已安装。
应该不是这里的问题。好像是版本不匹配。不知道怎么解决

图片说明
这个已经装了,那个报错不是正确的报错,I see the wrong error message.
The True problem is about version!!!

哦,发现哪错了,我误把backends写成了backens
谢谢热心帮助。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!