q296264785
二克拉梦想
2016-12-14 08:16
采纳率: 50%
浏览 5.6k

android studio 编译的app在4.4.4版本的安卓手机上运行不了?

我在 abdroid studio上编译的app,在模拟器上可以正常运行,下载到手机上一打开闪一下就关闭了,也不报错什么的。

这是app的编译配置:

 android {
    compileSdkVersion 24
    buildToolsVersion "25.0.1"
    defaultConfig {
        applicationId "com.example.administrator.class_fragmenttest"
        minSdkVersion 14
        targetSdkVersion 24
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }

手机版本信息
图片说明

,我把手机换成5.5的Android就可以运行了。问题是我设置的最低兼容的api版本是14 ,应该能在4.4的android上运行才对的。哪位大神知道是什么原因不? 代码里面什么都没有写,只有studio自动生成的 hello android!这个程序都不能在4.4的手机上运行

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

9条回答 默认 最新

  • github_37039460
    KLUAS 2016-12-14 08:17

    试试android manefest文件夹下有个minVersion,改了,还有就是properties文件夹里的android=“”改一下android的版本,降低

    点赞 评论
  • dsxjinzhiqiang
    dsxjinzhiqiang 2016-12-14 08:23

    版本太低了,将项目的最大版本设置成android6.0

    点赞 评论
  • as_csdn
    代码的灵魂是bug! 2016-12-14 12:50

    把这个buildToolsVersion "25.0.1"改成24.0.1试试

    点赞 评论
  • a1021508536
    花重锦官城 2016-12-15 06:04

    不知道是不是studio2.2 之前用的2.2编译的有问题,也是报错,后来换了2.0

    点赞 评论
  • codbking
    codbking 2016-12-16 05:18

    1 你先确定手机里面有没有安装包名相同的软件?用adb shell list package,2再看看控制台报的什么错误

    点赞 评论
  • qq_16826631
    Fantasy_苦笑 2017-02-28 01:40

    楼主这个问题解决了吗?

    点赞 评论
  • m0_37707016
    m0_37707016 2017-03-08 08:05

    楼主 问题解决没有 ,我也遇见了这样的问题, 求分享啊

    点赞 评论
  • Gfuye
    口十子i 2017-03-21 08:43

    也遇到这个问题。比较急,楼主怎么解决了的呢?

    点赞 评论
  • turingroot
    chen54264 2017-06-13 01:26

    同样碰到了这个问题,请问,楼主解决了没有啊?!

    点赞 评论

相关推荐