myeclipse连接sqlserver2008r2

抛出错误显示:此驱动程序不支持jre1.8版,请使用支持JDBC4.0的sqljdbc4.jar类库。我用的是sqljdbc4.0。求解。谢谢!

1个回答

jdk版本太高了,不对应.
参考微软官方文档http://www.microsoft.com/zh-cn/download/details.aspx?id=11774

有如下说明:
• Sqljdbc.jar 需要 JRE 5 并支持 JDBC 3.0 API
• Sqljdbc4.jar 需要 JRE 6 并支持 JDBC 4.0 API
• Sqljdbc41.jar 需要 JRE 7 并支持 JDBC 4.1 API
• Sqljdbc42.jar 需要 JRE 8 并支持 JDBC 4.2 API

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问